B&W 703 Woofer Spots - AVS Forum
Forum Jump: 
 
Thread Tools
Old 01-13-2014, 04:04 PM - Thread Starter
Senior Member
 
mariokrt64's Avatar
 
Join Date: Jul 2008
Posts: 477
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 13
My 703 have develop several spots on the black woofers.....To me it looks like some kind of "fungus" may be developing on the cone surface....I tried to remove with a very gentle brush but did not worked....Is there anyway to remove this "spots". I checked in the B&W site and the replacement drivers are $162.18 plus shipping ea.....so I am trying to avoid replacing them. I need to try something since this appears to be getting worse since last time I checked a couple of months ago......

Help is appreciatted very much.....
mariokrt64 is offline  
Sponsored Links
Advertisement
 
Old 01-21-2014, 09:58 AM - Thread Starter
Senior Member
 
mariokrt64's Avatar
 
Join Date: Jul 2008
Posts: 477
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 13
I don't think I am the first to run into this problem....Anyone cares to comment on potential tricks to address this issue....?

Thanks....
mariokrt64 is offline  
Old 01-22-2014, 09:27 PM - Thread Starter
Senior Member
 
mariokrt64's Avatar
 
Join Date: Jul 2008
Posts: 477
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 13
I am not sure would be able to sell them with those spots....I may try on of those "athlete feet" aerosols since they the aerosol is very volatile and hopefully won't wet the cone....though it may be a different fungus it may help....thks for your feedback...
mariokrt64 is offline  
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off