I thought it was my Mission, and it was.... - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 9 Old 02-10-2014, 12:00 PM - Thread Starter
Member
 
jeffG70's Avatar
 
Join Date: Dec 2002
Location: Clinton Township, Michigan
Posts: 125
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I put my G70 up on the ceiling 5 years ago and never fired it up. I went digital and took it down this weekend. I found my old Mission speakers four 781s 1 78c and two 78ds which have been on a shelf well protected for 7 years. I hooked them up and didn't hear any bass. I looked at the drivers and saw the leaking problem. How can I confirm that other drivers are working? Should I just use the ear test or a multimeter? I took the drivers out of one cabinet and connected them to the leads directly bypassing the crossover to see if I heard anything. Should I just throw all of these away and start over or find some woofers to replace the damaged ones?

Thanks,
Jeff
jeffG70 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 02-12-2014, 05:41 AM
Member
 
Blacklightning's Avatar
 
Join Date: Jan 2006
Location: Edmonton,AB Canada
Posts: 158
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 36 Post(s)
Liked: 33
Those are a nice set of speakers you have there. I think it all comes down to money or effort. speakers equal to what you have will be pricey but finding woofers from Missions good years will be hard. You might have better luck finding 78?'s on the used market.

in any case test all the speakers to see how many you need to replace. Maybe you will only need to replace 2 and you could find some 782 or 783 towers.
Blacklightning is offline  
post #3 of 9 Old 02-12-2014, 08:53 AM - Thread Starter
Member
 
jeffG70's Avatar
 
Join Date: Dec 2002
Location: Clinton Township, Michigan
Posts: 125
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Mission told me I could get new ones.... says they are probably of better quality since they are newer, for about $97.00 each. She never heard of the ferrofluid problem. If she searched she would know. The site didn't have the US as an option for country of inquiry. I had to use Canada to be able to send the message. Maybe that's a problem too. I know that the 4 781 are all bad. The surrounds doesn't have anything but high frequency as does the center. I think everything you see that isn't a tweeter is bad in that photo. It's a little sad.
jeffG70 is offline  
post #4 of 9 Old 02-12-2014, 01:33 PM
Member
 
Blacklightning's Avatar
 
Join Date: Jan 2006
Location: Edmonton,AB Canada
Posts: 158
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 36 Post(s)
Liked: 33
You now have me worried about my Missions in storage. They are indoors about exposed to -30 temperatures. frown.gif

I may be hunting for new 2 channel speakers.

I'm thinking Martin Logan's or another folded tweeter speaker. I love my missions but they really are the only speakers I have really listened to.
Blacklightning is offline  
post #5 of 9 Old 02-12-2014, 02:34 PM
AVS Special Member
 
commsysman's Avatar
 
Join Date: Dec 2007
Location: Southern California
Posts: 5,282
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 130 Post(s)
Liked: 256
Those were not really very good-sounding speakers when they were new.

Trying to restore them is flogging a dead horse.

Put your money into some nice KEF, PSB, Focal or Wharfedale speakers, which will will sound way better than they ever did or will.
commsysman is offline  
post #6 of 9 Old 02-14-2014, 08:18 AM - Thread Starter
Member
 
jeffG70's Avatar
 
Join Date: Dec 2002
Location: Clinton Township, Michigan
Posts: 125
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
That's what I was thinking. They were a bit on the harsh side as I remember. I had Wharfdales and left them in my home theater when I sold my house and kept these. I made a mistake there. I guess they go out the the curb. I noticed the structure of the encloser inside is pretty complicated. I wish they put as much thought into the drivers as they did the design of the box.
jeffG70 is offline  
post #7 of 9 Old 04-03-2014, 07:06 AM - Thread Starter
Member
 
jeffG70's Avatar
 
Join Date: Dec 2002
Location: Clinton Township, Michigan
Posts: 125
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I think I found the real reason EVERY driver in this batch of speakers failed. How are is it to replace the lead wires? It might be worth a try.
jeffG70 is offline  
post #8 of 9 Old 04-03-2014, 07:20 AM
Member
 
Blacklightning's Avatar
 
Join Date: Jan 2006
Location: Edmonton,AB Canada
Posts: 158
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 36 Post(s)
Liked: 33
Did you try connecting the wires directly to the speaker?
if that works, I think replacing that wire will be easy...

The real question is why did that happen to every speaker?
Blacklightning is offline  
post #9 of 9 Old 07-15-2014, 09:35 AM
Newbie
 
Join Date: Jul 2014
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
Hi jeffG70,

Wondering if you had any joy with the repair?

I just (perhaps foolishly) picked up a Mission 78c centre channel to go with my existing mission floorstanders from a different range, and am just anticipating facing the same problem as lots of other 78 series owners.

The unit was a bargain, but I'm beginning to wish I Googled it more thoroughly first.
MissionOwner is offline  
Reply Speakers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off