Pioneer SX-205 receiver no power to speakers - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!



Forum Jump: 
 
Thread Tools
Old 04-26-2014, 06:10 PM - Thread Starter
Newbie
 
billymc4215's Avatar
 
Join Date: Apr 2014
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

I just purchased a Pioneer Sx205 receiver at Goodwill for 25.00.It seems to be in good shape but I cant get my speakers to work with it.There is no sound from the speakers at all.No static or anything.I have checked the speaker wire and the speakers and they worked great with my old receiver.What is the problem?

billymc4215 is offline  
Sponsored Links
Advertisement
 
Old 07-18-2014, 08:32 PM
Newbie
 
Join Date: Jul 2014
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
You got a great amp, for starters this should be the schematic: http://diagramas.diagramasde.com/audio/PIONEER_SX205_SX255R.pdf

you might have a different version, just google it, it's easy to find the other one.
I recapped and replaced all the op amps and it is great at 100W a channel.
ivandezande is offline  
Sponsored Links
Advertisement
 
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off