PSB Century subwoofer failure - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 08-01-2014, 04:21 PM - Thread Starter
Member
 
BigO734's Avatar
 
Join Date: Jun 2012
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 12
PSB Century subwoofer failure

After many years of trouble free use, my Century Subsonic 2i has failed. The green LED light comes on but no sound is being output. I fear the amp has died. I checked the fuse and it's still good. I called PSB and they can sell me a replacement amp for $469, the cost of a brand new sub. Any suggestions? I considered buying a plate amp from PE but not sure about that. Comments, suggestions would be appreciated.
Thanks.
BigO734 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-01-2014, 04:32 PM
Member
 
curtissp's Avatar
 
Join Date: Jun 2014
Posts: 82
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 72 Post(s)
Liked: 3
Quote:
Originally Posted by BigO734 View Post
After many years of trouble free use, my Century Subsonic 2i has failed. The green LED light comes on but no sound is being output. I fear the amp has died. I checked the fuse and it's still good. I called PSB and they can sell me a replacement amp for $469, the cost of a brand new sub. Any suggestions? I considered buying a plate amp from PE but not sure about that. Comments, suggestions would be appreciated.
Thanks.
Sounds like a fried amp to me.. I'd take out the sub and test it first if it's fine.. I'd go buy a different amp on Parts express. $469 is quite high.
curtissp is offline  
post #3 of 3 Old 10-12-2014, 05:36 AM - Thread Starter
Member
 
BigO734's Avatar
 
Join Date: Jun 2012
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 12
I did just that. There was no way I was going to pay that much for just an amp. Went to PE and purchased a Dayton Audio plate amp. I had to make some modifications to the sub box but after that this new amp works just fine. Re-calibrated the system and I am now back up and running...except for new issue with PSB speaker tweeter (new post about that issue).
BigO734 is offline  
Reply Speakers

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off