Wharfedale Diamond 9.1 - Tear in midrange membrane - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 1 Old 08-04-2014, 04:52 AM - Thread Starter
Newbie
 
Join Date: Aug 2014
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
Wharfedale Diamond 9.1 - Tear in midrange membrane

Hello all,

I own a stereo setup consists of a Yamaha RX-V563 receiver and a pair of Wharfedale Diamond 9.1

About a month ago, the membrane around one of the speakers got torn.

While waiting for it to return from fixing, about a week ago, the other speaker's membrane got torn as well.

I fear that there's something causing it to tear.
I'm afraid of plugging the fixed speaker to the receiver again,

I'll describe the environment surrounding the speakers.
Hopefully you could direct me to the problem.

* The membrane was not dry and still soft.
* The speakers are 6 years old.
* I don't use it with high volume, -25db tops.
* The speakers are located near the air output vent of my air conditioner. Lately it's on most of the day.
* The electricity infrastructure of my home is rather old.
* The receiver, PC, and A/C are connected to the same electricity outlet using a splitter.
* The speakers is not exposed to sunlight.
* The speakers are connected to the receiver with cheap 2.5 mm cables.

I would appreciate your help,
Thanks a lot,
Ran.
ranash is offline  
Reply Speakers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off