Paradigm Owners Thread - Page 1153 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 948Likes
Reply
 
Thread Tools
post #34561 of 34585 Old 06-08-2017, 03:43 PM
Newbie
 
Bwats's Avatar
 
Join Date: Jun 2013
Location: New York City
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 0
Signature S8 distortion?

Hey guys finally taking my home theater hobby seriously and putting together a dedicated home theater room. I'm looking for some insight. I currently own a pair of Signature S8s. Which are part of a home theater setup of all signature series speakers. The S8s are being powered by a Parasound A21, processor is an Integra dhc-80.3. I prefer watching movies at near reference level ( -9db )... I'm getting a slight distortion from the tweeters on certain movies (Lord of the Rings Mines of Moria scene, Tron Legacy stadium scene where he's introduced as a User). I'm a little frustrated because the S8s were part of Paradigm's Flagship line of speakers not to long ago and should be able to handle reference level sound. Is there an adjustment I can make on the Preamp? figured I'd ask before messing with it. I already ran the Audyssey setup still hearing the distortion, or could it be my room's acoustics being that I haven't treated it for acoustics yet. Thanks in advance.
Bwats is offline  
Sponsored Links
Advertisement
 
post #34562 of 34585 Old 06-08-2017, 04:08 PM
Senior Member
 
leadliner's Avatar
 
Join Date: Dec 2007
Location: West Chester, Pennsylvania
Posts: 218
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 16
Quote:
Originally Posted by Bwats View Post
Hey guys finally taking my home theater hobby seriously and putting together a dedicated home theater room. I'm looking for some insight. I currently own a pair of Signature S8s. Which are part of a home theater setup of all signature series speakers. The S8s are being powered by a Parasound A21, processor is an Integra dhc-80.3. I prefer watching movies at near reference level ( -9db )... I'm getting a slight distortion from the tweeters on certain movies (Lord of the Rings Mines of Moria scene, Tron Legacy stadium scene where he's introduced as a User). I'm a little frustrated because the S8s were part of Paradigm's Flagship line of speakers not to long ago and should be able to handle reference level sound. Is there an adjustment I can make on the Preamp? figured I'd ask before messing with it. I already ran the Audyssey setup still hearing the distortion, or could it be my room's acoustics being that I haven't treated it for acoustics yet. Thanks in advance.
go into the bluray player and adjust the dynamic rang. also in audyssey you should be able to make an adjustment that softens the treble .
leadliner is online now  
post #34563 of 34585 Old 06-09-2017, 12:57 PM
Advanced Member
 
decibels's Avatar
 
Join Date: Oct 2014
Location: Vancouver
Posts: 642
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 372 Post(s)
Liked: 156
Has anyone used Studio 20's as Atmos speakers? Is there any reason why they would not work?

I am thinking of switching from a 7.1 to 5.2 system and use the 20's as my front heights.

My humble yet growing like weeds SACD collection

HT: Anthem AVM60, Anthem MCA 50, Anthem PVA 7, Oppo BDP-103, Sony HAP-Z1ES, PS3, Graham Slee ULDE, Graham Slee ERA Gold V, Pioneer PL 518 turntable
SP: Paradigm Studio 100's, CC 690, Studio 20's SR, Studio 20's SB, SVS SB13 Plus
decibels is offline  
 
post #34564 of 34585 Old 06-09-2017, 01:15 PM
Newbie
 
Bwats's Avatar
 
Join Date: Jun 2013
Location: New York City
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 0
Quote:
Originally Posted by leadliner View Post
go into the bluray player and adjust the dynamic rang. also in audyssey you should be able to make an adjustment that softens the treble .
Thank you. Will try it out this weekend.
Bwats is offline  
post #34565 of 34585 Old 06-14-2017, 03:50 PM
Member
 
leeshanok's Avatar
 
Join Date: Jul 2007
Location: Atlanta
Posts: 138
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 65 Post(s)
Liked: 33
Quote:
Originally Posted by Bwats View Post
Hey guys finally taking my home theater hobby seriously and putting together a dedicated home theater room. I'm looking for some insight. I currently own a pair of Signature S8s. Which are part of a home theater setup of all signature series speakers. The S8s are being powered by a Parasound A21, processor is an Integra dhc-80.3. I prefer watching movies at near reference level ( -9db )... I'm getting a slight distortion from the tweeters on certain movies (Lord of the Rings Mines of Moria scene, Tron Legacy stadium scene where he's introduced as a User). I'm a little frustrated because the S8s were part of Paradigm's Flagship line of speakers not to long ago and should be able to handle reference level sound. Is there an adjustment I can make on the Preamp? figured I'd ask before messing with it. I already ran the Audyssey setup still hearing the distortion, or could it be my room's acoustics being that I haven't treated it for acoustics yet. Thanks in advance.
Paradigm lists the S8s as handling suitable amplifier power range between 15 and 500 watts. Your A21 is rated at 250 watts/ch so not a problem for the S8s. By the way, I have a set of S8v3 with Classe CAM600 mono blocks (600 watts/ch) and have no problem whatsoever. Also, I have a set of S6v3 in another setup with Parasound A51 and sounds clean as a whistle.
leeshanok is offline  
post #34566 of 34585 Old 06-14-2017, 04:27 PM
Member
 
visionik's Avatar
 
Join Date: Jan 2003
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 10
Paradigm Tribute 30th Anniversary Speakers

Hi All -

I am the very fortunate owner of a pair of Paradigm Tribute 30th Anniversary speakers - they are at our property in California. I love them. Just beautiful.

I have been searching for a second pair of these speakers for almost three years now for our home in Florida.

I finally found a second pair a few weeks ago via eBay in Germany. The speakers were listed wit "make an offer" on eBay. I made an offer and we agreed on the price. The final price was just about right for what they are.

I have eagerly been awaiting the arrival of these speakers for the last two weeks as they shipped from Germany to the US.

Unfortunately, their are two big problems:

1. The speakers are missing parts (plinths) and were damaged (snapped terminals), perhaps in shipping.

2. More significantly: All serial numbers I can find have been removed from the speakers. They were shipped in original Paradigm boxes, but the serial numbers were removed from both the boxes and from the backs of the speakers.

So in short, their is a good chance they were stolen.

I believe only 200 pairs of these speakers were made. I know it's remote, but I thought I'd ask - does anyone know of a pair of stolen Tributes in Europe? I am filing police reports in the US and Germany, and would like to get these back to the rightful owner if at all possible.

Best,

-Visionik
visionik is offline  
post #34567 of 34585 Old 06-14-2017, 04:52 PM
AVS Forum Special Member
 
Jonas2's Avatar
 
Join Date: May 2015
Location: South Bay Area
Posts: 2,194
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Quoted: 1149 Post(s)
Liked: 423
Quote:
Originally Posted by visionik View Post

2. More significantly: All serial numbers I can find have been removed from the speakers. They were shipped in original Paradigm boxes, but the serial numbers were removed from both the boxes and from the backs of the speakers.

So in short, their is a good chance they were stolen.

I believe only 200 pairs of these speakers were made. I know it's remote, but I thought I'd ask - does anyone know of a pair of stolen Tributes in Europe? I am filing police reports in the US and Germany, and would like to get these back to the rightful owner if at all possible.

Best,

-Visionik
That is somewhat suspicious, isn't it? Have you alerted eBay? I wonder if Paradigm could give you some advice; they might know where originals went in Europe - perhaps not owners, but the resellers. I wonder if the drivers have serial#s matched to the speakers, and if that could be a lead..... Very interesting though, keep us posted if you don't mind!

5.2.4 System....Display: Sony XBR-65X930D; Processing: Anthem AVM60; Power Distribution: Panamax M5400-PM;
Mains:
Paradigm 85F and 55C (Piano Black); Side Surrounds: Totem Acoustic Tribe III (Dusk); Amplification: D-Sonic M3-2800-7 (7ch. x 400w);
ATMOS:
Definitive Technology DI8R; Amplification: Class D Audio SDS-470C (4ch. x 300w)
Subwoofers:
2 x SVS-SB13Ultras; Media: Oppo UDP-203, Sony BDP S-470, Pioneer CLD-59
Jonas2 is offline  
post #34568 of 34585 Old 06-14-2017, 06:31 PM
Member
 
LarryF's Avatar
 
Join Date: Jan 2006
Posts: 32
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Liked: 8
^^

I just noticed a pair of those speakers for sale on audiogon.com if anyone is still looking for them. I have no connection to the seller, but thought I should point them out in case anyone here is interested.

Larry
LarryF is online now  
post #34569 of 34585 Old 06-14-2017, 06:32 PM
Member
 
visionik's Avatar
 
Join Date: Jan 2003
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 10
Quote:
Originally Posted by Jonas2 View Post
That is somewhat suspicious, isn't it? Have you alerted eBay? I wonder if Paradigm could give you some advice; they might know where originals went in Europe - perhaps not owners, but the resellers. I wonder if the drivers have serial#s matched to the speakers, and if that could be a lead..... Very interesting though, keep us posted if you don't mind!
Yes, I have opened a return case with eBay. Basically I'm doing three things in parallel.

1. Getting my money back via eBay

2. Filing police reports in the US and Germany disclosing that I believe I have stolen goods

3. Working to find the possible rightful owner of these speakers, so that when they are returned the German police can take possession of them and hold them for that rightful owner.

It's always possible that I bought them from a legitimate owner who removed the serial numbers because of some delusional paranoia or other issue that I just completely don't understand. But a very likely answer is unfortunately that they are stolen.

-Visionik
visionik is offline  
post #34570 of 34585 Old 06-15-2017, 05:40 PM
Member
 
Join Date: Nov 2016
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 1
I've got a pair of 75W's that I paid with an AV7702 and an XPA3 - looking to finish off the setup with a new sub (looking for an SVS SB 13 Ultra)
rwarederek is offline  
post #34571 of 34585 Old 06-15-2017, 06:38 PM
AVS Forum Special Member
 
grasshoppers's Avatar
 
Join Date: Dec 2008
Location: aridzona
Posts: 3,451
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 846 Post(s)
Liked: 538
Quote:
Originally Posted by rwarederek View Post
I've got a pair of 75W's that I paid with an AV7702 and an XPA3 - looking to finish off the setup with a new sub (looking for an SVS SB 13 Ultra)
You should also check out Rythmik subwoofers too.

Anthem MRX-300-Outlaw Audio M2200
Rythmik F12 subs
Paradigm Signature S6,C1,S1
Harman Kardon DMC1000 (music)
Assassin HTPC (movies)
grasshoppers is online now  
post #34572 of 34585 Old 06-15-2017, 07:08 PM
Senior Member
 
whitey019's Avatar
 
Join Date: Jan 2007
Location: Maryland
Posts: 323
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 107 Post(s)
Liked: 69
Quote:
Originally Posted by rwarederek View Post
I've got a pair of 75W's that I paid with an AV7702 and an XPA3 - looking to finish off the setup with a new sub (looking for an SVS SB 13 Ultra)
I recommend you look at SVS's outlet. Might even be able to go to a SB 16 Ultra. I have a SB 13 ultra and the outlet is very tempting.
whitey019 is online now  
post #34573 of 34585 Old 06-15-2017, 08:09 PM
Member
 
Join Date: Jul 2015
Posts: 58
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 31 Post(s)
Liked: 1
IN Wall

Have a Denon 7200wa with two Paradigm Servo 15 subs. I have want to go with a 7.2.4 system in a 12x12 room/basement. What Paradigm In walls would you recommend? What Atmos would you recommend with this set up also. I know the SA LCR is an old line for Paradigm, are they any good?
Glewis34 is offline  
post #34574 of 34585 Old 06-15-2017, 09:17 PM
Member
 
Join Date: Nov 2016
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 1
Quote:
Originally Posted by grasshoppers View Post
You should also check out Rythmik subwoofers too.
How would you compare those to the SB13 Ultra? I really like the form factor for the performance of the 13 - anything bigger would take up too much space.
rwarederek is offline  
post #34575 of 34585 Old 06-16-2017, 11:11 AM
Member
 
Join Date: Sep 2016
Posts: 117
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 60 Post(s)
Liked: 4
Anyone running phantom v3's ?

I have picked up a couple from someone for my garage setup and they are loud but seems like im turning up the receiver to like 85 for them to be pretty loud

receiver is denon avr-s500bt

are these phantom v3's damaged ? blown ?
adamf4i7783 is offline  
post #34576 of 34585 Old 06-16-2017, 04:36 PM
Senior Member
 
Invader3's Avatar
 
Join Date: Apr 2004
Location: Wisconsin
Posts: 339
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
Liked: 20
Hey everyone. I've had a pair of Paradigm Monitor 9s for several years that are still great speakers. Recently, we replaced the carpet in our living room with wood floors. These speakers have carpet spikes, and I'm hoping to replace the spikes with some type of feet so they don't scratch the wood flooring. Any ideas on what I can use? I've been to two local hardware stores and can't find anything that fits the bill.

Thanks!
Invader3 is offline  
post #34577 of 34585 Old 06-17-2017, 04:38 AM
Member
 
Join Date: Aug 2016
Posts: 69
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 46 Post(s)
Liked: 5
Quote:
Originally Posted by Invader3 View Post
These speakers have carpet spikes, and I'm hoping to replace the spikes with some type of feet so they don't scratch the wood flooring.
The spikes just unscrew.

You don't need anything on wood. The reason for the spikes it to get through the carpet to the solid subfloor.

Use some thin felt if you are worried about scratching the floor/speakers.
Just cut a piece to match the speaker base.
ST Dog is offline  
post #34578 of 34585 Old 06-17-2017, 05:52 AM
Senior Member
 
Invader3's Avatar
 
Join Date: Apr 2004
Location: Wisconsin
Posts: 339
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
Liked: 20
Quote:
Originally Posted by ST Dog View Post
The spikes just unscrew.

You don't need anything on wood. The reason for the spikes it to get through the carpet to the solid subfloor.

Use some thin felt if you are worried about scratching the floor/speakers.
Just cut a piece to match the speaker base.
Felt is a good idea. I will probably try that.
Invader3 is offline  
post #34579 of 34585 Old 06-17-2017, 12:49 PM
AVS Forum Special Member
 
Jonas2's Avatar
 
Join Date: May 2015
Location: South Bay Area
Posts: 2,194
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Quoted: 1149 Post(s)
Liked: 423
Quote:
Originally Posted by Invader3 View Post
Felt is a good idea. I will probably try that.
They make discs of varying diameters with a sticky back, you could look for something like that.

5.2.4 System....Display: Sony XBR-65X930D; Processing: Anthem AVM60; Power Distribution: Panamax M5400-PM;
Mains:
Paradigm 85F and 55C (Piano Black); Side Surrounds: Totem Acoustic Tribe III (Dusk); Amplification: D-Sonic M3-2800-7 (7ch. x 400w);
ATMOS:
Definitive Technology DI8R; Amplification: Class D Audio SDS-470C (4ch. x 300w)
Subwoofers:
2 x SVS-SB13Ultras; Media: Oppo UDP-203, Sony BDP S-470, Pioneer CLD-59
Jonas2 is offline  
post #34580 of 34585 Old Today, 11:25 AM
AVS Forum Special Member
 
tjcinnamon's Avatar
 
Join Date: Jul 2008
Posts: 1,669
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 1046 Post(s)
Liked: 251
Hi All,

I'm getting some distortion in my Prestige F75's. I have the post here outlining the scenario and tools at my disposal. Any help appreciated.

*Official* Marantz 2015 NR-1506/1606, SR-5010/6010/7010 & AV7702mkII owner's thread

Thanks,
Joe

Marantz 7010 for 7.2.4
2 x Paradigm Prestige 75F's
1 x Paradigm Prestige 45C
8 x Paradigm CI Pro P65-R's
Sub 2 x Rythmik LVX12's
TV: LG 65B6
tjcinnamon is online now  
post #34581 of 34585 Old Today, 12:09 PM
AVS Forum Special Member
 
tjcinnamon's Avatar
 
Join Date: Jul 2008
Posts: 1,669
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 1046 Post(s)
Liked: 251
Quote:
Originally Posted by Glewis34 View Post
Have a Denon 7200wa with two Paradigm Servo 15 subs. I have want to go with a 7.2.4 system in a 12x12 room/basement. What Paradigm In walls would you recommend? What Atmos would you recommend with this set up also. I know the SA LCR is an old line for Paradigm, are they any good?
12 x 12 is pretty small for the rears and top rear. I have a 7.2.4 system in a 13 x 22 room. The 13 is the tight part. I have 8 CI Pro's. What are your fronts? The Pro's sound great. However, I think I could have gone with CI Homes. There's not much sound that goes to those speakers. For my rears, I placed those high so they wouldn't be right in the back of me head. Well it turns out they were too close to the top rears. I may try and switch them with an angled CI Home. Based on the fact that it's angled, I may get a further perceived distance based on the hypotenuse.

So I think with a top and surround bed, you could go CI home to save cash. I went CI Pro because I didn't want to risk it but in retrospect I could have. It's only 50 per speaker you save so $400 between the pro and the home... So depending on how budget conscious you are may help make your decision.

How high is your ceiling? That was another factor for me. I have 7' ceilings so the rears and tops are cramped BUT they basically get the same signals especially when upmixed.

Marantz 7010 for 7.2.4
2 x Paradigm Prestige 75F's
1 x Paradigm Prestige 45C
8 x Paradigm CI Pro P65-R's
Sub 2 x Rythmik LVX12's
TV: LG 65B6
tjcinnamon is online now  
post #34582 of 34585 Old Today, 12:59 PM
AVS Forum Special Member
 
Jonas2's Avatar
 
Join Date: May 2015
Location: South Bay Area
Posts: 2,194
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Quoted: 1149 Post(s)
Liked: 423
Quote:
Originally Posted by tjcinnamon View Post
Hi All,

I'm getting some distortion in my Prestige F75's. I have the post here outlining the scenario and tools at my disposal. Any help appreciated.

*Official* Marantz 2015 NR-1506/1606, SR-5010/6010/7010 & AV7702mkII owner's thread

Thanks,
Joe
I wouldn't think so, but I wonder if the receiver is beginning to clip? You mentioned possibly the banana plugs or speaker wire in the other thread - are you able to jiggle the connections around at all when the problem is happening and detect a change? Has this always been the case, or is the problem a more recent development?

5.2.4 System....Display: Sony XBR-65X930D; Processing: Anthem AVM60; Power Distribution: Panamax M5400-PM;
Mains:
Paradigm 85F and 55C (Piano Black); Side Surrounds: Totem Acoustic Tribe III (Dusk); Amplification: D-Sonic M3-2800-7 (7ch. x 400w);
ATMOS:
Definitive Technology DI8R; Amplification: Class D Audio SDS-470C (4ch. x 300w)
Subwoofers:
2 x SVS-SB13Ultras; Media: Oppo UDP-203, Sony BDP S-470, Pioneer CLD-59
Jonas2 is offline  
post #34583 of 34585 Old Today, 01:28 PM
AVS Forum Special Member
 
tjcinnamon's Avatar
 
Join Date: Jul 2008
Posts: 1,669
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 1046 Post(s)
Liked: 251
Quote:
Originally Posted by Jonas2 View Post
I wouldn't think so, but I wonder if the receiver is beginning to clip? You mentioned possibly the banana plugs or speaker wire in the other thread - are you able to jiggle the connections around at all when the problem is happening and detect a change? Has this always been the case, or is the problem a more recent development?
I'll give the connections a jiggle to see. It would be odd that it only happens infrequently and wouldn't be consistent if that were the case. That's certainly the easiest place to start.

The distortion was crackling and noticeable.

Marantz 7010 for 7.2.4
2 x Paradigm Prestige 75F's
1 x Paradigm Prestige 45C
8 x Paradigm CI Pro P65-R's
Sub 2 x Rythmik LVX12's
TV: LG 65B6
tjcinnamon is online now  
post #34584 of 34585 Old Today, 02:14 PM
AVS Forum Special Member
 
Jonas2's Avatar
 
Join Date: May 2015
Location: South Bay Area
Posts: 2,194
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Quoted: 1149 Post(s)
Liked: 423
Quote:
Originally Posted by tjcinnamon View Post
The distortion was crackling and noticeable.
Can it happen at any time, or does it tend to happen after the AVR has been on for a while?

5.2.4 System....Display: Sony XBR-65X930D; Processing: Anthem AVM60; Power Distribution: Panamax M5400-PM;
Mains:
Paradigm 85F and 55C (Piano Black); Side Surrounds: Totem Acoustic Tribe III (Dusk); Amplification: D-Sonic M3-2800-7 (7ch. x 400w);
ATMOS:
Definitive Technology DI8R; Amplification: Class D Audio SDS-470C (4ch. x 300w)
Subwoofers:
2 x SVS-SB13Ultras; Media: Oppo UDP-203, Sony BDP S-470, Pioneer CLD-59
Jonas2 is offline  
post #34585 of 34585 Old Today, 02:17 PM
AVS Forum Special Member
 
tjcinnamon's Avatar
 
Join Date: Jul 2008
Posts: 1,669
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 1046 Post(s)
Liked: 251
Quote:
Originally Posted by Jonas2 View Post
Can it happen at any time, or does it tend to happen after the AVR has been on for a while?
Anytime. I rarely have it on for more than 2 hours at a time.

Marantz 7010 for 7.2.4
2 x Paradigm Prestige 75F's
1 x Paradigm Prestige 45C
8 x Paradigm CI Pro P65-R's
Sub 2 x Rythmik LVX12's
TV: LG 65B6
tjcinnamon is online now  
Sponsored Links
Advertisement
 
Reply Speakers

Tags
Paradigm , Speaker Systems



Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off