Official Anthony Gallo Owners Thread - Page 100 - AVS Forum
Forum Jump: 
 1Likes
Reply
 
Thread Tools
post #2971 of 2978 Old 08-01-2014, 10:22 PM
Member
 
brandtlj's Avatar
 
Join Date: May 2006
Posts: 116
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 17
I'm looking for some help in choosing between satellites for a 2.1 music system.

This will be for a small living room and the speakers will be wall mounted. I'll be bringing my own sub into the mix (a Martin Logan Dynamo 200w) and I'm thinking about an AVR with bass management to drive these (any suggestions?).

I'm leaning towards the A'divas vs the Micro's, but more importantly, I wanted to see if anyone has directly compared the new SE versions to the older Ti versions and seen much of a difference.

The Ti drivers are rated at 88-89db into 8ohms whereas
the SE drivers are rated 85db into 4ohms, which is quite a bit harder to drive.

So, three Q's:

1. What AVR or 2.1 capable amp?
2. Go A'diva's or micros?
3. SE or Ti?

Last edited by brandtlj; 08-02-2014 at 12:13 AM.
brandtlj is offline  
Sponsored Links
Advertisement
 
post #2972 of 2978 Old 08-03-2014, 05:08 PM
Member
 
abalone's Avatar
 
Join Date: Mar 2008
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 20
Quote:
Originally Posted by abalone View Post
Question for anyone with Gallo Strada floor stands. On mine if I tap in the middle of the plastic back cover on top I get a clinky rattle sound. Does yours do that?

For a while now I've been noticing an occasional transient buzzy, almost clipping sound during some loud high frequency passages. Finally the other day it was very noticeable and repeatable during a piano piece. Traced it to that plastic cover. Took them off and bingo, clear as a bell.

Now I'm looking for a fix. Tried putting some memory foam in there to damp it and snug the fit, but it still rattles when I tap it. Any observations or suggestions appreciated.
No one has Strada floor stands?
abalone is offline  
post #2973 of 2978 Old 08-04-2014, 07:30 AM
Member
 
Encom Tron's Avatar
 
Join Date: Dec 2012
Location: Grid
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 11
I have 5 Strada speakers and 2 of them are on floor stands. I have not noticed any buzzing or clipping sound from any of the speakers (or stands) even at high volume peaks during movies.

I suggest contacting Gallo's customer service. Perhaps your plastic cover piece is defective.
Encom Tron is offline  
post #2974 of 2978 Old 08-04-2014, 04:03 PM
Member
 
abalone's Avatar
 
Join Date: Mar 2008
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 20
Quote:
Originally Posted by Encom Tron View Post
I have 5 Strada speakers and 2 of them are on floor stands. I have not noticed any buzzing or clipping sound from any of the speakers (or stands) even at high volume peaks during movies.

I suggest contacting Gallo's customer service. Perhaps your plastic cover piece is defective.
Thanks for the reply. I did contact Gallo and was told the issue would be passed along to Anthony, but so far I haven't heard anything back.

Just curious if you tap in the middle of the plastic cover on the top back of a floor stand, do you get a hollow, plastic, clinky sound? It's really obvious on mine. The buzzy sound during music only happens at certain frequencies and volume, so not surprising it would be rarely heard.

Here's a Dropbox link to a mp3 recording of me tapping on the top of the speaker, the top of the plastic cover, and the middle of the cover: https://www.dropbox.com/s/7zfrf8ipl4...rada_cover.mp3

Last edited by abalone; 08-04-2014 at 04:48 PM.
abalone is offline  
post #2975 of 2978 Old 08-04-2014, 05:37 PM
Member
 
Encom Tron's Avatar
 
Join Date: Dec 2012
Location: Grid
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 11
I played your .mp3 file through my iPhone while tapping (using a fingernail) the same areas of the speaker and stand as you recorded. Your recorded sounds were much worse than the sounds I was generating.

Something does not seem right. Either they changed the design of the cover piece or the supplier decided to cut some costs (probably without authorization from Gallo) and built a bad batch.

If the backs of the speaker stands are not visible, if I were you, I'd remove the plastic cover pieces until Gallo comes up with a fix.
Encom Tron is offline  
post #2976 of 2978 Old 08-04-2014, 06:04 PM
Member
 
abalone's Avatar
 
Join Date: Mar 2008
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 20
Quote:
Originally Posted by Encom Tron View Post
I played your .mp3 file through my iPhone while tapping (using a fingernail) the same areas of the speaker and stand as you recorded. Your recorded sounds were much worse than the sounds I was generating.

Something does not seem right. Either they changed the design of the cover piece or the supplier decided to cut some costs (probably without authorization from Gallo) and built a bad batch.

If the backs of the speaker stands are not visible, if I were you, I'd remove the plastic cover pieces until Gallo comes up with a fix.
Thanks for that info. I've had the covers off since I discovered they were causing the buzzing. But the backs are visible so I'd like to find a fix. I'll update if I get an answer from Gallo.
abalone is offline  
post #2977 of 2978 Old 08-30-2014, 09:08 PM
Newbie
 
Join Date: Aug 2014
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
I've had the ref 3.1's for about 5yrs now and been driving them with a Cambridge Audio Azur 640R. A week ago the receiver was done in by a lightning strike. After researching a replacement I decided to purchase a Krell s300i integrated. I would like to hear from anyone who has experienced this combination or even a similar Krell amp. Thanx in advance.
beavbomb is offline  
post #2978 of 2978 Old Yesterday, 08:27 PM
Member
 
tronic307's Avatar
 
Join Date: Apr 2006
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 10
Quote:
Originally Posted by abalone View Post
No one has Strada floor stands?
That happened to me on loud piano with the bookshelf stands. Some double-sided tape between the speakers and the mounting plate fixed it.
tronic307 is offline  
Reply Speakers

Tags
Anthony Gallo Acoustics , Anthony Gallo Acoustics Tr 3d , Anthony Gallo Acoustics Nucleus Reference 3 5 , Yamaha , Sony , Pioneer Elite , Pioneer Elite 49 Txi Receiver

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off