Help with the preamp stage of my receiver? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 01-08-2009, 11:25 PM - Thread Starter
Member
 
Illah's Avatar
 
Join Date: Jun 2004
Location: San Francisco
Posts: 182
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
This is sort of a DIY fix question, hopefully this is the right place to post it.

Basically one channel of my receiver developed a very noticeable hiss. My troubleshooting puts it in the preamp stage.

I've actually built small, simple amps in my day, but never worked on anything like a modern receiver. Since my troubleshooting put the problem in the preamp, I don't think that would involve any of the more complex electronics like the DAC and whatnot. So in theory, if it's just a problem with a burnt capacitor or opamp I might be able to fix it myself.

I already used this issue as an excuse to upgrade, and my warranty is long expired, so I'm willing to risk messing it up

--Illah
Illah is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 01-09-2009, 02:59 AM
 
hdblu's Avatar
 
Join Date: Jun 2007
Location: Sydney
Posts: 1,073
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
On what receiver you have depends to Me I do not think you can fix it your self, They are to complex. I would not take the risk, But if it out of warranty all you can do is try But if you try you will most likely make it worse.
hdblu is offline  
Reply Receivers, Amps, and Processors

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off