Denon 1709 not working with my PS3 properly! Help! - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 5 Old 11-18-2009, 02:32 PM - Thread Starter
Newbie
 
lencholamas's Avatar
 
Join Date: Nov 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have my ps3 hooked up to my denon 1709 via HDMI and optical cable. For some reason when using the ps3 for videos/games, the screen goes in and out meaning there is a fuzzy gray screen or a screen that says "mode not supported" for a second or two and then goes back to showing the video. This happens pretty frequently especially when playing video games (every 5 seconds or so). I swapped HDMI cables and nothing changed. And the audio is fine.

I called denon support up and they had me connect the ps3 directly to the TV and it worked fine (I already knew this). They also made me do a factory reset on the receiver and nothing changed. They then told me to bring it into a denon service center which I did. The service center folks told me that denon told them it isn't a receiver issue but rather a ps3 compatibility issue and I should call Sony to ask them if they have a fix or software patch or something. I can see this turning into a blame game! Can anyone help me?
lencholamas is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 11-18-2009, 02:51 PM
 
googlegod's Avatar
 
Join Date: Nov 2008
Posts: 1,387
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by lencholamas View Post

I have my ps3 hooked up to my denon 1709 via HDMI and optical cable. For some reason when using the ps3 for videos/games, the screen goes in and out meaning there is a fuzzy gray screen or a screen that says "mode not supported" for a second or two and then goes back to showing the video. This happens pretty frequently especially when playing video games (every 5 seconds or so). I swapped HDMI cables and nothing changed. And the audio is fine.

I called denon support up and they had me connect the ps3 directly to the TV and it worked fine (I already knew this). They also made me do a factory reset on the receiver and nothing changed. They then told me to bring it into a denon service center which I did. The service center folks told me that denon told them it isn't a receiver issue but rather a ps3 compatibility issue and I should call Sony to ask them if they have a fix or software patch or something. I can see this turning into a blame game! Can anyone help me?

Try another HDMI Denon input. But really you don't need HDMI to the denon cause there isn't HD audio decoders in the denon, so optical cable is all that is needed for 5.1 and run the PS3 to the TV and the buggy firmware won't be a big problem and you will have a better picture. I run both my xbox 360 and my sony 350 bluray with hdmi to a 1909 with no problems
googlegod is offline  
post #3 of 5 Old 11-18-2009, 02:52 PM - Thread Starter
Newbie
 
lencholamas's Avatar
 
Join Date: Nov 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I did try another denon input and doesn't work. I guess I can try to connect the ps3 directly to the tv and use the audio from the receiver but it's kinda annoying that I have to do that. But at least it's a workaround!
lencholamas is offline  
post #4 of 5 Old 11-18-2009, 02:54 PM
AVS Addicted Member
 
JOHNnDENVER's Avatar
 
Join Date: Dec 2005
Posts: 13,377
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 12
Does the resolution set of the PS3 make any difference?


There is a rather bizar ritual to reset HDCP between the devices.

Unplug everything for an extended period of time.

Plug it back in and bring up display first putting it on the proper input, then the AVR once again putting it on the proper input, and then the source.


If this fixes it? be prepared as it will most likely do it again. Take care when switching sources to minimize issue.

Switching sources while content is running is one way this sort of thing can happen.
JOHNnDENVER is offline  
post #5 of 5 Old 11-18-2009, 02:57 PM
 
googlegod's Avatar
 
Join Date: Nov 2008
Posts: 1,387
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by lencholamas View Post

I did try another denon input and doesn't work. I guess I can try to connect the ps3 directly to the tv and use the audio from the receiver but it's kinda annoying that I have to do that.

There is not much else you can do, as you said denon CS is useless and sony may have a fix that is easly downloaded were as the low end denons don't afford such luxuries, just be happy that someway you can get it to work at all !
googlegod is offline  
Reply Receivers, Amps, and Processors

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off