Onkyo SC5508 Surround processor [No Price Talk] - Page 92 - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #2731 of 2749 Old 02-21-2014, 07:12 AM
Wireless member
 
pepar's Avatar
 
Join Date: Jul 2002
Location: Quintana Roo ... in my mind
Posts: 25,144
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 185 Post(s)
Liked: 163
Quote:
Originally Posted by turnne1 View Post

hope that works out for you and the "bugs" dont return

others that have had HDMI boards replaced have not been as fortunate...historically
and check me for accuracy...but only think they give you 6 months warranty on the replacement board

Warren

The front panel/IDE bug was bad soldering and cleanup. Replace it with parts manufactured correctly, the bug is gone for good. As for the HDMI board, can you like me to posts complaining about the replacement failing? I have not heard that before.

Jeff
pepar is online now  
Sponsored Links
Advertisement
 
post #2732 of 2749 Old 02-24-2014, 06:04 AM
AVS Special Member
 
turnne1's Avatar
 
Join Date: Nov 2008
Posts: 3,908
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 651 Post(s)
Liked: 142
Quote:
Originally Posted by pepar View Post

The front panel/IDE bug was bad soldering and cleanup. Replace it with parts manufactured correctly, the bug is gone for good. As for the HDMI board, can you like me to posts complaining about the replacement failing? I have not heard that before.

Jeff

on the AVR's

seriously......there are all types of posts where replacement HDMI boards failed again

use the search function in the forum

There are models showing up on the secondary market...xxx8 model AVR's and pre pros with bad HDMI boards being sold as junk
I have seen two failed 5508's on ebay in the last 3 weeks. I think an earlier poster here bought one of them

As for the cable...yes..hopefully that was a one time fix
time will tell I guess


Warren

Rm 1 Samsung 64F8500 Onkyo 5509 prepro Sherbourn 5/1500A amp B&W CM10s..CM2 center...CM5's.rears
Rm 2 LG 47LE8500 Denon 4520 Celestion 305 speaker system
Rm 3 Samsung 51E8000 Yamaha A2010 Kef 2005.2 speaker system
Rm 4 Panasonic 50ST50 906 Mirage Omni sat speaker system
turnne1 is offline  
post #2733 of 2749 Old 02-24-2014, 06:15 AM
AVS Special Member
 
Archaea's Avatar
 
Join Date: Apr 2004
Location: Kansas City, MO
Posts: 6,490
Mentioned: 36 Post(s)
Tagged: 2 Thread(s)
Quoted: 685 Post(s)
Liked: 847
Do any of to you hear an ever so slight "thumping" on the amped speakers when holding down the volume up or down button on the remote with your 5508?

"Without subs it's just background music - with subs it's the main event!"
Archaea's Theatre Room
2011 KC Sub Shootout
2012 KC Blind Sub Shootout
My Subwoofer Recommendations by Pricepoint
Archaea is online now  
post #2734 of 2749 Old 02-24-2014, 07:22 AM
Senior Member
 
Maddmaster's Avatar
 
Join Date: May 2010
Location: Maryland
Posts: 428
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 15
Quote:
Originally Posted by turnne1 View Post

on the AVR's

seriously......there are all types of posts where replacement HDMI boards failed again

use the search function in the forum

There are models showing up on the secondary market...xxx8 model AVR's and pre pros with bad HDMI boards being sold as junk
I have seen two failed 5508's on ebay in the last 3 weeks. I think an earlier poster here bought one of them

As for the cable...yes..hopefully that was a one time fix
time will tell I guess


Warren

The whole xxx8 product line was affected. You are correct that two 5508's were sold on Ebay. I picked up one of them. It is worth the risk for the cost. Plus the fact that I can do the work myself if any is required.

Front - Mythos ST, Center - Mythos 8 and 10
Front Height - Gems, Side Surround - Gem XL
Back Surround - Gem XL
Sub - Supercube Ref
There can never be enough music
Maddmaster is offline  
post #2735 of 2749 Old 02-24-2014, 07:25 AM
Senior Member
 
Maddmaster's Avatar
 
Join Date: May 2010
Location: Maryland
Posts: 428
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 15
Quote:
Originally Posted by Archaea View Post

Do any of to you hear an ever so slight "thumping" on the amped speakers when holding down the volume up or down button on the remote with your 5508?

I don't get any noise at all using my Pronto or the factory remote.

Front - Mythos ST, Center - Mythos 8 and 10
Front Height - Gems, Side Surround - Gem XL
Back Surround - Gem XL
Sub - Supercube Ref
There can never be enough music
Maddmaster is offline  
post #2736 of 2749 Old 02-26-2014, 05:37 PM
AVS Special Member
 
turnne1's Avatar
 
Join Date: Nov 2008
Posts: 3,908
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 651 Post(s)
Liked: 142
Quote:
Originally Posted by Maddmaster View Post

The whole xxx8 product line was affected. You are correct that two 5508's were sold on Ebay. I picked up one of them. It is worth the risk for the cost. Plus the fact that I can do the work myself if any is required.

if you can do the work..if required...then you scored well

As I said before I bought a junk 875 and just a few weeks ago, a junked 906

the 906 had one of the HDMI in's and one of the outputs on the fritz...but other than that..its cherry, with one output and three inputs working

and for $130 I paid for it..I am quite satisfied
If it fails next year I could care less for what I have invested

the 875( that I paid $80.00 for) actually worked 100% when I got it
I send the previous owner a message...he was pissed and said the shop told him it needed an HDMI board to the tune of $600...so he sold it for junk
he did tell me it had been acting up on him...I guess I chalk it up to fed ex "bumping" it back into service


Warren

Rm 1 Samsung 64F8500 Onkyo 5509 prepro Sherbourn 5/1500A amp B&W CM10s..CM2 center...CM5's.rears
Rm 2 LG 47LE8500 Denon 4520 Celestion 305 speaker system
Rm 3 Samsung 51E8000 Yamaha A2010 Kef 2005.2 speaker system
Rm 4 Panasonic 50ST50 906 Mirage Omni sat speaker system
turnne1 is offline  
post #2737 of 2749 Old 02-28-2014, 07:48 AM
Senior Member
 
Maddmaster's Avatar
 
Join Date: May 2010
Location: Maryland
Posts: 428
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 15
Quote:
Originally Posted by turnne1 View Post

if you can do the work..if required...then you scored well

As I said before I bought a junk 875 and just a few weeks ago, a junked 906

the 906 had one of the HDMI in's and one of the outputs on the fritz...but other than that..its cherry, with one output and three inputs working

and for $130 I paid for it..I am quite satisfied
If it fails next year I could care less for what I have invested

the 875( that I paid $80.00 for) actually worked 100% when I got it
I send the previous owner a message...he was pissed and said the shop told him it needed an HDMI board to the tune of $600...so he sold it for junk
he did tell me it had been acting up on him...I guess I chalk it up to fed ex "bumping" it back into service


Warren

5508 just arrived this morning. Packaged well but when I opened the box, OMG. It must have been in a smoked filled room 24 hrs a day everyday for it's life span. Looking for the Fabreeze to wash it down. Even the remote control and manual are so bad the front page and the white keys on the remote are brown. I had to laugh when I opened the manual and every page inside is white like new. Physically it survived the shipping but right now my man cave smells. Not sure if I will keep it now. Hope Fabreeze works.

Front - Mythos ST, Center - Mythos 8 and 10
Front Height - Gems, Side Surround - Gem XL
Back Surround - Gem XL
Sub - Supercube Ref
There can never be enough music
Maddmaster is offline  
post #2738 of 2749 Old 02-28-2014, 07:52 AM
Wireless member
 
pepar's Avatar
 
Join Date: Jul 2002
Location: Quintana Roo ... in my mind
Posts: 25,144
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 185 Post(s)
Liked: 163
Quote:
Originally Posted by Maddmaster View Post

5508 just arrived this morning. Packaged well but when I opened the box, OMG. It must have been in a smoked filled room 24 hrs a day everyday for it's life span. Looking for the Fabreeze to wash it down. Even the remote control and manual are so bad the front page and the white keys on the remote are brown. I had to laugh when I opened the manual and every page inside is white like new. Physically it survived the shipping but right now my man cave smells. Not sure if I will keep it now. Hope Fabreeze works.

Don't put it under a UV light!

Jeff
pepar is online now  
post #2739 of 2749 Old 02-28-2014, 08:54 AM
Senior Member
 
Maddmaster's Avatar
 
Join Date: May 2010
Location: Maryland
Posts: 428
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 15
Quote:
Originally Posted by pepar View Post

Don't put it under a UV light!

Jeff

For most it wouldn't be an issue but I am allergic to whatever is in cigarette smoke. It took my doctor to find it years ago.

Front - Mythos ST, Center - Mythos 8 and 10
Front Height - Gems, Side Surround - Gem XL
Back Surround - Gem XL
Sub - Supercube Ref
There can never be enough music
Maddmaster is offline  
post #2740 of 2749 Old 02-28-2014, 09:53 AM
Wireless member
 
pepar's Avatar
 
Join Date: Jul 2002
Location: Quintana Roo ... in my mind
Posts: 25,144
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 185 Post(s)
Liked: 163
Quote:
Originally Posted by Maddmaster View Post

For most it wouldn't be an issue but I am allergic to whatever is in cigarette smoke. It took my doctor to find it years ago.

Even without an allergy, it is a terrible smell especially when the unit heats up. BTW, the internal components are likely coated ...

Jeff
pepar is online now  
post #2741 of 2749 Old 03-03-2014, 07:21 PM
AVS Special Member
 
turnne1's Avatar
 
Join Date: Nov 2008
Posts: 3,908
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 651 Post(s)
Liked: 142
Quote:
Originally Posted by Maddmaster View Post

5508 just arrived this morning. Packaged well but when I opened the box, OMG. It must have been in a smoked filled room 24 hrs a day everyday for it's life span. Looking for the Fabreeze to wash it down. Even the remote control and manual are so bad the front page and the white keys on the remote are brown. I had to laugh when I opened the manual and every page inside is white like new. Physically it survived the shipping but right now my man cave smells. Not sure if I will keep it now. Hope Fabreeze works.

yikes

thats not good
well...in time ( and with heat) it should go away

Have you tried to connect it yet?
I could smell a little of that on the 875 I bought...though it did go away in time

maybe they kept it in a cabinet where the remnants of the smoke could not land past the faceplate of the the actual unit

btw...I have also noticed that someone has been selling the companion 9 channel Onkyo amp, the PA-MC5500, on Ebay for about 75% retail....the seller auctions a few units a week, new in box...but with no manufacturer warranty...

curious...I was tempted when I saw them selling for $250( delivered) a couple of weeks ago...the seller has since raised his pricing
Was about to pull the trigger and really could not think of what I would do with a 9 channel amp...especially I already have another amp that has been in storage for a few years

I Googled the Onkyo amp and there were some that said it was just the amp section of the Onkyo 50XX receiver packaged in its own box


Warren

Rm 1 Samsung 64F8500 Onkyo 5509 prepro Sherbourn 5/1500A amp B&W CM10s..CM2 center...CM5's.rears
Rm 2 LG 47LE8500 Denon 4520 Celestion 305 speaker system
Rm 3 Samsung 51E8000 Yamaha A2010 Kef 2005.2 speaker system
Rm 4 Panasonic 50ST50 906 Mirage Omni sat speaker system
turnne1 is offline  
post #2742 of 2749 Old 03-03-2014, 07:58 PM
Senior Member
 
Maddmaster's Avatar
 
Join Date: May 2010
Location: Maryland
Posts: 428
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 15
I powered it up Saturday and upgraded the firmware. I don't think it was ever connected to the internet. The smell has died down sonatas plus.

I'll check.for that power amp.

Front - Mythos ST, Center - Mythos 8 and 10
Front Height - Gems, Side Surround - Gem XL
Back Surround - Gem XL
Sub - Supercube Ref
There can never be enough music
Maddmaster is offline  
post #2743 of 2749 Old 06-18-2014, 05:50 PM
AVS Special Member
 
turnne1's Avatar
 
Join Date: Nov 2008
Posts: 3,908
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 651 Post(s)
Liked: 142
I pulled the trigger on a Yamaha CX-A5000...should be delivered by weeks end

A couple of people I trust say they liked the Yamaha better than the 5508

Hopefully I will feel the same

Will be selling the 5508...it has a year left on the extended warranty


Warren

Rm 1 Samsung 64F8500 Onkyo 5509 prepro Sherbourn 5/1500A amp B&W CM10s..CM2 center...CM5's.rears
Rm 2 LG 47LE8500 Denon 4520 Celestion 305 speaker system
Rm 3 Samsung 51E8000 Yamaha A2010 Kef 2005.2 speaker system
Rm 4 Panasonic 50ST50 906 Mirage Omni sat speaker system
turnne1 is offline  
post #2744 of 2749 Old 10-07-2014, 03:33 PM
Senior Member
 
Maddmaster's Avatar
 
Join Date: May 2010
Location: Maryland
Posts: 428
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 15
Quote:
Originally Posted by turnne1 View Post
I pulled the trigger on a Yamaha CX-A5000...should be delivered by weeks end

A couple of people I trust say they liked the Yamaha better than the 5508

Hopefully I will feel the same

Will be selling the 5508...it has a year left on the extended warranty


Warren
Did your CX-A5000 arrive. What are your feelings?

Front - Mythos ST, Center - Mythos 8 and 10
Front Height - Gems, Side Surround - Gem XL
Back Surround - Gem XL
Sub - Supercube Ref
There can never be enough music
Maddmaster is offline  
post #2745 of 2749 Old 10-07-2014, 03:58 PM
AVS Special Member
 
turnne1's Avatar
 
Join Date: Nov 2008
Posts: 3,908
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 651 Post(s)
Liked: 142
Quote:
Originally Posted by Maddmaster View Post
Did your CX-A5000 arrive. What are your feelings?
yes...and I had HIGH expectations when I opened the box
However..reality soon set in

I had the Onkyo connected via RCA to the amp
When I did this with the Yamaha it had a terrible ground loop

At the time I didnt have a set of XLR cables to try it that way
I called the store I bought it from and they assumed it was defective and told me to send it back
When it arrived they tested it and no problems

They suggested I call an electrician and have him do some work and I questioned why the Onkyo would perform fine
So..I returned the Yamaha and put the Onkyo back in place
I have also now bought and utilized some XLR cables

Now...I am having HDMI board issues with the Onkyo
Its still under warranty...so I will likely be three weeks without while they repair it

At this point I am going to have it fixed and wait it out for now

Warren

Rm 1 Samsung 64F8500 Onkyo 5509 prepro Sherbourn 5/1500A amp B&W CM10s..CM2 center...CM5's.rears
Rm 2 LG 47LE8500 Denon 4520 Celestion 305 speaker system
Rm 3 Samsung 51E8000 Yamaha A2010 Kef 2005.2 speaker system
Rm 4 Panasonic 50ST50 906 Mirage Omni sat speaker system
turnne1 is offline  
post #2746 of 2749 Old Yesterday, 01:10 PM
Senior Member
 
foraye's Avatar
 
Join Date: Dec 2003
Location: PA
Posts: 216
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 18
I just got my 5508 back from Onkyo for "No Audio/Video" from not just HDMI but any input. It surfaced months ago, and got to the point that I could not turn the unit off. If I did it would not recognize any inputs when restarted. I'd have to do multiple resets , USP boots etc. The HDMI video then failed completely, followed by the audio.

I called it in and they sent me a box and packaging. Initially I didn't have the original receipt, and was offered a refurbished 5509 at 50% list, I declined. I waited a few months and called back, got the same guy on the phone...and an RMA this time. Go figure...either way its working again, there hasn't been any explanation of what was repaired, no packing slip, only a piece of paper indicating that its been reset to factory defaults.

It looks like a trade is in the works, I was set on the Yamaha until now , so I'll look at the Marantz next. I've got to say, when I was purchasing $900 receivers I had less issues..."More money more problems!"
foraye is online now  
post #2747 of 2749 Old Yesterday, 05:09 PM
Senior Member
 
Maddmaster's Avatar
 
Join Date: May 2010
Location: Maryland
Posts: 428
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 15
Quote:
Originally Posted by foraye View Post
I just got my 5508 back from Onkyo for "No Audio/Video" from not just HDMI but any input. It surfaced months ago, and got to the point that I could not turn the unit off. If I did it would not recognize any inputs when restarted. I'd have to do multiple resets , USP boots etc. The HDMI video then failed completely, followed by the audio.

I called it in and they sent me a box and packaging. Initially I didn't have the original receipt, and was offered a refurbished 5509 at 50% list, I declined. I waited a few months and called back, got the same guy on the phone...and an RMA this time. Go figure...either way its working again, there hasn't been any explanation of what was repaired, no packing slip, only a piece of paper indicating that its been reset to factory defaults.

It looks like a trade is in the works, I was set on the Yamaha until now , so I'll look at the Marantz next. I've got to say, when I was purchasing $900 receivers I had less issues..."More money more problems!"
They replaced the HDMI Board. That controls all the things you were having problems with. It's a known problem.

Front - Mythos ST, Center - Mythos 8 and 10
Front Height - Gems, Side Surround - Gem XL
Back Surround - Gem XL
Sub - Supercube Ref
There can never be enough music
Maddmaster is offline  
post #2748 of 2749 Old Today, 08:18 AM
Senior Member
 
foraye's Avatar
 
Join Date: Dec 2003
Location: PA
Posts: 216
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 18
@Maddmaster
Yes that is what I figured, I've been aware of it for a few years. Somehow if you call in and know too much about the issue, it seem counterproductive for me, So i just say its not working Audio/Video and...not reciept needed, and label is on its way!..

Well, it took a week to get the prepaid shipping label/box, which I thought was a nice touch. While the carton was about 1/2 the gage of the original (which I shipped it back in), they also included packing tape! and bagging. They did turn it around in about a week though.

Its amazing how its become hit or miss with equipment these days. I had to send back my Panny AE8000 (Main Board replacement), then my Emotiva Amp, with a similar issue to yours but it was my balanced connections that kept shorting when connected to the Onkyo ( I now use the RCAs only). Emotiva returned it and claimed no problem found but everything has worked fine... Now the Onkyo...
foraye is online now  
post #2749 of 2749 Old Today, 02:32 PM
Senior Member
 
foraye's Avatar
 
Join Date: Dec 2003
Location: PA
Posts: 216
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 18
I just came across this ... My unit was repaired under this program.

Its covered in this AVS thread HERE.

I must have had my unit repaired under it. I still went to the site and typed in my S/N and it indicated that "Your unit has already been repaired under this service".

Good luck to all with HDMI/No Audio Issues!
foraye is online now  
Reply Receivers, Amps, and Processors

Tags
Onkyo Pr Sc5507 Pre Amplifier Home Theater Av Controller Preamp 9 2 Channel New
Gear in this thread - Sc5507 by PriceGrabber.com

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off