Integra DTR 7.8 - Unit Display Not Working - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 10 Old 01-26-2011, 12:24 PM - Thread Starter
Senior Member
 
FLPat's Avatar
 
Join Date: Dec 2008
Location: Dunedin, FL (near Clearwater)
Posts: 384
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have a two year old Integra DTR 7.8. When I turned it on yesterday the display on the front of the unit did not light up, and hasn't since. The unit appears to be working fine otherwise, just no display. The only light working on the front is the red stand-by/IR monitor LED.

I tried the dimmer button on the receiver (and the remote) but no luck.

Does anyone know if I'm missing something simple, or if displays usually have a dedicated fuse that may be easy to replace etc?

Appreciate any feedback.
FLPat is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 02-03-2011, 09:06 PM
Advanced Member
 
alanl715's Avatar
 
Join Date: Oct 2007
Location: tejas
Posts: 932
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
the unit is still under the 3 yr warranty ( u've had it 2 yrs )...have a servicenter replace the defective resistor in the display for free.
alanl715 is offline  
post #3 of 10 Old 02-04-2011, 02:09 PM - Thread Starter
Senior Member
 
FLPat's Avatar
 
Join Date: Dec 2008
Location: Dunedin, FL (near Clearwater)
Posts: 384
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks for telling me about the resistor. I got it refurbished, so I think the warranty was for 90 days or something like that. Sounds like it is a fairly simply fix, but it will cost me..!
FLPat is offline  
post #4 of 10 Old 02-04-2011, 09:10 PM
Advanced Member
 
alanl715's Avatar
 
Join Date: Oct 2007
Location: tejas
Posts: 932
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by FLPat View Post

Thanks for telling me about the resistor. I got it refurbished, so I think the warranty was for 90 days or something like that. Sounds like it is a fairly simply fix, but it will cost me..!

Integra refurbs have a manf 2 yr p&l warranty fyi.
alanl715 is offline  
post #5 of 10 Old 02-05-2011, 07:31 AM - Thread Starter
Senior Member
 
FLPat's Avatar
 
Join Date: Dec 2008
Location: Dunedin, FL (near Clearwater)
Posts: 384
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Dang, I bought it 12/6/08. The display died the next month, January, of course. Maybe they will have pity. Thanks for that info!
FLPat is offline  
post #6 of 10 Old 03-13-2011, 08:55 AM - Thread Starter
Senior Member
 
FLPat's Avatar
 
Join Date: Dec 2008
Location: Dunedin, FL (near Clearwater)
Posts: 384
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I called Integra and they offered to warrant the repair. I took it to the local repair shop, they replaced a bad resistor, and now everything is working again - woo hoo!

It was a lot of work for a bad resistor. I thought it was pretty nice of Integra to warrant the repair even though I was a month out.
FLPat is offline  
post #7 of 10 Old 12-06-2012, 12:46 PM
Member
 
drsung's Avatar
 
Join Date: May 2002
Posts: 65
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Do you have any additional information on the resisitor? I have a 7.8 that is now long out of warranty that the display screen does not come on. The rest of the receiver works fine. I would like to attempt the repair myself.

Thanks.
drsung is offline  
post #8 of 10 Old 01-22-2013, 02:36 PM - Thread Starter
Senior Member
 
FLPat's Avatar
 
Join Date: Dec 2008
Location: Dunedin, FL (near Clearwater)
Posts: 384
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I wish I could help you but I did not get any of that information from the repair shop. Alanl715 sounds like he might know. Good luck!
FLPat is offline  
post #9 of 10 Old 01-22-2013, 02:36 PM - Thread Starter
Senior Member
 
FLPat's Avatar
 
Join Date: Dec 2008
Location: Dunedin, FL (near Clearwater)
Posts: 384
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I wish I could help you but I did not get any of that information from the repair shop. Alanl715 sounds like he might know. Good luck!
FLPat is offline  
post #10 of 10 Old 10-01-2013, 01:25 PM
Newbie
 
GANDDALFF69's Avatar
 
Join Date: Oct 2013
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

I have the same problem with the same model, I'm in Miami and can't find anyone here. can fix or sell the parts

Thank for any information

GANDDALFF69 is offline  
Reply Receivers, Amps, and Processors

Tags
Integra

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off