Official Pioneer VSX-521k owners thread - Page 26 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
Reply
 
Thread Tools
post #751 of 753 Old 01-29-2017, 06:08 AM
Newbie
 
Join Date: Jan 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
Quote:
Originally Posted by curtdusoleil View Post
My Center speaker is plugged in and I am getting full sound out of it, all voices. There was just a strange, low volume muffled echo of the voices coming from what seemed the rest of my speakers.

I think I fixed it. In my settings I had my front and rear speakers set to different Small and Large. I changed them all to the same and set the subwoofer to No and it seems to have fixed the problem.
Hi,

I am new on this site.

I have a Hisense 55M7000 which supports ARC on HDMI 2 port, so I've connected this to my Pioneer 521 via the TV out HDMI port.
No sound unless I also connect an optical connection but this causes issues with the CEC and switching on and off control.

I suspect I need to enable to ARC but from what I've read I need a working remote control to access the setup menu, it appears my remote has stopped working.
Please advise on how to resolve?
I could try and locate a replacement remote on eBay if required.

Also please advise if this amp fully supports 4k?

Thanks
puthsardarade is offline  
Sponsored Links
Advertisement
 
post #752 of 753 Old 02-19-2017, 03:55 PM
Member
 
jaydee77ca's Avatar
 
Join Date: Sep 2007
Posts: 104
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Liked: 24
Official Pioneer VSX-521k owners thread

Hi, I have a pair of Power Acoustik HP-902RFT headphones that I'm trying to get to work with my Pioneer VSX-821-K receiver. I can't get sound to come out of the headphones though.

The cable DVR and bluray player are connected to the receiver via HDMI. The receiver is connected to the TV via HDMI. The headphones are connected to the receiver via RCA left/right cables to the DVR/BDR audio out plugs.

However, no matter what I do I can't get the sound to come from the headphones. I know the headphones work because I tested them separately plugged directly into the cable DVR box.

Anybody know what I could be doing wrong?

Thanks!


Sent from my iPad using Tapatalk

Last edited by jaydee77ca; 02-19-2017 at 04:00 PM.
jaydee77ca is offline  
post #753 of 753 Old 03-27-2017, 04:56 PM
Newbie
 
Join Date: Mar 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
Does anyone here happen to have an OEM remote and/or the calibration mic that I could either purchase, or even borrow for about a week to set mine up. I just received this receiver but without remote and microphone. Yes, I do understand that I am just registered here but I am seriously interested.

Please reply or message me. Thanks!

Oh, and Location is in MN, if that helps anyone.
tlh007 is offline  
Sponsored Links
Advertisement
 
Reply Receivers, Amps, and Processors

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off