Denon 3808 Receiver -- dead? - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!

Forum Jump: 
Thread Tools
Old 07-09-2011, 04:33 PM - Thread Starter
guarnibl's Avatar
Join Date: Sep 2008
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I'm running the following:

5 SVSound speakers w/ Sub.

HDMI from TV to Monitor HDMI jack on the receiver.

HDMI to PS3 -- DVD

Tested all cables... no video or audio. Speakers work fine on other receiver. Xbox/PS3 all output audio/video when hooked to TV directly.. just not through receiver. There is no Denon logo showing up.

I didn't change anything. What gives? Any ideas guys? I reset the micro processor, but nothing. Not sure what else to check.. my setup is pretty simple.

Receiver model:
guarnibl is offline  
Sponsored Links
Old 07-09-2011, 07:14 PM
AVS Addicted Member
jdsmoothie's Avatar
Join Date: Sep 2007
Location: Orlando, FL
Posts: 63,702
Mentioned: 204 Post(s)
Tagged: 1 Thread(s)
Quoted: 10572 Post(s)
Liked: 4896
Could be the HDMI board has gone bad. Try doing a "network reset" instead ... press/hold the up/down arrow keys on the front panel while powering on the AVR (similar to what you would do for the regular micro reset).

If you think your AVR is defective, refer to the Owner's manual and reset the microprocessor a few times in a row.

2016 Denon AVR Owner's thread

2016 Marantz AVR Owner's thread
jdsmoothie is offline  
Sponsored Links
Thread Tools

Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off