Yamaha Receiver Not Turning On - AVS Forum
Receivers, Amps, and Processors > Yamaha Receiver Not Turning On
Crblanz's Avatar Crblanz 05:23 PM 10-01-2011
Hey, so I've had the Yamaha RX V675 receiver for a bit now, and just recently it stopped turning on. I didn't change of move anything, so I'm not sure what could have happened.

But now, when I first plug it in, a light for "HDMI through" is the only thing on (it isn't connected to anything but the wall). Most of the buttons on the remote don't do anything, but certain ones have an effect, such as the power button and a series of buttons for BD/DVD, TV, etc. When I press any of these buttons, the receiver clicks, and the light goes off, giving no indication that the device is on. A second press results in another click, as well as a third button press. After that, the receiver does not respond to anything. I can unplug then replug the device and repeat the process over again.

I'm at a complete loss for what it could be, would any of you be able to help me? Thanks

toofarzong's Avatar toofarzong 08:19 PM 10-01-2011
If it's under warranty take it in. If not just go purchase a new one. Nobody here could tell you with 100% certainty what the problem is without taking it apart and running some diagnostics.
rdgrimes's Avatar rdgrimes 09:29 PM 10-01-2011
If a Yamaha has gone into protection mode 3 times it will default to a "dead" status. There's a secret way to reset the thing, which is posted in several of the Yamaha threads. Can't say if this is your issue but it's worth looking into.
Up
Mobile  Desktop