Denon AVR-588 help - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 5 Old 06-28-2012, 11:35 PM - Thread Starter
Member
 
deboardfam's Avatar
 
Join Date: Jun 2012
Location: Grayson, Ky
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I am checking out a Denon AVR-588 for a buddy who is having an issue. It is giving white noise and a distorted popping sound. I verified is a good audio input, also tried different speakers. Still having the same issue. Do I have many options or should we be looking for a local tech who can work on it? Is it really worth fixing? It looks like a really nice receiver, older, but a 7.1 with an extra zone channel as well.. Thanks for your help / input.
deboardfam is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 06-29-2012, 04:39 AM
585-645-1006
 
jdsmoothie's Avatar
 
Join Date: Sep 2007
Location: Orlando, FL
Posts: 47,960
Mentioned: 26 Post(s)
Tagged: 0 Thread(s)
Quoted: 2604 Post(s)
Liked: 1894
Is this issue with all sources and all type audio tracks? Try resetting the microprocessor (see Owner's manual p. 38). Also try swapping out the HDMI cables.

---------------------------------
"JD" – jd@avscience.com ; Call me --> 585-645-1006, AVScience - AVSForum sponsor and dealer for AVRs and Speakers 

Daily 8am – 8pm EST
Call for info on Denon, Marantz, Yamaha, Pioneer, Onkyo, Def Tech, Atlantic Tech, Oppo
** Think the AVR is defective?  Reset the microprocessor 4-5 times. 
jdsmoothie is offline  
post #3 of 5 Old 06-29-2012, 08:00 AM - Thread Starter
Member
 
deboardfam's Avatar
 
Join Date: Jun 2012
Location: Grayson, Ky
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I tried two hdmi and a composite and got the same issue he was having at his house so that's a different source. I'll try resetting the processor after vacation. I'll have to look up the manual, he didn't give me one.
deboardfam is offline  
post #4 of 5 Old 06-29-2012, 08:08 AM
585-645-1006
 
jdsmoothie's Avatar
 
Join Date: Sep 2007
Location: Orlando, FL
Posts: 47,960
Mentioned: 26 Post(s)
Tagged: 0 Thread(s)
Quoted: 2604 Post(s)
Liked: 1894
If resetting the microprocessor doesn't resolve the issue, he's likely better served replacing it with a newer model. This was the lowest level model and does not have Audyssey MultEQ which would likely provide a marked improvement in audio quality. Getting a clearance sale on either last year's 1612 or 1712 would be a nice upgrade.

247

Another option would be buying a refurb model ...

http://www.accessories4less.com/make-a-store/item/DENAVR1612/DENON-AVR-1612-5.1-Channel-A/V-Home-Theater-Receiver/1.html

---------------------------------
"JD" – jd@avscience.com ; Call me --> 585-645-1006, AVScience - AVSForum sponsor and dealer for AVRs and Speakers 

Daily 8am – 8pm EST
Call for info on Denon, Marantz, Yamaha, Pioneer, Onkyo, Def Tech, Atlantic Tech, Oppo
** Think the AVR is defective?  Reset the microprocessor 4-5 times. 
jdsmoothie is offline  
post #5 of 5 Old 06-29-2012, 08:26 AM
AVS Special Member
 
JChin's Avatar
 
Join Date: Oct 2008
Location: Mesquite Tx
Posts: 8,612
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 125 Post(s)
Liked: 140
Hi deboardfam, give this a whirl ... remove receiver cover and dust off the interior with compressed air. Just note to power off completly, unplug all cables including power cord.
JChin is offline  
Reply Receivers, Amps, and Processors

Tags
Denon Avr 588 Dolby Digital Surround Receiver

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off