Marantz SR7007 AV Receiver Owner's Thread - Page 19 - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #541 of 981 Old 05-23-2013, 08:15 PM
Member
 
Rehan's Avatar
 
Join Date: Apr 2009
Location: Northern California
Posts: 102
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 19
Hi guys,

I just got a Marantz SR7007 for my home setup. I have it connected via pre-outs (FL and FR) to 2 NAD C 275BEE stereo power amps. The NAD amps allow being turned on via 12v trigger out and I have connected 2 trigger out cables from the back of the Marantz to the amps.

I went through the on screen display and made sure both triggers were activated from every source on my main zone but for some reason only Trigger #2 works. I've swapped the amps to the different trigger ports and whichever amp is connected to Trigger #2 works whereas the Trigger #1 connected amp doesn't turn on/off.

Does this mean I have a defective unit?
Rehan is offline  
Sponsored Links
Advertisement
 
post #542 of 981 Old 05-24-2013, 01:43 AM
Newbie
 
Uncle Jan's Avatar
 
Join Date: May 2013
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quoting myself: Re: zone 2. According to another source, it is possible to set up according to my preferences if I also have an analogue connection between the BR-player and the receiver. But I can't use wide speakers and zone 2 at the same time. I haven't been able to test this yet.


YES, using analogue inputs from the BR player did the trick.
Presumably you must have double connections, HDMI and analogue, from other sources as well if you want them to be played in more zones than the Main one. Even more cables wasn't exactly on the wish list....
Jan
Uncle Jan is offline  
post #543 of 981 Old 05-24-2013, 02:36 AM
585-645-1006
 
jdsmoothie's Avatar
 
Join Date: Sep 2007
Location: Orlando, FL
Posts: 43,826
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 715 Post(s)
Liked: 1400
Quote:
Originally Posted by Rehan View Post

Hi guys,

I just got a Marantz SR7007 for my home setup. I have it connected via pre-outs (FL and FR) to 2 NAD C 275BEE stereo power amps. The NAD amps allow being turned on via 12v trigger out and I have connected 2 trigger out cables from the back of the Marantz to the amps.

I went through the on screen display and made sure both triggers were activated from every source on my main zone but for some reason only Trigger #2 works. I've swapped the amps to the different trigger ports and whichever amp is connected to Trigger #2 works whereas the Trigger #1 connected amp doesn't turn on/off.

Does this mean I have a defective unit?

Possibly, especially if you have the settings correct.. Try a soft reset (unplug the power cord for a few minutes) and if still no joy then reset the microprocessor (p. 179 OM).

---------------------------------
"JD" – jd@avscience.com ; shop.avscience.com ; 585-645-1006, AVScience - Authorized dealer for AV Gear 
Mon - Fri: 8am – 8pm EST (Sat/Sun too, will return call if I don't pick up)
Call for pricing on Denon, Marantz, Yamaha, Onkyo, Klipsch, Def Tech, Oppo, Parasound 
** Think the AVR is defective?  Reset the microprocessor 4-5 times. 
jdsmoothie is online now  
post #544 of 981 Old 05-24-2013, 02:38 AM
585-645-1006
 
jdsmoothie's Avatar
 
Join Date: Sep 2007
Location: Orlando, FL
Posts: 43,826
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 715 Post(s)
Liked: 1400
Quote:
Originally Posted by vik75 View Post

Hi Marantz sr7007 owners,

I want to buy a marantz sr7007 but i have 5 audio psysics yarra evolution 20-120watt 4 ohm speakers.
Should this be a problem for the sr7007?

At average TV volume levels, not likely, however, don't expect to be able to attain louder movie/music listening levels without the AVR shutting down in protection mode.

---------------------------------
"JD" – jd@avscience.com ; shop.avscience.com ; 585-645-1006, AVScience - Authorized dealer for AV Gear 
Mon - Fri: 8am – 8pm EST (Sat/Sun too, will return call if I don't pick up)
Call for pricing on Denon, Marantz, Yamaha, Onkyo, Klipsch, Def Tech, Oppo, Parasound 
** Think the AVR is defective?  Reset the microprocessor 4-5 times. 
jdsmoothie is online now  
post #545 of 981 Old 05-27-2013, 08:40 AM
Newbie
 
Uncle Jan's Avatar
 
Join Date: May 2013
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Could I possibly hope for a software update to the 7007? Or is this a question of hardware?
As I have a very short experience as a Marantz-owner, I don't know what is possible re software updates.
Uncle Jan is offline  
post #546 of 981 Old 05-27-2013, 10:40 AM
585-645-1006
 
jdsmoothie's Avatar
 
Join Date: Sep 2007
Location: Orlando, FL
Posts: 43,826
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 715 Post(s)
Liked: 1400
Sorry, but no as it is indeed a hardware issue.

---------------------------------
"JD" – jd@avscience.com ; shop.avscience.com ; 585-645-1006, AVScience - Authorized dealer for AV Gear 
Mon - Fri: 8am – 8pm EST (Sat/Sun too, will return call if I don't pick up)
Call for pricing on Denon, Marantz, Yamaha, Onkyo, Klipsch, Def Tech, Oppo, Parasound 
** Think the AVR is defective?  Reset the microprocessor 4-5 times. 
jdsmoothie is online now  
post #547 of 981 Old 05-29-2013, 06:54 PM
Member
 
DrMichael's Avatar
 
Join Date: Apr 2013
Location: Minnesota
Posts: 167
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 21
Good evening,
I currently own a Marantz SR7007 AVR paired with Martin Logan speakers and have noticed a faint hissing noise when the volume is turned all the way down or when the speaker is not in use. I for sure hear it when I have my ear up to the tweeter. I can hear it at my listening position (8 feet) when I mute it on and off noticing the change. I hear it is normal for a hiss to occur when close to a speaker with hightly efficient/sensitive speakers paired with powerful amps. Any thoughts on this issue? Is this normal?
Thank you

Panasonic TC-P65ZT60
Marantz AV8801
Marantz MM8077
Martin Logan Motion 30 Center Channel
Martin Logan Motion 40 Fronts/Rears
REL R-528 SE (2)
Oppo BDP-103D
Playstation 4
Furman ELITE-20 PF i Power Conditioner
DrMichael is offline  
post #548 of 981 Old 05-30-2013, 03:09 PM
Newbie
 
kim karomi's Avatar
 
Join Date: May 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hello, all.

I am a new owner of the SR7007. In fact, this is the first AVR I have ever owned. The thing I'm having trouble with and that I can't seem to locate even in the manual is related to wireless streaming of .flac files.

When I use the Android Marantz Remote App to access the media library on my laptop ( I haven't yet built a dedicated HTPC/server) I can access all the albums and files because the directories and folders show up on my phone's app-interface. But if I use the web interface or use the remote control that came with the AVR in conjunction with the on-screen menu I cannot drop down a folder level even to see the titles of .flac files. And in some cases I cannot even see albums/folders that contain .flac files.

I'm trying to find out if there's a setting I'm missing somewhere or if this is just a drawback of the AVR interface.
kim karomi is offline  
post #549 of 981 Old 05-31-2013, 04:10 AM
Member
 
DrMichael's Avatar
 
Join Date: Apr 2013
Location: Minnesota
Posts: 167
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 21
Quote:
Originally Posted by DrMichael View Post

Good evening,
I currently own a Marantz SR7007 AVR paired with Martin Logan speakers and have noticed a faint hissing noise when the volume is turned all the way down or when the speaker is not in use. I for sure hear it when I have my ear up to the tweeter. I can hear it at my listening position (8 feet) when I mute it on and off noticing the change. I hear it is normal for a hiss to occur when close to a speaker with hightly efficient/sensitive speakers paired with powerful amps. Any thoughts on this issue? Is this normal?
Thank you

Anybody?

Panasonic TC-P65ZT60
Marantz AV8801
Marantz MM8077
Martin Logan Motion 30 Center Channel
Martin Logan Motion 40 Fronts/Rears
REL R-528 SE (2)
Oppo BDP-103D
Playstation 4
Furman ELITE-20 PF i Power Conditioner
DrMichael is offline  
post #550 of 981 Old 05-31-2013, 09:24 AM
Newbie
 
kim karomi's Avatar
 
Join Date: May 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I'm definitely no expert but, from what I can remember from my science classes, you might be hearing noise floor, which is is the totality of all unwanted signal generated or received by the system. There are a few basic things you can check for reducing hiss:
>> cable connections and terminations: Are they clean, neat, trim and tight
>> interference/shielding: Are your cables and speaker wires close to other electrical sources or fields; can they be moved or shielded?

It's also possible that it's something you're stuck with. My parents' old system used to hiss. Only time I paid attention to it was in the quiet passages of listening to western classical music or when the system was first turned on.

Have you tried hitting people on the Audio Theory board here?
kim karomi is offline  
post #551 of 981 Old 05-31-2013, 09:27 AM
Newbie
 
kim karomi's Avatar
 
Join Date: May 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
PS: you really shouldn't be hearing the hiss from your normal listening position though. Sometimes changing the listening/sound mode can fix this.

Cheers
kim karomi is offline  
post #552 of 981 Old 06-05-2013, 11:45 AM
Newbie
 
SkyWalker1726's Avatar
 
Join Date: Feb 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
hi everyone , i recently upgraded from a Denon 1912 to a SR7007 , but i have a little problem ,
i connected all my speakers to the 7007 using the same cables that i used for my denon 1912 , got my PC and PS3 connected too , but there's a constant noise sound in the background , like when there's nothing playing there's a constant "shhhhhhhhhhhhhhhhhhhhhhhhhhhhhh" sound , as soon as i turn on the Device , coming out of all the speakers . how do i make this noise stop , didn't have it with my denon
any suggestion would be appreciated
thx

EDIT :
Quote:
Originally Posted by DrMichael View Post

Good evening,
I currently own a Marantz SR7007 AVR paired with Martin Logan speakers and have noticed a faint hissing noise when the volume is turned all the way down or when the speaker is not in use. I for sure hear it when I have my ear up to the tweeter. I can hear it at my listening position (8 feet) when I mute it on and off noticing the change. I hear it is normal for a hiss to occur when close to a speaker with hightly efficient/sensitive speakers paired with powerful amps. Any thoughts on this issue? Is this normal?
Thank you

i'm having the exact same problem , a hissss sound from the tweeter , how do i fix this frown.gif
SkyWalker1726 is offline  
post #553 of 981 Old 06-05-2013, 03:40 PM
585-645-1006
 
jdsmoothie's Avatar
 
Join Date: Sep 2007
Location: Orlando, FL
Posts: 43,826
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 715 Post(s)
Liked: 1400
Try resetting the microprocessor. If still no joy you may want to consider replacing the unit (if as you say nothing else changed in the configuration).

---------------------------------
"JD" – jd@avscience.com ; shop.avscience.com ; 585-645-1006, AVScience - Authorized dealer for AV Gear 
Mon - Fri: 8am – 8pm EST (Sat/Sun too, will return call if I don't pick up)
Call for pricing on Denon, Marantz, Yamaha, Onkyo, Klipsch, Def Tech, Oppo, Parasound 
** Think the AVR is defective?  Reset the microprocessor 4-5 times. 
jdsmoothie is online now  
post #554 of 981 Old 06-05-2013, 08:03 PM
Member
 
DrMichael's Avatar
 
Join Date: Apr 2013
Location: Minnesota
Posts: 167
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 21
Quote:
Originally Posted by SkyWalker1726 View Post

hi everyone , i recently upgraded from a Denon 1912 to a SR7007 , but i have a little problem ,
i connected all my speakers to the 7007 using the same cables that i used for my denon 1912 , got my PC and PS3 connected too , but there's a constant noise sound in the background , like when there's nothing playing there's a constant "shhhhhhhhhhhhhhhhhhhhhhhhhhhhhh" sound , as soon as i turn on the Device , coming out of all the speakers . how do i make this noise stop , didn't have it with my denon
any suggestion would be appreciated
thx

EDIT :
i'm having the exact same problem , a hissss sound from the tweeter , how do i fix this frown.gif

So I brought home magnolias sr7007 demo and it does the same thing. I then hooked up the Denon 4520ci and it was dead silent ( didnt love the sound however). I currently have a demo of the Pioneer sc67 and its is dead silent. I just cant get my REL sub to work right in 2ch stereo. So I can say its the Marantz thats hissing/buzzing. Im at a loss on what to do. Thoughts?????mad.gif

Panasonic TC-P65ZT60
Marantz AV8801
Marantz MM8077
Martin Logan Motion 30 Center Channel
Martin Logan Motion 40 Fronts/Rears
REL R-528 SE (2)
Oppo BDP-103D
Playstation 4
Furman ELITE-20 PF i Power Conditioner
DrMichael is offline  
post #555 of 981 Old 06-05-2013, 09:59 PM
Advanced Member
 
Maccur's Avatar
 
Join Date: Oct 2001
Location: NoCal
Posts: 529
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 13
Hissing/buzzing: are we talking about a ground loop or something else? For ground loop, my first suspect is any satellite receiver or cable box.
Maccur is online now  
post #556 of 981 Old 06-06-2013, 05:47 AM
Member
 
DrMichael's Avatar
 
Join Date: Apr 2013
Location: Minnesota
Posts: 167
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 21
Quote:
Originally Posted by Maccur View Post

Hissing/buzzing: are we talking about a ground loop or something else? For ground loop, my first suspect is any satellite receiver or cable box.

No! Its not a ground loop. The noise is there when everything is unplugged from the reciever except the speakers. I did have a ground loop with the cable box before and fixed it with a transformer.

Panasonic TC-P65ZT60
Marantz AV8801
Marantz MM8077
Martin Logan Motion 30 Center Channel
Martin Logan Motion 40 Fronts/Rears
REL R-528 SE (2)
Oppo BDP-103D
Playstation 4
Furman ELITE-20 PF i Power Conditioner
DrMichael is offline  
post #557 of 981 Old 06-06-2013, 03:34 PM
Advanced Member
 
Maccur's Avatar
 
Join Date: Oct 2001
Location: NoCal
Posts: 529
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 13
I was going to suggest disconnecting the cable box from the wall (electrical and digital) just to see.
Maccur is online now  
post #558 of 981 Old 06-07-2013, 01:27 PM
Member
 
LX200GPS12's Avatar
 
Join Date: Aug 2011
Location: London (the big one)
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have finally managed to stream music from my amp today and noticed that the pause/stop button, which is actually the “Enter” button on the remote has no effect on proceedings whatsoever! The other thing is that the pictures being steamed from my NAS were very blurry. Was wondering if anyone else experienced this and what I need to do to fix it.
Thanks.
LX200GPS12 is offline  
post #559 of 981 Old 06-11-2013, 07:05 AM
Newbie
 
kim karomi's Avatar
 
Join Date: May 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by LX200GPS12 View Post

I have finally managed to stream music from my amp today and noticed that the pause/stop button, which is actually the “Enter” button on the remote has no effect on proceedings whatsoever! The other thing is that the pictures being steamed from my NAS were very blurry. Was wondering if anyone else experienced this and what I need to do to fix it.
Thanks.

Have you programmed your source buttons to operate different devices? In that case, check to see that your remote in in AVR mode and not in some device mode. This is pretty much the only thing I can think of for why the Enter button isn't working as it needs to.
kim karomi is offline  
post #560 of 981 Old 06-12-2013, 07:57 AM
Member
 
amairphoto's Avatar
 
Join Date: Mar 2013
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 11
I wish that for the receiver I could change the tone per channel. I would just like to raise the treble just a little on the enter speaker but no where else.
amairphoto is offline  
post #561 of 981 Old 06-12-2013, 09:19 AM
Senior Member
 
erhurd's Avatar
 
Join Date: May 2008
Location: San Diego County, southern California, USA, Planet Earth
Posts: 462
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 37
I found this post regarding the new SR line-up posted by Marantz America in Facebook yesterday morning. Just thought I would share some info regarding Marantz AVRs of the near-future. Here is the link to the article: http://www.audioholics.com/reviews/receivers/marantz-sr5008-sr6008-sr7008

Will post the same in the SR7005 owners thread as well...

Edwin R. Hurd
AVS Forums Lurker-In-Training!

My Tight-space A/V Setup
erhurd is offline  
post #562 of 981 Old 06-17-2013, 12:11 PM
Advanced Member
 
RickPas's Avatar
 
Join Date: Nov 2003
Location: Rhode Island
Posts: 561
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Liked: 10
I'm choosing between the SR-6008 or the 7007 I have Golden Ear Triton 2's and a SVS- pb-12 sub for listening to 2channel....I'm not concerned about Home theatre surround, That will sound fine. I'm more interested in listening to 2channel music....
Any thoughts on these 2 recievers I do have a large room. But I would think there wouldn't be a big diffence between the 110 watts or the 125 watts.....
Thanks for any feedback
Rick

RickP.
RickPas is offline  
post #563 of 981 Old 06-17-2013, 06:48 PM
585-645-1006
 
jdsmoothie's Avatar
 
Join Date: Sep 2007
Location: Orlando, FL
Posts: 43,826
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 715 Post(s)
Liked: 1400
Both will perform equally well ... choose the model that best meets your feature/input/output/budget requirements.

---------------------------------
"JD" – jd@avscience.com ; shop.avscience.com ; 585-645-1006, AVScience - Authorized dealer for AV Gear 
Mon - Fri: 8am – 8pm EST (Sat/Sun too, will return call if I don't pick up)
Call for pricing on Denon, Marantz, Yamaha, Onkyo, Klipsch, Def Tech, Oppo, Parasound 
** Think the AVR is defective?  Reset the microprocessor 4-5 times. 
jdsmoothie is online now  
post #564 of 981 Old 06-18-2013, 11:59 AM
Newbie
 
CypherMK's Avatar
 
Join Date: Jan 2009
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by SkyWalker1726 View Post

hi everyone , i recently upgraded from a Denon 1912 to a SR7007 , but i have a little problem ,
i connected all my speakers to the 7007 using the same cables that i used for my denon 1912 , got my PC and PS3 connected too , but there's a constant noise sound in the background , like when there's nothing playing there's a constant "shhhhhhhhhhhhhhhhhhhhhhhhhhhhhh" sound , as soon as i turn on the Device , coming out of all the speakers . how do i make this noise stop , didn't have it with my denon
any suggestion would be appreciated
thx

EDIT :
i'm having the exact same problem , a hissss sound from the tweeter , how do i fix this frown.gif

See my post on page 9. Also have the same issue. Haven't found a solution however.
CypherMK is offline  
post #565 of 981 Old 06-18-2013, 02:25 PM
Advanced Member
 
RickPas's Avatar
 
Join Date: Nov 2003
Location: Rhode Island
Posts: 561
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Liked: 10
Really stupid question, but looking at back of 6008 does the sub get connected to the sub output pre out? My reciever now just has a sub output...I don't see anything else besides the pre outs and the 7ch analog output for the sub...
Rick

RickP.
RickPas is offline  
post #566 of 981 Old 06-18-2013, 02:44 PM
585-645-1006
 
jdsmoothie's Avatar
 
Join Date: Sep 2007
Location: Orlando, FL
Posts: 43,826
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 715 Post(s)
Liked: 1400
^^
Correct. The sub would be connected to the sub pre-out on an AVR.

---------------------------------
"JD" – jd@avscience.com ; shop.avscience.com ; 585-645-1006, AVScience - Authorized dealer for AV Gear 
Mon - Fri: 8am – 8pm EST (Sat/Sun too, will return call if I don't pick up)
Call for pricing on Denon, Marantz, Yamaha, Onkyo, Klipsch, Def Tech, Oppo, Parasound 
** Think the AVR is defective?  Reset the microprocessor 4-5 times. 
jdsmoothie is online now  
post #567 of 981 Old 06-18-2013, 02:53 PM
Member
 
DrMichael's Avatar
 
Join Date: Apr 2013
Location: Minnesota
Posts: 167
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 21
Quote:
Originally Posted by CypherMK View Post

See my post on page 9. Also have the same issue. Haven't found a solution however.
I also have the same issue....it's the noise floor which is louder than others. I demoed the other brands which were quiet but not nearly as good of sound. I'm trading in the 7007 for the 7008 which has a higher s/n ratio so hopefully it's quieter.

Panasonic TC-P65ZT60
Marantz AV8801
Marantz MM8077
Martin Logan Motion 30 Center Channel
Martin Logan Motion 40 Fronts/Rears
REL R-528 SE (2)
Oppo BDP-103D
Playstation 4
Furman ELITE-20 PF i Power Conditioner
DrMichael is offline  
post #568 of 981 Old 06-19-2013, 08:23 AM
AVS Special Member
 
Selden Ball's Avatar
 
Join Date: Jan 2001
Location: upstate NY
Posts: 6,627
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 140 Post(s)
Liked: 358
If the hissing noise is loud enough to hear at your primary listening position, then that particular receiver is defective.

Selden
Selden Ball is online now  
post #569 of 981 Old 06-22-2013, 09:42 AM
Senior Member
 
William Moore's Avatar
 
Join Date: Apr 2003
Location: Wichita, Kansas
Posts: 465
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 11
Have there been any firmware updates to the SR7007 regarding operational issues or just functionality with streaming, etc. Also, I can't seem to find any "firmware" section at the Marantz website where one can download new firmware, and, is it possible to download firmware to a thumb drive and then load it into the receiver, or does this have to be done with a network connection? Thanks.

William R. Moore
William Moore is offline  
post #570 of 981 Old 06-22-2013, 09:53 AM
585-645-1006
 
jdsmoothie's Avatar
 
Join Date: Sep 2007
Location: Orlando, FL
Posts: 43,826
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 715 Post(s)
Liked: 1400
There was an update released back in March which also can be loaded via USB. The change log is noted in the post below as well as the USB update information in the next post. The 3313CI recently got an update at the end of May so more than likely the 7007 will soon as well.

http://www.avsforum.com/t/1420942/marantz-sr7007-av-receiver-owners-thread/400_100#post_23115962

---------------------------------
"JD" – jd@avscience.com ; shop.avscience.com ; 585-645-1006, AVScience - Authorized dealer for AV Gear 
Mon - Fri: 8am – 8pm EST (Sat/Sun too, will return call if I don't pick up)
Call for pricing on Denon, Marantz, Yamaha, Onkyo, Klipsch, Def Tech, Oppo, Parasound 
** Think the AVR is defective?  Reset the microprocessor 4-5 times. 
jdsmoothie is online now  
Reply Receivers, Amps, and Processors

Tags
Marantz Sr7007 Home Theater Av Receiver
Gear in this thread - Sr7007 by PriceGrabber.com

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off