Elite SC-67 and PS3 compatibility issues regarding Dolby True HD - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 07-21-2012, 02:58 PM - Thread Starter
Member
 
Raikirik's Avatar
 
Join Date: Sep 2010
Posts: 55
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
I've been playing around with a brand new SC-67, using my PS3 as a blu ray player and noticed it has issues when playing Dolby True HD tracks using bitstream. I tried two movies that had problems whenever switching audio tracks during the movie. Those two movies were Transformers DOTM and Kung fu Panda 2. If I would try to switch to say, French or Spanish, there would be no sound and I would be left with the L and R lights on the receiver blinking. Most recently I tried another disc with True HD and the same issue though it occurred even earlier, it happened during the beginning logos and at the menu. I got the same blinking L and R. I believe something happens with the signal coming from the PS3 whenever Dolby tracks are being constantly changed (disc starts with True HD, switches to DD, then True HD and then DD for the menu). I set the PS3 to output LPCM and booted the same discs. I didn't get any problems whatsoever. I attribute it to the fact that it stays in PCM the entire time and doesn't switch tracks constantly. It should be noted that I didn't encounter this problem with DTS HD MA tracks in either bitstream or LPCM from the starting of the disc to the menu, and then playing the movie. The problem with switching audio tracks during the movie also did not occur on DTS HD MA tracks.

I tried to replicate this issue using a standalone blu ray player but had no problems in either bitstream or LPCM modes. It looks like the PS3 has some sort of problem outputting Dolby tracks to these new receivers and the receiver has a hard time trying to find out what's going on. I previously used a SC-57 and this issue was not there. My previous receiver was a Sony STR DG 820 and bitstreaming worked fine there as well. Hopefully a firmware update will correct the issues I'm experiencing with the PS3. It doesn't affect games as far as I can tell as most games are output in PCM and constantly put out that signal. I've tried one game that outputs DD but it stays that way from boot and does not switch tracks and no issues were present.

Update: In the sound settings of the PS3 I went to manual and switched off True HD. This allowed for consistent output of sound but at the loss of having True HD. This is a workaround for being able to bitstream without the sound being output being messed up. Once I switched on True HD again, the the L+R and PCM lights blinked on the receiver and I was not getting sound at the menu of one of my discs.
Raikirik is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 08-07-2012, 01:00 PM
Member
 
jgminder's Avatar
 
Join Date: Dec 2009
Location: Orlando, FL
Posts: 190
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 10
Quote:
Originally Posted by Raikirik View Post

I've been playing around with a brand new SC-67, using my PS3 as a blu ray player and noticed it has issues when playing Dolby True HD tracks using bitstream. I tried two movies that had problems whenever switching audio tracks during the movie. Those two movies were Transformers DOTM and Kung fu Panda 2. If I would try to switch to say, French or Spanish, there would be no sound and I would be left with the L and R lights on the receiver blinking. Most recently I tried another disc with True HD and the same issue though it occurred even earlier, it happened during the beginning logos and at the menu. I got the same blinking L and R. I believe something happens with the signal coming from the PS3 whenever Dolby tracks are being constantly changed (disc starts with True HD, switches to DD, then True HD and then DD for the menu). I set the PS3 to output LPCM and booted the same discs. I didn't get any problems whatsoever. I attribute it to the fact that it stays in PCM the entire time and doesn't switch tracks constantly. It should be noted that I didn't encounter this problem with DTS HD MA tracks in either bitstream or LPCM from the starting of the disc to the menu, and then playing the movie. The problem with switching audio tracks during the movie also did not occur on DTS HD MA tracks.
I tried to replicate this issue using a standalone blu ray player but had no problems in either bitstream or LPCM modes. It looks like the PS3 has some sort of problem outputting Dolby tracks to these new receivers and the receiver has a hard time trying to find out what's going on. I previously used a SC-57 and this issue was not there. My previous receiver was a Sony STR DG 820 and bitstreaming worked fine there as well. Hopefully a firmware update will correct the issues I'm experiencing with the PS3. It doesn't affect games as far as I can tell as most games are output in PCM and constantly put out that signal. I've tried one game that outputs DD but it stays that way from boot and does not switch tracks and no issues were present.
Update: In the sound settings of the PS3 I went to manual and switched off True HD. This allowed for consistent output of sound but at the loss of having True HD. This is a workaround for being able to bitstream without the sound being output being messed up. Once I switched on True HD again, the the L+R and PCM lights blinked on the receiver and I was not getting sound at the menu of one of my discs.

Did you try switching sources and then switching back again? This could verify if it's some HDMI handshake issue for the audio.
jgminder is offline  
Reply Receivers, Amps, and Processors

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off