Denon AVR 3312CI Blinking green light after Play - AVS Forum

AVS Forum > Audio > Receivers, Amps, and Processors > Denon AVR 3312CI Blinking green light after Play

Receivers, Amps, and Processors

birjup's Avatar birjup
12:17 AM Liked: 10
post #1 of 4
09-28-2012 | Posts: 5
Joined: Sep 2012
My 3312CI has been working perfectly for two months now, but all of a sudden, after an hour or two of play the speakers will go in and out, as well as the hdmi out to the tv will be in and out, and the green light blinks. Help
jdsmoothie's Avatar jdsmoothie
04:31 AM Liked: 1894
post #2 of 4
09-28-2012 | Posts: 47,960
Joined: Sep 2007
Check for loose HDMI cable connections, otherwise a flashing "green" power light is not normal operations and may require repair.

Also note there is a dedicated thread for Denon AVR-XX12 model owners linked in my sig. Review posts #3-6 in that thread for additional helpful information.
birjup's Avatar birjup
10:50 AM Liked: 10
post #3 of 4
09-28-2012 | Posts: 5
Joined: Sep 2012
I will check these again. I first noticed it when I was watching netflix on my Apple TV, so I connected that HDMI straight to the TV and it worked fine. I thought the amp may have overheated, although I doubted it. The next day, I was watching tv and the sound was going to the denon via optical out, and it started doing it again, it blinks the green light around the standby button as well as some other things on the display.
jdsmoothie's Avatar jdsmoothie
11:43 AM Liked: 1894
post #4 of 4
09-28-2012 | Posts: 47,960
Joined: Sep 2007
Yeh ... more than likely defective. frown.gif
Tags: Denon Avr3312ci Receiver
Gear in this thread
Reply Receivers, Amps, and Processors

Subscribe to this Thread

Powered by vBadvanced CMPS v3.2.3