Pioneer VSX-822/BIC Acoustech PL-89 Help - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 6 Old 10-24-2012, 04:43 PM - Thread Starter
Newbie
 
ColoradoKMB's Avatar
 
Join Date: Oct 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi,

I just received my new PL-89s today, and got them hooked up. I have to say I am disappointed with the sound so far. I thought that maybe since I am a newbie there may be something I am missing (settings, break-in period). Any advice that is provided would be greatly appreciated.

Thanks!
ColoradoKMB is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 10-24-2012, 07:46 PM
AVS Special Member
 
Knucklehead90's Avatar
 
Join Date: Nov 2008
Location: State of Confusion - 98823
Posts: 7,470
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 68 Post(s)
Liked: 114
Check for correct polarity on the speakers. If you have one wired up backwards from the other it'll sound pretty bad.

When all else fails - RTFM!

♫♫♫ Two Channel Rules! ♫♫♫

GO SEAHAWKS!!!
Knucklehead90 is offline  
post #3 of 6 Old 10-25-2012, 06:27 PM - Thread Starter
Newbie
 
ColoradoKMB's Avatar
 
Join Date: Oct 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Checked the polarity, and they are both hooked up the same. I guess maybe I should clarify; they don't sound horrible they are clear, and both speakers sound the same. They just do not sound like I thought they would. There is no definition to the music, and the bass is not what I would expect it to be from (2) 8" woofers. That's why I thought it might be a setting on the receiver. Any other thoughts would be welcomed.

Thanks,

Kory
ColoradoKMB is offline  
post #4 of 6 Old 10-25-2012, 06:29 PM - Thread Starter
Newbie
 
ColoradoKMB's Avatar
 
Join Date: Oct 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Or maybe the receiver doesn't have the juice to push them?
ColoradoKMB is offline  
post #5 of 6 Old 12-27-2012, 10:46 AM
Member
 
bigjsd's Avatar
 
Join Date: Jan 2008
Posts: 181
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Well your certainly not pushing them with the greatest receiver out there but the BIC's are very efficient and even some of the crappiest amps out there can sound beautiful through an awesome pair of speakers. I would make the assumption that this is your first experience with horn loaded speakers??? If that is the case they can take some getting used to since they are much more of a natural, in your face, unconditioned sound. When I purchased my first set of Klipsch Reference Series speakers about 8 years ago I thought I had made a serious mistake. Now I would never buy anything but a horn loaded speaker. I will say though that I originally powered them with a Yamaha receiver before upgrading to a Denon and the horns sound MUCH better powered by the Denon so the receiver could be the issue still. I recently got a chance to hear the PL-89's for the first time at a holiday party and I was TOTALLY impressed. They were paired with a brand new Onkyo 818 and they were playing music and they sounded beautiful. I am anxious to hear whether you decided to keep these and if they sounded better once they were broke in and you had time to get used to them? I certainly wouldn't make a final judgement without hooking them up to a receiver with bit better build quality than your current Pioneer. Maybe one of the recent Pioneer Elite models with some room correction technology would make these babies sing????
bigjsd is offline  
post #6 of 6 Old 02-12-2013, 08:42 PM
Senior Member
 
metalguy's Avatar
 
Join Date: Apr 2008
Posts: 459
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 36
Quote:
Originally Posted by ColoradoKMB View Post

Checked the polarity, and they are both hooked up the same. I guess maybe I should clarify; they don't sound horrible they are clear, and both speakers sound the same. They just do not sound like I thought they would. There is no definition to the music, and the bass is not what I would expect it to be from (2) 8" woofers. That's why I thought it might be a setting on the receiver. Any other thoughts would be welcomed.

Thanks,

Kory

So did you keep them? what happened?
metalguy is offline  
Reply Receivers, Amps, and Processors

Tags
Bic Acoustech Pl 89 Speakers

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off