TX-NR709 Fried all my speakers - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 6 Old 11-20-2012, 08:19 AM - Thread Starter
Member
 
zwc0442's Avatar
 
Join Date: Jul 2012
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I bought a Onkyo 709 about three months ago and everything had been working fine with it up till a few days ago. Then I was playing a game with the volume around -40db when all the speakers started to make a crackling sound then a very loud pop came from all of them. Then no sound at all. Tried different input sources and nothing so I figured something happened to the receiver. Took it into a shop for warranty repair and got a call yesterday saying everything is fine with it. So I grab my multimeter from work and start checking speakers and all of them are toast. I've got polk monitor 50's for fronts, Cs2 for center and monitor 30's for surrounds. They all have wildly different ohm readings. One will read 24 another 16 and so on. Pulled the drivers out of one cabinet and Checked and one woofer now reads 16 another 60 the tweeter 24. Tried hooking the drivers up seperately to another receiver and they barely play any sound. Just very low and very distorted. Does anyone have an idea on what could have caused this? Thanks for any help.
zwc0442 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 11-20-2012, 10:02 AM
 
runnin''s Avatar
 
Join Date: Jan 2009
Posts: 1,557
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 45
So far all indications are the Onkyo. I'd phone the shop again, and tell them about your speakers.
runnin' is offline  
post #3 of 6 Old 11-20-2012, 11:33 AM - Thread Starter
Member
 
zwc0442's Avatar
 
Join Date: Jul 2012
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I did call them back and he just kept saying that he has no idea how that would happen. I talked to another person and he said possibly the power supply could have done something weird and sent high amperage dc power out to all the speakers which could have fried them all so quickly.
zwc0442 is offline  
post #4 of 6 Old 11-20-2012, 11:46 AM
AVS Addicted Member
 
arnyk's Avatar
 
Join Date: Oct 2002
Location: Grosse Pointe Woods, MI
Posts: 14,387
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 763 Post(s)
Liked: 1178
Quote:
Originally Posted by zwc0442 View Post

I bought a Onkyo 709 about three months ago and everything had been working fine with it up till a few days ago. Then I was playing a game with the volume around -40db when all the speakers started to make a crackling sound then a very loud pop came from all of them. Then no sound at all. Tried different input sources and nothing so I figured something happened to the receiver. Took it into a shop for warranty repair and got a call yesterday saying everything is fine with it. So I grab my multimeter from work and start checking speakers and all of them are toast. I've got polk monitor 50's for fronts, Cs2 for center and monitor 30's for surrounds. They all have wildly different ohm readings. One will read 24 another 16 and so on. Pulled the drivers out of one cabinet and Checked and one woofer now reads 16 another 60 the tweeter 24. Tried hooking the drivers up seperately to another receiver and they barely play any sound. Just very low and very distorted. Does anyone have an idea on what could have caused this? Thanks for any help.

When you say read 24 and 16 and so on, what are you referring to? Ohms?
arnyk is offline  
post #5 of 6 Old 11-20-2012, 11:57 AM - Thread Starter
Member
 
zwc0442's Avatar
 
Join Date: Jul 2012
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by arnyk View Post

When you say read 24 and 16 and so on, what are you referring to? Ohms?

Yes ohms.
zwc0442 is offline  
post #6 of 6 Old 11-20-2012, 08:37 PM - Thread Starter
Member
 
zwc0442's Avatar
 
Join Date: Jul 2012
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Could the receiver had sent out DC power to all the outputs? Ive been searching everywhere online and thats the only explanation that I have come across that makes sense. There are a couple other threads online that something similar has happened. So I'm guessing if the receiver did it once it would be a good possibility that it could do it again?
zwc0442 is offline  
Reply Receivers, Amps, and Processors

Tags
Onkyo Tx Nr709
Gear in this thread - Nr709 by PriceGrabber.com

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off