Denon 1913 - Audio & Video not working - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!

Forum Jump: 
Thread Tools
post #1 of 2 Old 11-26-2012, 06:52 PM - Thread Starter
IdolHandz's Avatar
Join Date: Nov 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I am having problems with a new Denon 1913. After connecting it and finishing the setup, the system was operating okay (except for network functions). Then, the unit prompted me to update. I accepted and waited. After about two hours of waiting, I realized that the unit dropped it's network connection. I turned the unit off and then back on. The unit was on autopilot to retry the update. After reading a few threads on this site, I took some of the advice and went to bed to allow the unit to update overnight. I woke up to the unit continuing the attempt to update. I shut it off thinking that the update was pointless. I tried to do a network reset, but it doesn't reset anything. It blinks three times as if it were going to reset the unit, but it never prompts me for the language like it did when I first set the unit up.

By the way, what's wrong with this model's network card? I have a rock solid network (lan and wan) and this unit crapped out every few minutes on the network functions (internet radio and pandora). This is why I finally opted to update the unit - thought it was a fix to the crappy network card issue.

Thanks in advance!

If it helps, the AVR is the only unit in this system. Nothing else is connected other than the TV and speakers.
IdolHandz is offline  
Sponsored Links
post #2 of 2 Old 11-27-2012, 04:15 AM
jdsmoothie's Avatar
Join Date: Sep 2007
Location: Orlando, FL
Posts: 55,842
Mentioned: 88 Post(s)
Tagged: 0 Thread(s)
Quoted: 6247 Post(s)
Liked: 3010
Try unplugging the AVR for a few minutes and then give the update another try. Otherwise you may want to try using a different router or exchanging the unit.

"JD" - Sales - Call 585-645-1006 for setup and pricing discussion 8am - 8pm EST daily
Authorized dealer: Denon, Marantz, Yamaha, Onkyo, Def Tech, Atl Tech, Parasound, Oppo

Think you have a defective AVR? Owner's manual - Factory reset 4-5 times in a row.
jdsmoothie is offline  
Sponsored Links
Reply Receivers, Amps, and Processors

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off