"OFFICIAL" Pioneer SC-1222-K Owners Thread - Page 52 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 5Likes
Reply
 
Thread Tools
post #1531 of 1535 Old 08-24-2017, 01:15 PM
Newbie
 
Join Date: Aug 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
Hey, everyone.

I was hoping someone could help me. My Pioneer SC-1222-K receiver just stopped working for some reason. When I tried to turn it on nothing happened. I took the cover off and checked all of the fuses and everything is good. When I put the cover back on and plugged it back in I decided to hold the power button down and the unit turned on and displays 'POWER ON' although will not do anything else. If you hit the power button again it turns off but in order to turn it back on you need to hold the power button down for a period of time.

Any idea whats wrong? Is the receiver still salvageable? Not sure what to do and any help would be appreciated!

-Brenton
Brenton Watkajtys is offline  
Sponsored Links
Advertisement
 
post #1532 of 1535 Old 08-24-2017, 02:19 PM
AVS Forum Special Member
 
LastButNotLeast's Avatar
 
Join Date: Feb 2007
Location: 08077
Posts: 8,349
Mentioned: 35 Post(s)
Tagged: 1 Thread(s)
Quoted: 1804 Post(s)
Liked: 1416
Try a factory reset:
https://www.techwalla.com/articles/h...neer-receivers
Michael

Did you really need to quote that entire post in your reply?
Downloadable FREE demo discs: Demonstration Blu-Ray Discs (Independently Authored)
Welcome to AVS - Get out while you still can!
Don't guess, measure: Getting Started With REW: A Step-by-Step Guide
LastButNotLeast is offline  
post #1533 of 1535 Old 09-04-2017, 05:24 PM
Newbie
 
Join Date: Sep 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
Ok im going nuts. I have a pioneer SC1222-K. Just had to send it in to get warranty work done and they reset to factory default. Since i got it back i have not been able to use the iControlAV app on my phone nor iPad. So ithought i would update it. There is an update. Now my issue is, the receiver wont recognise ANY usb i put in it as having the update file in it. And this update cant be done over the internet. Anyone have any ideas? All usb devices ive tried were empty with only the unzipped update file on it.

Sent from my SM-N920V using Tapatalk
regalscenter77 is offline  
 
post #1534 of 1535 Old 09-04-2017, 05:41 PM
Advanced Member
 
scoobdude's Avatar
 
Join Date: Mar 2007
Posts: 512
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 59 Post(s)
Liked: 30
What format and what size is the USB?

For the app did you make sure you have it set to DHCP or in a range of statics that is available on your network? Also did you verify the network settings were turned on? Not sure how good you are with computers and bettering but there is a way to send commands via command prompt.

Sent from my Pixel using Tapatalk
scoobdude is offline  
post #1535 of 1535 Old 09-05-2017, 10:20 AM
AVS Forum Special Member
 
LastButNotLeast's Avatar
 
Join Date: Feb 2007
Location: 08077
Posts: 8,349
Mentioned: 35 Post(s)
Tagged: 1 Thread(s)
Quoted: 1804 Post(s)
Liked: 1416
Try reformatting the USB drive to a different format (I almost went with "formatting format," but I think you know what I mean).
Michael

Did you really need to quote that entire post in your reply?
Downloadable FREE demo discs: Demonstration Blu-Ray Discs (Independently Authored)
Welcome to AVS - Get out while you still can!
Don't guess, measure: Getting Started With REW: A Step-by-Step Guide
LastButNotLeast is offline  
Sponsored Links
Advertisement
 
Reply Receivers, Amps, and Processors

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off