*Official* Pioneer SC-1522 9.2 Network ready AV receiver owners thread - Page 63 - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!



Forum Jump: 
 6Likes
Reply
 
Thread Tools
post #1861 of 1879 Old 02-29-2016, 04:26 PM
Senior Member
 
teeitup's Avatar
 
Join Date: Mar 2006
Location: Washington State
Posts: 471
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 112 Post(s)
Liked: 45
Quote:
Originally Posted by JChin View Post
Don't sound good. Could check one more thing, unplug power cord then remove the receiver top cover and see if a fuse is blown.
Good idea. I was looking through the vents and if I remember correctly there are a bunch of fuses in this thing. Solid state electronics!!

Sent from my LG-LS980 using Tapatalk
teeitup is offline  
Sponsored Links
Advertisement
 
post #1862 of 1879 Old 02-29-2016, 04:29 PM
Senior Member
 
teeitup's Avatar
 
Join Date: Mar 2006
Location: Washington State
Posts: 471
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 112 Post(s)
Liked: 45
Quote:
Originally Posted by JChin View Post
Don't sound good. Could check one more thing, unplug power cord then remove the receiver top cover and see if a fuse is blown.
Good idea. I was looking through the vents and if I remember correctly there are a bunch of fuses in this thing. Solid state electronics!!
teeitup is offline  
post #1863 of 1879 Old 03-06-2016, 04:14 PM
Advanced Member
 
Menasor's Avatar
 
Join Date: Oct 2008
Location: SF Bay Area
Posts: 751
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Liked: 19
Hey for those who were able to get 1440p output to their sc1522k, how were you able to do so? I tried with my GTX970 and there's no option for 1440p display. The highest is 1080p/60. The receiver is connected to my Vizio M75-C1 which should be able to handle this resolution as well as 4K

Vizio M75-C1
Ascend Sierra-1
Ascend Sierra-1 Center
Ascend HTM-200 SE
SVS PC12-NSD
Pioneer SC-1522-K
Menasor is offline  
post #1864 of 1879 Old 03-17-2016, 11:32 AM
SMG
Member
 
SMG's Avatar
 
Join Date: Oct 2001
Location: San Jose CA
Posts: 110
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 10
Hi All,

I have a chance to get this receiver for $300.00 from a private party. This person bought in end of 2012 from New Egg for $1071.00 - has receipt.

Would you guys recommend at this price point? I'm upgrading from my trusty 12 yr. old Denon 3201 - still going strong, but wouldn't mind upgrading with HDMI - better video processing etc.

Besides the HDCP 2.2 lacking, any thing else I need to watch out for? I wasn't really planning to upgrade right now, this deal sort of fell in my lap. Already have the green light from my CTO to get a 4k display this Christmas ;-) I think I can work around the HDCP 2.2 issue by going direct from source to display if needed.

Should I get this now, or hold out for a more current unit with all the new standards?

Thanks in advance,
Serv

Last edited by SMG; 03-17-2016 at 02:31 PM.
SMG is offline  
post #1865 of 1879 Old 03-18-2016, 01:25 AM
Member
 
masterslacker's Avatar
 
Join Date: Aug 2004
Posts: 76
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Liked: 12
I would jump at this deal because I just "lightening just ate mine" if it were me as the $300 is a nice replacement cost. And to go 9.2 these days it's $1K for the Pioneer and everything else is more expensive...at least in my research so far to replace this unit.

I paid $600 in 2013 so I'm not out a ton of money but more the functionality of 9.2 at that cost just can't be beat IMHO.

Quote:
Originally Posted by SMG View Post
Hi All,

I have a chance to get this receiver for $300.00 from a private party. This person bought in end of 2012 from New Egg for $1071.00 - has receipt.

Would you guys recommend at this price point? I'm upgrading from my trusty 12 yr. old Denon 3201 - still going strong, but wouldn't mind upgrading with HDMI - better video processing etc.

Besides the HDCP 2.2 lacking, any thing else I need to watch out for? I wasn't really planning to upgrade right now, this deal sort of fell in my lap. Already have the green light from my CTO to get a 4k display this Christmas ;-) I think I can work around the HDCP 2.2 issue by going direct from source to display if needed.

Should I get this now, or hold out for a more current unit with all the new standards?

Thanks in advance,
Serv
ALtlOff likes this.
masterslacker is offline  
post #1866 of 1879 Old 03-26-2016, 05:06 PM
SMG
Member
 
SMG's Avatar
 
Join Date: Oct 2001
Location: San Jose CA
Posts: 110
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 10
Thanks Masterslacker. Bought the receiver, the sound is definitely very airy and open compared to my Denon. I'm having a couple of problems.

1. I have a ethernet cable plugged in, but can't access any network features or get the iPhone App to work? Is there a different thread on this topic?

2. In my Denon, even when listening to a stereo source such as Pandora (through my Tivo), the SUB was always working. In the Pioneer, i can't get the SUB to come on when listening to music. It only shows the L and R speakers on the display. I've played around with all the surround choices. I don't know what I"m doing wrong.

thanks,
Serv
SMG is offline  
post #1867 of 1879 Old 03-26-2016, 10:37 PM
Member
 
masterslacker's Avatar
 
Join Date: Aug 2004
Posts: 76
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Liked: 12
Quote:
Originally Posted by SMG View Post
Thanks Masterslacker. Bought the receiver, the sound is definitely very airy and open compared to my Denon. I'm having a couple of problems.

1. I have a ethernet cable plugged in, but can't access any network features or get the iPhone App to work? Is there a different thread on this topic?

2. In my Denon, even when listening to a stereo source such as Pandora (through my Tivo), the SUB was always working. In the Pioneer, i can't get the SUB to come on when listening to music. It only shows the L and R speakers on the display. I've played around with all the surround choices. I don't know what I"m doing wrong.

thanks,
Serv
Mine stopped working with the iPhone app and such when I upgraded my router...I figured if a complete reset would get it back to working but not sure.

Good luck...
masterslacker is offline  
post #1868 of 1879 Old 03-27-2016, 11:22 PM
SMG
Member
 
SMG's Avatar
 
Join Date: Oct 2001
Location: San Jose CA
Posts: 110
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 10
Quote:
Originally Posted by masterslacker View Post
Mine stopped working with the iPhone app and such when I upgraded my router...I figured if a complete reset would get it back to working but not sure.

Good luck...
Ok, another question. My Denon had an 'All Stereo' mode, that I could use with any type of source, stereo or otherwise. I can't find anything like that in the Pioneer. My wife likes to turn on the rear surrounds for most of the TV shows, and I can't figure it out.

Help...
SMG is offline  
post #1869 of 1879 Old 03-28-2016, 12:08 AM
AVS Special Member
 
JChin's Avatar
 
Join Date: Oct 2008
Location: Mesquite Tx
Posts: 9,080
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 322 Post(s)
Liked: 197
Quote:
Originally Posted by SMG View Post
Ok, another question. My Denon had an 'All Stereo' mode, that I could use with any type of source, stereo or otherwise. I can't find anything like that in the Pioneer. My wife likes to turn on the rear surrounds for most of the TV shows, and I can't figure it out.

Help...
Hi SMG, pioneer would be "extended stereo".
JChin is online now  
post #1870 of 1879 Old 03-30-2016, 12:23 PM
Member
 
mmbond's Avatar
 
Join Date: Jul 2001
Location: Los angeles
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 10
Hey guys: Just bought the Denon X4200 at a great price to upgrade from a Pioneer SC-1522-k which I thought was having handshake issues, but I later determined is not and works perfectly. I got the Denon X4200 for $899, but I'm not sure how much of an improvement it is and whether or not I should ditch the perfectly fine Pioneer for the new Denon. Any thoughts are greatly appreciated!
mmbond is offline  
post #1871 of 1879 Old 04-02-2016, 02:22 PM
Newbie
 
Join Date: Jan 2016
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 1
My SC-1522 has recently started losing the network connection. That just kills any chance I have of using Pandora in the backyard through Zone 2. Are many (or any) of you seeing the same problem? This started as I get into my third year of owning this unit. And any of you who got that UE22 ? Error code ..... Did the problems start with dropping network connections? I fear the beginning of the end.


Sent from my iPad using Tapatalk
unclepp is offline  
post #1872 of 1879 Old 04-03-2016, 10:10 AM
Member
 
azeemtn's Avatar
 
Join Date: Apr 2013
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by unclepp View Post
My SC-1522 has recently started losing the network connection. That just kills any chance I have of using Pandora in the backyard through Zone 2. Are many (or any) of you seeing the same problem? This started as I get into my third year of owning this unit. And any of you who got that UE22 ? Error code ..... Did the problems start with dropping network connections? I fear the beginning of the end.


Sent from my iPad using Tapatalk
Mine as well. All day yesterday. Very annoying.
I'm also having a harder and harder time getting the iPhone App to connect to it.

There are no more updates coming from Pioneer it seems, so this is pretty much it...
azeemtn is offline  
post #1873 of 1879 Old 04-03-2016, 12:09 PM
Member
 
mooonshine199's Avatar
 
Join Date: Mar 2013
Location: San Diego
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 13
The mobile app was recently updated and the update broke the app. If you go to the app store and look at the reviews everyone is saying the same thing. They released an update for the 2016 products and now it appears the app is non functional for many many users....including myself. The good news is they are still updating the app. The bad news is they need to update it again before any of us can use it.... This has rendered my zone 2 useless as well. I think it might be time to switch brands. This amp isn't bad as far as sound quality and hardware goes, but the software in the unit as well as the app have likely made me never buy any Panasonic electronics again. Not only is the interface overly complicated with its childish balls, and the need to press 13 buttons just to get zone 2 up and playing Pandora, but it fails to even do what it's built to do with the apps intermittent connectivity issues ....
mooonshine199 is offline  
post #1874 of 1879 Old 04-07-2016, 06:00 PM
Member
 
IronWaffle's Avatar
 
Join Date: Jan 2010
Location: Maryland
Posts: 60
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Liked: 14
*Official* Pioneer SC-1522 9.2 Network ready AV receiver owners thread

I'm not sure what to make of this, but tonight I noticed my receiver doesn't recognize the subwoofer connected to it.

Less than a week ago I re-ran MCACC when adding two back channels and there was no problem. The system has been largely unused since, so not sure when/what happened.

Hopefully I can tackle it this weekend but in the meantime I'd love some tips if anyone has ideas or logical questions that might help me solve this.

Basic details:
  • Subwoofer can be powered on but only manually, whereas normally it comes on with the receiver
  • Subwoofer has disappeared from "Status" view of iPad app
  • I just ran an MCACC demo and all speakers are recognized EXCEPT the subwoofer, even when I've manually powered it up.
  • I don't believe it's the cable -- but could it be the cable? How can I safely check that?

I'm not ready to pull the trigger on an AV receiver upgrade, though my subwoofer has been the underpowered link in my chain for a few years. Still, I'd rather not have to replace anything until I can afford to do it right.

I bought this 1522, like many here I suspect, during the big Costco sale a few years ago. I've had no significant problems until now. Not sure where this falls into their generous guarantee policy. I'd rather not find out. I just want to hear some Millennium Falcon goodness this weekend!

Thanks in advance for any bits of wisdom.


Pioneer SC-1522 Receiver | Oppo 93 Blu-Ray Player | Samsung 65JS850D UHDTV
PSB Imagine T2, C Centre & Image S5 Surround | SVS SB-2000 Subwoofer
Mac mini (2012) iTunes Server | Arcam rDAC

Last edited by IronWaffle; 04-07-2016 at 06:05 PM.
IronWaffle is online now  
post #1875 of 1879 Old 04-08-2016, 10:01 AM
Senior Member
 
Pioneer_Elte's Avatar
 
Join Date: Jun 2012
Posts: 380
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 64 Post(s)
Liked: 56
Quote:
Originally Posted by IronWaffle View Post
I'm not sure what to make of this, but tonight I noticed my receiver doesn't recognize the subwoofer connected to it.

Less than a week ago I re-ran MCACC when adding two back channels and there was no problem. The system has been largely unused since, so not sure when/what happened.

Hopefully I can tackle it this weekend but in the meantime I'd love some tips if anyone has ideas or logical questions that might help me solve this.

Basic details:
  • Subwoofer can be powered on but only manually, whereas normally it comes on with the receiver
  • Subwoofer has disappeared from "Status" view of iPad app
  • I just ran an MCACC demo and all speakers are recognized EXCEPT the subwoofer, even when I've manually powered it up.
  • I don't believe it's the cable -- but could it be the cable? How can I safely check that?

I'm not ready to pull the trigger on an AV receiver upgrade, though my subwoofer has been the underpowered link in my chain for a few years. Still, I'd rather not have to replace anything until I can afford to do it right.

I bought this 1522, like many here I suspect, during the big Costco sale a few years ago. I've had no significant problems until now. Not sure where this falls into their generous guarantee policy. I'd rather not find out. I just want to hear some Millennium Falcon goodness this weekend!

Thanks in advance for any bits of wisdom.
Have you ruled out that it's not the subwoofer that is having the issues?

I had a similar situation with my 1522 and my JBL sub, then I would get an loud hum out of the subwoofer (like it had a grounding issue) even with the rca cable unplugged. Well I took the subwoofer apart, found the repair manual online and brought the unit into work. We looked it over and replaced the caps with brand new Panasonic caps simple fix under $5. The lab tech also looked at all the solder joints and fixed a couple suspect ones that look cracked.

Took the sub's main board home and everything worked again.

I know it may be tough, but if you have the ability to either swap out subs or try your sub at a friends house it will quickly pinpoint which is the problem child.

Pioneer_Elte is offline  
post #1876 of 1879 Old 04-08-2016, 10:18 AM
Member
 
IronWaffle's Avatar
 
Join Date: Jan 2010
Location: Maryland
Posts: 60
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Liked: 14
Thanks for the post. My response is interspersed below...

Quote:
Originally Posted by Pioneer_Elte View Post
Have you ruled out that it's not the subwoofer that is having the issues?
Unfortunately, I haven't ruled anything out at all yet. I added a new subwoofer cable to an Amazon Prime order that should be here tonight. I really doubt that's the issue but I can afford it and rule that out as part of the issue.

Quote:
I had a similar situation with my 1522 and my JBL sub, then I would get an loud hum out of the subwoofer (like it had a grounding issue) even with the rca cable unplugged. Well I took the subwoofer apart, found the repair manual online and brought the unit into work. We looked it over and replaced the caps with brand new Panasonic caps simple fix under $5. The lab tech also looked at all the solder joints and fixed a couple suspect ones that look cracked.

Took the sub's main board home and everything worked again.
Thanks for sharing this. It's out of my skill set, though. I may have to try this at some point but I tend to break things when trying to fix them. None of my real-world friends would be up to the task either.

Quote:
I know it may be tough, but if you have the ability to either swap out subs or try your sub at a friends house it will quickly pinpoint which is the problem child.
This isn't an option. Yet. I plan to post for subwoofer recommendations to suit my PSBs in a few minutes. If I can find the recommendation locally then I might buy and see what happens. If it works, then great -- I'll keep the new sub in the main system and if I can repair the old one I'll move it to my old one in the bedroom. I've been wanting to upgrade for awhile and can justify the expense. If it doesn't work then I'll be left to assume it's the receiver.

First world problems.


Pioneer SC-1522 Receiver | Oppo 93 Blu-Ray Player | Samsung 65JS850D UHDTV
PSB Imagine T2, C Centre & Image S5 Surround | SVS SB-2000 Subwoofer
Mac mini (2012) iTunes Server | Arcam rDAC
IronWaffle is online now  
post #1877 of 1879 Old 05-16-2016, 08:42 AM
Member
 
Leander311's Avatar
 
Join Date: May 2010
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 13
Greetings!

After picking up the SC-1522 as so many of you did via Costco a few years back, I've finally an impetus to revive it from bedroom HT duty into my main living area, which currently uses an older Pioneer Elite VSX-23 (Decently-hefty AB topology)... The reason? I'm upgrading to some "big boy" mains - Axiom M80HP's - from the Polk Monitor 70's I've had for about 6 years. The older VSX-23 isn't spec'd down to 4-ohm duty, so the SC-1522 should be a nice swap for this application.

The similarly-spec'd SC-68 exhibited favorable test bench numbers: http://www.soundandvision.com/conten...kuV9rTuO8vz.97

Yes, the Elite SC-65 is the non-Elite SC-1522's direct comparison, but the SC-68's advertised power numbers are at least in the same ballpark:
http://www.pioneerelectronics.com/ep...le%20Sheet.pdf
http://www.pioneerelectronics.com/ep...le%20Sheet.pdf
http://www.pioneerelectronics.com/ep...le%20Sheet.pdf

I'm assuming with each channels' discrete amplifiers, the SC-1522 will operate more cleanly in bi-amp configuration to the mains, but wanted to see if anyone here had experience with this vs. traditional wiring (1 channel per L/R main), especially into 4-ohm loads. Eventually, and maybe sooner than later if I have the connectivity gremlins others here have mentioned, I imagine upgrading to dedicated amps, but in the meantime would like the upgrade in speakers to be as meaningful as possible.

Many Thanks,
Nick
Leander311 is offline  
post #1878 of 1879 Old 05-16-2016, 08:52 AM
Member
 
Leander311's Avatar
 
Join Date: May 2010
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 13
(subscribing)
Leander311 is offline  
post #1879 of 1879 Old 07-25-2016, 08:35 PM
Member
 
stopdrpnro's Avatar
 
Join Date: May 2007
Posts: 99
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Liked: 11
Haven't visited the thread since we hit page 50 or so but since it share internals with a few other models is there any hope of modding the firmware for atmos?
stopdrpnro is offline  
Sponsored Links
Advertisement
 
Reply Receivers, Amps, and Processors

Tags
Pioneer Sc 1522k 9 2 Channel Av Receiver
Gear in this thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off