Calling Al Rotel RA1520 owners - Overheating? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 04-06-2013, 03:25 PM - Thread Starter
Newbie
 
SirVenom's Avatar
 
Join Date: Apr 2013
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi Folks,

I am having issues with my Rotel RA150. It is overheating. The amp is connected to B&W CM9s and as you can see on the video below volume knob is less then half.

Amp is 2 months old and sitting on top of my Tv unit. Air circulation is not restricted.

Just to confirm that this is temperature related used a fan and plays for hours with no problems.

Room temp is around 27 C degrees.

In your experience, Is this normal or should I start calling the shop for an RMA?

http://www.youtube.com/watch?feature=player_embedded&v=eoc-75fnP_k
SirVenom is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 04-06-2013, 09:19 PM
AVS Special Member
 
Brian B's Avatar
 
Join Date: Oct 1999
Location: Los Angeles, CA
Posts: 1,314
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 25
Maybe it doesn't like your taste in music?

I would get it replaced...

B.
Brian B is offline  
post #3 of 3 Old 04-06-2013, 11:16 PM - Thread Starter
Newbie
 
SirVenom's Avatar
 
Join Date: Apr 2013
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hahaha if that is the case I agree. Nirvana is not my cup of tea either. I just used that one for testing purposes...
SirVenom is offline  
Reply Receivers, Amps, and Processors

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off