Center channel audio missing when playing Blu-Ray - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!

Forum Jump: 
Thread Tools
post #1 of 2 Old 10-25-2013, 09:09 AM - Thread Starter
gajahduduk's Avatar
Join Date: May 2011
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I recently replaced a Samsung blu-ray player with a Sony BDP-S5100. It's connected through a 5.1 channel Pioneer Elite AV receiver in the VSX line. I'm using the same HDMI cable to connect the new blu-ray player to the receiver as the old one used.

The odd thing is that whenever I play a Blu-Ray disc, the center channel audio does not play. I can resolve this simply by turning the receiver off and on again.

Any idea what the deal is? This was not a problem with the old DVD player (which had other more serious problems which is why I replaced it.)

This problem only seems to happen when playing a Blu-Ray disc, not with regular DVDs or streaming video. Also I could be crazy but it seems to happen only with main feature content, not with preview content on the disc.
gajahduduk is offline  
Sponsored Links
post #2 of 2 Old 11-05-2013, 12:31 PM
Advanced Member
unavol's Avatar
Join Date: Aug 2007
Location: AL
Posts: 709
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 33 Post(s)
Liked: 46
I recently got a Sony s5100 and I had a similar occurance. I'm also using a Pioneer Elite AVR. My trouble was with the subwoofer not getting a signal. I don't use a center channel so I don't know if it happened there. Does it happen all the time with yours? At first I was afraid my AVR was going bad, but it only happened once so I assumed it was just a glitch. I wonder if it's a problem?

There's nothing to see here.
unavol is offline  
Reply Receivers, Amps, and Processors

Sony Bdp S5100 3d Blu Ray Disc Player With Wi Fi
Gear in this thread - S5100 by

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off