Sherwood Newcastle R-972 HDMI problems - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 5 Old 11-23-2013, 03:42 PM - Thread Starter
Newbie
 
steve2150's Avatar
 
Join Date: Nov 2013
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

Have the Sherwood R-972 using Dish Network, the HDMI keeps cutting out picture and audio. My software is the one it came with 1.4.

steve2150 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 11-23-2013, 11:03 PM
AVS Special Member
 
Stereojeff's Avatar
 
Join Date: Oct 2000
Location: Whittier, CA USA
Posts: 1,525
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 22
How long is your HDMI cable? Which HDMI input are you using?

Jeff
Stereojeff is offline  
post #3 of 5 Old 11-24-2013, 04:35 AM - Thread Starter
Newbie
 
steve2150's Avatar
 
Join Date: Nov 2013
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
From the dish receiver 6' and from the R-972 to tv 10'
steve2150 is offline  
post #4 of 5 Old 11-25-2013, 06:34 AM
AVS Special Member
 
Stereojeff's Avatar
 
Join Date: Oct 2000
Location: Whittier, CA USA
Posts: 1,525
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 22
I also have a DISH network receiver with the R-972 and the installation is virtually fool-proof. I may need to reboot the receiver once or twice a year. Beyond that, the only issue is the 5 second wait for sound after the picture synchs in.

Your cable runs are reasonable and should not be an issue. You may want to try a different HDMI input on the R-972 as I understand they are not identical.

Beyond that, I recommend you consult with Sherwood tech support. Eugene at sherwoodamerica dot com.

Jeff
Stereojeff is offline  
post #5 of 5 Old 12-08-2013, 05:38 AM - Thread Starter
Newbie
 
steve2150's Avatar
 
Join Date: Nov 2013
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Just got my 2nd Sherwood Newcastle R-972 yesterday as I changed my HDMI cable problem solved with Dish. The 2nd has Blu-Ray problem. Just purchased my 2nd Sherwood Newcastle R-972 for my 2nd room, have the 1st about 1 1/2 years. With the new one playing a blu-ray only plays stereo not surround using hdmi. Same brand player, so I took the player and hdmifrom the first and connected it to the 2nd still only stereo while it played surround on the 1st. Noticed when first starting the new one the on screen menu froze so I shut it off and unplugged then the menu worked, doing trinnov it did not recognize the right front and left surround as no sound out of them but redid trinnov and then it worked. Tried different hdmi inputs, does surround with satellite hdmi input. The instruction manual is lacking. Which amp setting to use on 2nd bi-amp, surround back, on 1st 7 speakers on 2nd 5 speakers. Wonder if my 2nd is defective?
steve2150 is offline  
Reply Receivers, Amps, and Processors

Tags
Sherwood Newcastle R 972

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off