Sherwood Newcastle R-972 Blu-Ray Problem - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!

Forum Jump: 
Thread Tools
post #1 of 1 Old 12-08-2013, 05:40 AM - Thread Starter
steve2150's Avatar
Join Date: Nov 2013
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Just purchased my 2nd Sherwood Newcastle R-972 for my 2nd room, have the 1st about 1 1/2 years. With the new one playing a blu-ray only plays stereo not surround using hdmi. Same brand player, so I took the player and hdmifrom the first and connected it to the 2nd still only stereo while it played surround on the 1st. Noticed when first starting the new one the on screen menu froze so I shut it off and unplugged then the menu worked, doing trinnov it did not recognize the right front and left surround as no sound out of them but redid trinnov and then it worked. Tried different hdmi inputs, does surround with satellite hdmi input. The instruction manual is lacking. Which amp setting to use on 2nd bi-amp, surround back, on 1st 7 speakers on 2nd 5 speakers. Wonder if my 2nd is defective?
steve2150 is offline  
Sponsored Links
Reply Receivers, Amps, and Processors

Sherwood Newcastle R 972

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off