Optical audio on Sony STR-DH540 - AVS Forum
Forum Jump: 
 
Thread Tools
Old 02-03-2014, 06:20 PM - Thread Starter
Member
 
nelluk's Avatar
 
Join Date: Feb 2014
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

I'm trying to set up my STR-DH540 to take the optical audio out from my TV for over the air broadcasts. 

There is an HDMI cable from the receiver's TV port to the TV HDMI input. (ideally I'd use HDMI-ARC, but it seems buggy. See my other thread http://www.avsforum.com/t/1515656/samsung-smart-tv-un40f6300-unreliable-hdmi-arc )

Optical cable from TV's optical out to receiver's opt-in #2.

 

When receiver is in 'TV" mode, I can't get the audio. When I press 'input mode' it is permanently in 'Analog' mode for whatever reason. Nothing changes when I hit the button and it almost looks 'greyed out'.

 

If I change to any other receiver input, I can hit 'input mode' until it says Optical, and then I can hear the TV audio as expected.

 

So basically, is there any way to get this thing to use optical audio when the receiver is in 'TV" mode?

nelluk is offline  
Sponsored Links
Advertisement
 
Old 02-04-2014, 01:07 AM
AVS Special Member
 
kikkenit2's Avatar
 
Join Date: Nov 2006
Location: Redondo Beach, CA
Posts: 1,553
Mentioned: 1 Post(s)
Tagged: 1 Thread(s)
Quoted: 136 Post(s)
Liked: 97
Check out "Audio Input Assign" on page 51/52 of the manual.
kikkenit2 is offline  
Old 02-04-2014, 05:33 AM - Thread Starter
Member
 
nelluk's Avatar
 
Join Date: Feb 2014
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

Yeah, tried that. 'TV" input seems to be the only input that you can't assign audio to. It is missing from the on-screen menu, and the chart from page 52. 

Which is strange because page 22 says that is what you need to do to use optical from your TV.

nelluk is offline  
Old 02-04-2014, 01:22 PM
AVS Special Member
 
kikkenit2's Avatar
 
Join Date: Nov 2006
Location: Redondo Beach, CA
Posts: 1,553
Mentioned: 1 Post(s)
Tagged: 1 Thread(s)
Quoted: 136 Post(s)
Liked: 97
Receiver page 22 states set tv audio out to fixed and set receiver hdmi audio out
to TV+AMP in the hdmi settings menu. Have you done both of those?

Also look for hdmi control or hdmi cec and try turning that and arc off in both devices.
kikkenit2 is offline  
Old 02-04-2014, 01:45 PM - Thread Starter
Member
 
nelluk's Avatar
 
Join Date: Feb 2014
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

I don't think setting TV audio out to 'fixed' applies to me. The word 'fixed' does not appear in the entire manual for my TV (http://downloadcenter.samsung.com/content/UM/201308/20130813132610569/[ENG_US]X12ATSCF-1.119.pdf) Anyway, I know the TV is outputting its audio.

 

CEC is off in both devices. Arc is off on the TV (audio out set to External speakers). I don't think the receiver has an ARC setting specifically beyond the Input Mode which doesn't seem to work on this input only.

 

It's really just an aesthetic thing at this point, having to push a non-TV button on the remote to activate TV audio. But I am replacing the remote with a Harmony remote today, so..

nelluk is offline  
Old 02-05-2014, 01:13 AM
AVS Special Member
 
kikkenit2's Avatar
 
Join Date: Nov 2006
Location: Redondo Beach, CA
Posts: 1,553
Mentioned: 1 Post(s)
Tagged: 1 Thread(s)
Quoted: 136 Post(s)
Liked: 97
You are correct. ARC is only controlled by cycling through the Input Mode. I am stumped.
kikkenit2 is offline  
Old 02-05-2014, 07:38 AM
AVS Special Member
 
JChin's Avatar
 
Join Date: Oct 2008
Location: Mesquite Tx
Posts: 8,612
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 125 Post(s)
Liked: 140
Quote:
Originally Posted by nelluk View Post

I'm trying to set up my STR-DH540 to take the optical audio out from my TV for over the air broadcasts. Optical cable from TV's optical out to receiver's opt-in #2.

When receiver is in 'TV" mode, I can't get the audio. When I press 'input mode' it is permanently in 'Analog' mode for whatever reason. Nothing changes when I hit the button and it almost looks 'greyed out'.

If I change to any other receiver input, I can hit 'input mode' until it says Optical, and then I can hear the TV audio as expected.

So basically, is there any way to get this thing to use optical audio when the receiver is in 'TV" mode?

Hi nelluk, double check the optical cable doesn't have any small protective plastic caps at end. Also for testing try opt-in #1 or try another source e.g xbox, BD player etc... to see if it get sound.
JChin is offline  
Old 02-05-2014, 07:39 AM - Thread Starter
Member
 
nelluk's Avatar
 
Join Date: Feb 2014
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

No caps. As I've said the cable works fine for any other input except for TV, so I think we can eliminate the TV and the cable as sources of the problem.

nelluk is offline  
Old 02-05-2014, 08:48 AM
AVS Addicted Member
 
afrogt's Avatar
 
Join Date: Jul 2003
Location: SF Bay Area
Posts: 23,626
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 379 Post(s)
Liked: 443
Try clearing the settings as described on page 52. It should set everything back to the defaults and hopefully opt2 goes back to TV.


Afro GT
afrogt is online now  
Old 02-05-2014, 08:56 PM - Thread Starter
Member
 
nelluk's Avatar
 
Join Date: Feb 2014
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

Resetting the unit solved the problem. Thanks!

nelluk is offline  
Old 02-05-2014, 10:47 PM
AVS Addicted Member
 
afrogt's Avatar
 
Join Date: Jul 2003
Location: SF Bay Area
Posts: 23,626
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 379 Post(s)
Liked: 443
Glad it worked.

Afro GT
afrogt is online now  
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off