Marantz NR1604 shows no component picture - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 5 Old 03-02-2014, 05:20 AM - Thread Starter
Newbie
 
marcelschoen's Avatar
 
Join Date: Dec 2013
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

Hi there,

 

I have a Marantz NR1604, and I have a PS2 connected with component cables (YUV). Up until recently, that worked perfectly. For some reason, since today (probably) I suddenly have no picture anymore. I tried both component inputs, I also tried a different old console (SNES). The PS2 and SNES still work fine with another TV, so they are OK. After toying around with different cables etc. I have no other conclusion that that: The Marantz suddenly does not process the component inputs anymore. I have no clue what happened. Maybe a firmware update?

 

Anything else, like the various devices connected with HDMI, work fine...

 

Has anyone else experienced something like this?

marcelschoen is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 03-02-2014, 08:18 AM
585-645-1006
 
jdsmoothie's Avatar
 
Join Date: Sep 2007
Location: Orlando, FL
Posts: 43,981
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 784 Post(s)
Liked: 1436
Ensure the Video Conversion setting for that input wasn't disabled.

---------------------------------
"JD" – jd@avscience.com ; shop.avscience.com ; 585-645-1006, AVScience - Authorized dealer for AV Gear 
Mon - Fri: 8am – 8pm EST (Sat/Sun too, will return call if I don't pick up)
Call for pricing on Denon, Marantz, Yamaha, Onkyo, Klipsch, Def Tech, Atlantic Tech
** Think the AVR is defective?  Reset the microprocessor 4-5 times. 
jdsmoothie is online now  
post #3 of 5 Old 03-02-2014, 12:14 PM - Thread Starter
Newbie
 
marcelschoen's Avatar
 
Join Date: Dec 2013
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

Hi,

 

Thanks. I had just reset all input mappings to factory defaults, and then started to re-configure every input mapping again, and now the PS2 is back. I didn't even touch the video conversion settings... strange... But I'll have a look at those settings. For the moment, it's back to working, although I don't really know why. I'm under the impression that the whole analog-to-digital conversion part is not exactly very robust.

marcelschoen is offline  
post #4 of 5 Old 03-05-2014, 02:41 AM
585-645-1006
 
jdsmoothie's Avatar
 
Join Date: Sep 2007
Location: Orlando, FL
Posts: 43,981
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 784 Post(s)
Liked: 1436
For additional helpful information, you may want to review the 1604 Owner's thread linked below ...

http://www.avsforum.com/t/1470664/the-official-marantz-nr1604-owners-thread/0_100

---------------------------------
"JD" – jd@avscience.com ; shop.avscience.com ; 585-645-1006, AVScience - Authorized dealer for AV Gear 
Mon - Fri: 8am – 8pm EST (Sat/Sun too, will return call if I don't pick up)
Call for pricing on Denon, Marantz, Yamaha, Onkyo, Klipsch, Def Tech, Atlantic Tech
** Think the AVR is defective?  Reset the microprocessor 4-5 times. 
jdsmoothie is online now  
post #5 of 5 Old 03-05-2014, 06:27 AM - Thread Starter
Newbie
 
marcelschoen's Avatar
 
Join Date: Dec 2013
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

Just for the record - it just happened again. I switched on my PS2 and Marantz and wanted to play some, and again, I have no picture anymore. All HDMI sources work fine, but no picture from the PS2.

 

This sucks. I'm starting to hate the Marantz. Seems like another waste of money for a product that doesn't work as advertised.

marcelschoen is offline  
Reply Receivers, Amps, and Processors

Tags
Marantz Nr1604 Slim Line 7 1 Network Receiver
Gear in this thread - Nr1604 by PriceGrabber.com

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off