Please help. When I select BD/DVD I only get a blue screen? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 5 Old 03-18-2014, 11:08 AM - Thread Starter
Member
 
zagman1's Avatar
 
Join Date: Apr 2006
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hello-
Helping a friend dial in his system at vacation home. We just updated to the latest firmware on the Receiver. He previously was not set up for passthrough (is that the correct term?). We hooked up HDMI cable to the HDMI input named "MAIN" on receiver, and the other end went to HDMI 1 on his TV. I then hooked up HDMI cable to the input on Receiver named "Cab/Sat" and the other end to the HDMI slot on his Dish Receiver

I then hooked up HDMI cable to the input named "BD/DVD" on Receiver and the other end to HDMI cable to the HDMI slot on Memorex Blu Ray player. (do not have model number?)

When I select CAB/SAT input on Onkyo remote, TV switches to that input and voila, I have a picture. When I plug iphone or ipod in front USB input on Onkyo, and select "USB" on Onkyo remote, I get the playlist, artist , album etc. showing up on tv screen, so that input works as well. However, when I turn on Blu Ray player and select "BD/DVD" on Onkyo remote, I only get a blue screen on the TV. (Initially, the words BD/DVD, or Blu Ray show up) but then just goes to Blue screen. Do you have any idea what is wrong? Are there any settings etc. that need to be set? Should I have him try a newer Blu Ray player?

Very frustrating as he had it set up so it all worked before, and then I came along and said "You know, there is an easier way to do this"....


Thanks in advance for your help!

Z
zagman1 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 03-18-2014, 01:02 PM
AVS Special Member
 
Selden Ball's Avatar
 
Join Date: Jan 2001
Location: upstate NY
Posts: 7,170
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 453 Post(s)
Liked: 426
First find out if the Blu-ray player works when plugged directly into the TV. That'll tell you if the player and associated cable are compatible with the TV. Use the cable that you're using to connect the player to the receiver. If that fails, then the problem is in the player or its cable.

Another thing to try is a different HDMI input on the receiver, just in case that particular one is defective. The labels are primarily for your convenience. They all should work the same.

Often the startup screen of a Blu-ray player is low-resolution, but later images and on-disk menus are high-resolution (1920x1080 aka 1080p). There are a variety of things which could prevent a high-resolution video signal from being shown: poor cables, receiver settings, incompatibility with the TV resolution, etc, Cable and Satellite boxes usually output low resolution video: 480p, 720p or 1080i. I suspect that's the case for the video associated with the iPod, too.

Selden
Selden Ball is offline  
post #3 of 5 Old 03-18-2014, 01:20 PM
AVS Addicted Member
 
afrogt's Avatar
 
Join Date: Jul 2003
Location: SF Bay Area
Posts: 23,240
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 243 Post(s)
Liked: 400
Definitely connect the Blu Ray directly to the TV to see if it is working. It could be a resolution problem.

What Onkyo receiver is this? And what brand and model of TV?

Afro GT
afrogt is offline  
post #4 of 5 Old 03-18-2014, 05:52 PM - Thread Starter
Member
 
zagman1's Avatar
 
Join Date: Apr 2006
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks to both. It is a TX-N515 Receiver. Prior to me changing the setup, the Blu Ray player was working when hooked up to HDMI 2 on TV (Vizio Plasma), with audio cables going from Blu Ray to Receiver. Also what I forgot to mention is along with the Blue screen on TV, I wasn't getting audio either, while the DVD was playing. (It wasn't a Blu Ray disc)
zagman1 is offline  
post #5 of 5 Old 03-19-2014, 10:56 AM
AVS Special Member
 
Selden Ball's Avatar
 
Join Date: Jan 2001
Location: upstate NY
Posts: 7,170
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 453 Post(s)
Liked: 426
Quote:
Originally Posted by zagman1 View Post

Thanks to both. It is a TX-N515 Receiver. Prior to me changing the setup, the Blu Ray player was working when hooked up to HDMI 2 on TV (Vizio Plasma), with audio cables going from Blu Ray to Receiver. Also what I forgot to mention is along with the Blue screen on TV, I wasn't getting audio either, while the DVD was playing. (It wasn't a Blu Ray disc)

That's consistent with a bad connection between the BD player and the receiver.

Any of the player's output, the cable or the receiver's input might have gotten damaged during the change, or the cable might not have been fully plugged in. I'd suggest getting a new certified High Speed cable (which should be relatively inexpensive: you don't have to buy a "boutique" brand) and plug it into a different HDMI input on the receiver. Make sure both ends of the cable are fully seated: press firmly on both ends. Sometimes they look seated but aren't.

Selden
Selden Ball is offline  
Reply Receivers, Amps, and Processors

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off