No sound from denon avr 590 - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 05-05-2014, 12:40 PM - Thread Starter
Member
 
tiny0011's Avatar
 
Join Date: Mar 2008
Posts: 79
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
The other day I was listening my 590 when it started to make clicking sounds from the speakers.Then the audio quit completely.There is no sound from any input including tuner.The orange light around the power button is not blinking. I use banana plugs for speakers, no bare wires. When it did this, I checked to see if it was hot and it wasn`t. I did a reset but no help. I like this avr and don`t want to get rid of it. Any help would be deeply appreciated, Thank you!
tiny0011 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 05-05-2014, 12:49 PM
585-645-1006
 
jdsmoothie's Avatar
 
Join Date: Sep 2007
Location: Orlando, FL
Posts: 43,135
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 396 Post(s)
Liked: 1340
Unplug all source device power cables and their respective HDMI cables for at least 10 minutes. Plug back in and reconnect all cables. Do at least 4-5 microprocessor resets of the 590. If still no joy, then repair or replace. frown.gif

---------------------------------
"JD" – jd@avscience.com ; shop.avscience.com ; 585-645-1006, AVScience - AVSForum sponsor for 15 years  
Mon - Fri: 8am – 8pm EST (Sat/Sun too, will return call if I don't pick up)
Call for pricing on Denon, Marantz, Yamaha, Onkyo, Klipsch, Def Tech, Oppo, Parasound 
** Think the AVR is defective?  Reset the microprocessor 4-5 times. 
jdsmoothie is offline  
post #3 of 3 Old 05-07-2014, 06:47 AM - Thread Starter
Member
 
tiny0011's Avatar
 
Join Date: Mar 2008
Posts: 79
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Mr. JD, I did what you said and my 590 came back to life, plays like a champ. THANK YOU,I deeply appreciate your help!
tiny0011 is offline  
Reply Receivers, Amps, and Processors

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off