Aiwa NSX-D939 Will not turn on....Help? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 1 Old 05-10-2014, 07:34 PM - Thread Starter
Newbie
 
carlover4lyfe's Avatar
 
Join Date: May 2014
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

OK, so I have a more or less ancient Aiwa mini compact stereo system that I scored, :D and I plugged it in will no problems, :D turned it on, again, no biggie, :D then out of nowhere about 5 minutes in, the display goes blank.:( If this helps, it may or may not have been when I plugged in the speakers, while it was on if that makes a difference....now all that happens when I plug it in is I hear the fan in the back spin and it turns on and works but that's all, clock doesn't show up, nothing no display at all...only that damn fan :confused:  if anyone could help me or lead me in the right direction let me know, I'm not a genius with these electronics but I know a little bit :) I have a soldering iron (no solder, of course) and a screwdriver if I need to do something...lol any help greatly appreciated 

carlover4lyfe is offline  
Reply Receivers, Amps, and Processors
Gear in this thread - NSX-D939 by PriceGrabber.com

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off