The Official Onkyo TX-NR535/636/737/838 Thread. - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #1 of 649 Old 06-25-2014, 03:20 PM - Thread Starter
Senior Member
 
WhiskeyOmega's Avatar
 
Join Date: Apr 2014
Location: UK
Posts: 264
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 17
The Official Onkyo TX-NR535/636/737/838 Thread.

Did have a good look for a thread on these receivers but couldn't find one.

I picked up a 636 on Monday after I learned denon didn't know if any of the hdmi ports had hdcp 2.2. So glad I picked up a receiver with one port.

Have yet to use mine as I'm waiting on the Kef Q series speakers which will be here tomorrow.

I'm happy with the spec to go with my TV a LG 55La9700 4k. I have a small room so time will tell if the ACCUEQ will be fine for what I need.

Whilst I hope Onkyo aren't cutting corners with adding their own EQ simply as a profit making scheme. I get the feeling it's a nessesary evil with at least the lower end models to provide features such as 4 2.0 hdmi ports and hdcp 2.2

I for one appreciate at least onkyo giving full spec which Is the reason I picked this receiver over any other. As I can compromise certain software based features like the EQs in favour of better and more future compatible hardware.
WhiskeyOmega is offline  
Sponsored Links
Advertisement
 
post #2 of 649 Old 06-28-2014, 06:24 PM - Thread Starter
Senior Member
 
WhiskeyOmega's Avatar
 
Join Date: Apr 2014
Location: UK
Posts: 264
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 17
So. Got my kefs hooked up. The setup was very easy the accu EQ is OK. For some reason it thinks the sub is 8ft away but it's next to the right speaker that is about 5ft away. As it's only me listening I don't need multi positioning.

Anyway. Had a small issue with av sync between the oppo Bluray and the onkyo which was fixed by using 2 outputs by hdmi.

Also glad I can bi-amp which I didn't know I could do so got it in normal mode but will change it tomorrow

LG 55LA970W - Oppo 103D - Onkyo TX-NR636 - Kef Q1,5,9C speakers and Rel 150 sub - Sennheiser HD650 Headphones
WhiskeyOmega is offline  
post #3 of 649 Old 06-29-2014, 06:15 PM
Newbie
 
Join Date: Jun 2014
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 0
Looking at the 636 as a replacement for my HT-R667, which finally went out in a literal blaze of glory (sparks and everything - you can imagine my excitement...) after five-plus years of faithful service.

A few questions -

1) Would this receiver be compatible with the speakers and sub I've got leftover from my 667 system? I can't find any reason why they wouldn't be, but I want to make sure I'm not overlooking something on the power consumption side:
The 667, for reference - http://www.newegg.com/Product/Produc...82E16882120122

2) I never took advantage of the 7.1 capabilities of my 667 and, while I always intended to, NYC-living hasn't really afforded me the apartment layout that would really let me take advantage of 7.1. I'll be the first to admit that I'm hardly an expert here, but merely a guy who appreciates decent sound with his sports, music, and games, I'm really essentially looking for something with good HDMI pass through that is going to sound good without much expert tweaking. I've still got a 60hz 1080p TV and the need to replace my receiver has set me back at least a year in terms of upgrading on that front, unfortunately. Am I overshooting my needs here with the 636? Is there another lower model that would be better-suited for my needs at a cheaper price? Is it worth it to consider a cheaper model, or am I future-proofing here appropriately?

Thanks
Magoober16 is offline  
post #4 of 649 Old 06-29-2014, 06:28 PM - Thread Starter
Senior Member
 
WhiskeyOmega's Avatar
 
Join Date: Apr 2014
Location: UK
Posts: 264
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 17
Your speakers will be fine with this model. The 535 lower model only does 5.2 and doesn't have hdcp 2.2 or dolby atmos decoding so the 636 is your best bet. If you do intend to upgrade to a 4k TV soon then it's defiantly the one to go for.

LG 55LA970W - Oppo 103D - Onkyo TX-NR636 - Kef Q1,5,9C speakers and Rel 150 sub - Sennheiser HD650 Headphones
WhiskeyOmega is offline  
post #5 of 649 Old 06-30-2014, 10:02 AM
Member
 
jrdnlc's Avatar
 
Join Date: Oct 2013
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 10
Hey guys, have a question. I recently got the 727 from Amazon but I'm seeing now that the 737 will be Dolby Atmos upgradeable via firmware. Will the 737 do good with 6ohm speakers? They are 130W max and came with the HT-S9400THX home theatre package.

Thanks in advance!
jrdnlc is offline  
post #6 of 649 Old 06-30-2014, 10:04 AM - Thread Starter
Senior Member
 
WhiskeyOmega's Avatar
 
Join Date: Apr 2014
Location: UK
Posts: 264
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 17
Quote:
Originally Posted by jrdnlc View Post
Hey guys, have a question. I recently got the 727 from Amazon but I'm seeing now that the 737 will be Dolby Atmos upgradeable via firmware. Will the 737 do good with 6ohm speakers? They are 130W max and came with the HT-S9400THX home theatre package.

Thanks in advance!
Yes the default is 6ohms. The other option is 4ohms.

LG 55LA970W - Oppo 103D - Onkyo TX-NR636 - Kef Q1,5,9C speakers and Rel 150 sub - Sennheiser HD650 Headphones
WhiskeyOmega is offline  
post #7 of 649 Old 06-30-2014, 10:07 AM
Member
 
jrdnlc's Avatar
 
Join Date: Oct 2013
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 10
Quote:
Originally Posted by WhiskeyOmega View Post
Yes the default is 6ohms. The other option is 4ohms.
At 110W, right? My speakers are 130W max and want to make sure I don't blow them up
jrdnlc is offline  
post #8 of 649 Old 06-30-2014, 10:11 AM - Thread Starter
Senior Member
 
WhiskeyOmega's Avatar
 
Join Date: Apr 2014
Location: UK
Posts: 264
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 17
Quote:
Originally Posted by jrdnlc View Post
At 110W, right? My speakers are 130W max and want to make sure I don't blow them up
You'd do well to get it that loud but yea 110w.

LG 55LA970W - Oppo 103D - Onkyo TX-NR636 - Kef Q1,5,9C speakers and Rel 150 sub - Sennheiser HD650 Headphones
WhiskeyOmega is offline  
post #9 of 649 Old 06-30-2014, 10:12 AM
Member
 
jrdnlc's Avatar
 
Join Date: Oct 2013
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 10
Quote:
Originally Posted by WhiskeyOmega View Post
You'd do well to get it that loud but yea 110w.
Thanks a lot! Going to return the 727 today and pick up the 737 at Fry's.
jrdnlc is offline  
post #10 of 649 Old 06-30-2014, 01:13 PM
Newbie
 
Join Date: Jun 2014
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 0
So I picked up a 636 and have it all up and running - pretty happy with it so far. Wondering if anyone can help me figure these two pain points so far...

1) I used my R667 quite a bit to listen to music using the dock. One of the best parts about the dock was that I could use it while using another video input. For example, if I was sick of the commentating during an NHL game, I could flick on some tunes from the dock and still use the video from CBL/Sat. I haven't been able to emulate this with the bluetooth functionality yet - any ideas?

2) I've got an old model Xbox 360 (No HDMI output), so I'm stuck with Component cables. When I set it up on the new 636, it forces me to set its output to 480p in order to be upconverted in the receiver. However, the upconverted signal doesn't look nearly as good as the direct 720p feed off of the component cables would. Anyway to bypass this?

Happy to answer any questions about the 636, so feel free to ask away.
Magoober16 is offline  
post #11 of 649 Old 07-01-2014, 05:57 AM - Thread Starter
Senior Member
 
WhiskeyOmega's Avatar
 
Join Date: Apr 2014
Location: UK
Posts: 264
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 17
You tried bypassing the video out processing? I don't believe you can choose different video and audio. But I haven't looked for it.

LG 55LA970W - Oppo 103D - Onkyo TX-NR636 - Kef Q1,5,9C speakers and Rel 150 sub - Sennheiser HD650 Headphones
WhiskeyOmega is offline  
post #12 of 649 Old 07-01-2014, 07:44 AM
Advanced Member
 
lemonslush's Avatar
 
Join Date: Feb 2013
Location: MA
Posts: 847
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 352 Post(s)
Liked: 89
I had a 616 a few years back that got returned to amazon because the 7th channel didn't work. Aside from that it sounded OK.

Did you buy this because of the atmos or other reasons? I hope this new series doesn't have the same HDMI issues as the previous two did.
lemonslush is offline  
post #13 of 649 Old 07-01-2014, 11:48 AM - Thread Starter
Senior Member
 
WhiskeyOmega's Avatar
 
Join Date: Apr 2014
Location: UK
Posts: 264
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 17
Quote:
Originally Posted by lemonslush View Post
I had a 616 a few years back that got returned to amazon because the 7th channel didn't work. Aside from that it sounded OK.

Did you buy this because of the atmos or other reasons? I hope this new series doesn't have the same HDMI issues as the previous two did.
Well I'm basing the fact it won't since they're mostly hdmi 2.0

LG 55LA970W - Oppo 103D - Onkyo TX-NR636 - Kef Q1,5,9C speakers and Rel 150 sub - Sennheiser HD650 Headphones
WhiskeyOmega is offline  
post #14 of 649 Old 07-01-2014, 11:58 AM
Advanced Member
 
lemonslush's Avatar
 
Join Date: Feb 2013
Location: MA
Posts: 847
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 352 Post(s)
Liked: 89
Quote:
Originally Posted by WhiskeyOmega View Post
Well I'm basing the fact it won't since they're mostly hdmi 2.0
Is the atmos on the receiver already or is it a firm ware update to be out later?
lemonslush is offline  
post #15 of 649 Old 07-01-2014, 12:16 PM - Thread Starter
Senior Member
 
WhiskeyOmega's Avatar
 
Join Date: Apr 2014
Location: UK
Posts: 264
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 17
Quote:
Originally Posted by lemonslush View Post
Is the atmos on the receiver already or is it a firm ware update to be out later?
Don't know. I would assume it's a upgrade later but I have nothing that has atmos on it so can't test.

LG 55LA970W - Oppo 103D - Onkyo TX-NR636 - Kef Q1,5,9C speakers and Rel 150 sub - Sennheiser HD650 Headphones
WhiskeyOmega is offline  
post #16 of 649 Old 07-01-2014, 01:48 PM - Thread Starter
Senior Member
 
WhiskeyOmega's Avatar
 
Join Date: Apr 2014
Location: UK
Posts: 264
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 17
Got a weird av sync issue with my 636 which I've just figured out is to do with Dolby. Dts is fine but It's so close it's annoying. After what I thought was a problem with my oppo and now just had satellite installed I get this if I'm using dolby. Strange. Anyone else noticed it?

LG 55LA970W - Oppo 103D - Onkyo TX-NR636 - Kef Q1,5,9C speakers and Rel 150 sub - Sennheiser HD650 Headphones
WhiskeyOmega is offline  
post #17 of 649 Old 07-01-2014, 02:26 PM - Thread Starter
Senior Member
 
WhiskeyOmega's Avatar
 
Join Date: Apr 2014
Location: UK
Posts: 264
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 17
Also can you guys Check what firmware version you have and if you get a message saying unable to check for update to firmware?

LG 55LA970W - Oppo 103D - Onkyo TX-NR636 - Kef Q1,5,9C speakers and Rel 150 sub - Sennheiser HD650 Headphones
WhiskeyOmega is offline  
post #18 of 649 Old 07-01-2014, 07:38 PM
Newbie
 
Join Date: Jun 2014
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 0
Quote:
Originally Posted by WhiskeyOmega View Post
Also can you guys Check what firmware version you have and if you get a message saying unable to check for update to firmware?
1020-2110-0001-0200-0001

No message

Quote:
Originally Posted by WhiskeyOmega View Post
You tried bypassing the video out processing? I don't believe you can choose different video and audio. But I haven't looked for it.
I haven't found a way to bypass it. Waiting to hear back from Onkyo - hoping there is some way to use the direct source instead.

Onkyo replied about the dock question on Twitter - said you can only select a different audio source from video on all modes except Bluetooth, USB, and NET. I suggested a firmware update to patch it in - would be nice for Bluetooth. I also wish you could do videos through BT...

I'm pretty happy with the 636 so far - only thing that seems a bit off is very low volume on dialogue and very loud volume on explosions and music - it's making late night viewing a little bit of a challenge with the roommate. Am I missing something obvious in the settings? Still tweaking my settings a bit (and considering updating the speakers a bit...)
Magoober16 is offline  
post #19 of 649 Old 07-01-2014, 08:32 PM - Thread Starter
Senior Member
 
WhiskeyOmega's Avatar
 
Join Date: Apr 2014
Location: UK
Posts: 264
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 17
Quote:
Originally Posted by Magoober16 View Post
1020-2110-0001-0200-0001

No message



I haven't found a way to bypass it. Waiting to hear back from Onkyo - hoping there is some way to use the direct source instead.

Onkyo replied about the dock question on Twitter - said you can only select a different audio source from video on all modes except Bluetooth, USB, and NET. I suggested a firmware update to patch it in - would be nice for Bluetooth. I also wish you could do videos through BT...

I'm pretty happy with the 636 so far - only thing that seems a bit off is very low volume on dialogue and very loud volume on explosions and music - it's making late night viewing a little bit of a challenge with the roommate. Am I missing something obvious in the settings? Still tweaking my settings a bit (and considering updating the speakers a bit...)
OK scratch the dolby being the sync problem as it's working fine now. But I forced 4k output from the oppo and it dropped the refresh rate to 25hz. I now have a feeling it's to do with 50hz programs and outputs. Very strange.

I did notice there's a update for the 535 but I think that came out earlier. I really haven't figured this amp out at all as the last one I had was a denon 4308.

I just use headphones at night. Love the phase matching bass effect with them. I would try dynamic range control to counteract the range.

LG 55LA970W - Oppo 103D - Onkyo TX-NR636 - Kef Q1,5,9C speakers and Rel 150 sub - Sennheiser HD650 Headphones
WhiskeyOmega is offline  
post #20 of 649 Old 07-02-2014, 05:05 PM - Thread Starter
Senior Member
 
WhiskeyOmega's Avatar
 
Join Date: Apr 2014
Location: UK
Posts: 264
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 17
OK bypassing video by putting the sky satellite box directly into into the tv and using arc to send it back to the amp which has fixed it. So my guess is there's some sync problem in the 636 itself. I'll speak to onkyo tomorrow.

LG 55LA970W - Oppo 103D - Onkyo TX-NR636 - Kef Q1,5,9C speakers and Rel 150 sub - Sennheiser HD650 Headphones
WhiskeyOmega is offline  
post #21 of 649 Old 07-02-2014, 05:17 PM - Thread Starter
Senior Member
 
WhiskeyOmega's Avatar
 
Join Date: Apr 2014
Location: UK
Posts: 264
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 17
Has anyone figured out a way of accessing the amp without switching on a device if hdmi cec is on. I need it on for arc. Or I'll end up using optical from the tv instead.

LG 55LA970W - Oppo 103D - Onkyo TX-NR636 - Kef Q1,5,9C speakers and Rel 150 sub - Sennheiser HD650 Headphones
WhiskeyOmega is offline  
post #22 of 649 Old 07-06-2014, 04:30 PM - Thread Starter
Senior Member
 
WhiskeyOmega's Avatar
 
Join Date: Apr 2014
Location: UK
Posts: 264
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 17
Just bi-wired the front left and right speakers. So much more detail certainly in the music I'm testing it with

LG 55LA970W - Oppo 103D - Onkyo TX-NR636 - Kef Q1,5,9C speakers and Rel 150 sub - Sennheiser HD650 Headphones
WhiskeyOmega is offline  
post #23 of 649 Old 07-08-2014, 08:27 AM
Member
 
ldeveraux's Avatar
 
Join Date: Aug 2005
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 10
Quote:
Originally Posted by WhiskeyOmega View Post
Also can you guys Check what firmware version you have and if you get a message saying unable to check for update to firmware?
I get the same error, unable to check for update. New receiver, so maybe give it some time for Onkyo to sort it out?
ldeveraux is offline  
post #24 of 649 Old 07-08-2014, 01:18 PM - Thread Starter
Senior Member
 
WhiskeyOmega's Avatar
 
Join Date: Apr 2014
Location: UK
Posts: 264
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 17
There isn't a new firmware out yet AFAIK. Mine did say it bit all of sudden actually checks now.

LG 55LA970W - Oppo 103D - Onkyo TX-NR636 - Kef Q1,5,9C speakers and Rel 150 sub - Sennheiser HD650 Headphones
WhiskeyOmega is offline  
post #25 of 649 Old 07-08-2014, 10:05 PM
Member
 
B_BODY_1's Avatar
 
Join Date: Feb 2007
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 11
Can I run 2 tvs (sub out, main out) off of the 636 or do I need the 838? (I would like to run an hdmi cable to the kitchen from this receiver to a tv)

I don't really need to have different video sources for each room, since I would like it to be a second screen with audio. Although it would be nice to use slacker or other internet radio in the other room while the main is going on its own source can the 636 do that?

Thanks
WhiskeyOmega likes this.
B_BODY_1 is offline  
post #26 of 649 Old 07-09-2014, 10:36 AM
AVS Special Member
 
zeus33's Avatar
 
Join Date: Dec 2012
Posts: 1,633
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 335 Post(s)
Liked: 258
Quote:
Originally Posted by lemonslush View Post
Is the atmos on the receiver already or is it a firm ware update to be out later?

Attached Thumbnails
Click image for larger version

Name:	ATMOS-fw.jpg
Views:	3919
Size:	206.1 KB
ID:	154441  
zeus33 is online now  
post #27 of 649 Old 07-09-2014, 11:50 AM - Thread Starter
Senior Member
 
WhiskeyOmega's Avatar
 
Join Date: Apr 2014
Location: UK
Posts: 264
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 17
Quote:
Originally Posted by B_BODY_1 View Post
Can I run 2 tvs (sub out, main out) off of the 636 or do I need the 838? (I would like to run an hdmi cable to the kitchen from this receiver to a tv)

I don't really need to have different video sources for each room, since I would like it to be a second screen with audio. Although it would be nice to use slacker or other internet radio in the other room while the main is going on its own source can the 636 do that?

Thanks
You can run both main and sub at the same time or each. The sub out doesn't have 4k or hdcp 2.2 on the 636.

LG 55LA970W - Oppo 103D - Onkyo TX-NR636 - Kef Q1,5,9C speakers and Rel 150 sub - Sennheiser HD650 Headphones
WhiskeyOmega is offline  
post #28 of 649 Old 07-09-2014, 03:22 PM
Advanced Member
 
kokishin's Avatar
 
Join Date: Sep 2006
Location: Silicon Valley
Posts: 728
Mentioned: 4 Post(s)
Tagged: 1 Thread(s)
Quoted: 361 Post(s)
Liked: 164
Quote:
Originally Posted by WhiskeyOmega View Post
OK scratch the dolby being the sync problem as it's working fine now. But I forced 4k output from the oppo and it dropped the refresh rate to 25hz. I now have a feeling it's to do with 50hz programs and outputs. Very strange.

Haven't looked at the Oppo specs in a long time but if the Oppo provides HDMI 1.4 out, then due to HDMI 1.4 bandwidth restrictions, it can only support up to 4K @ 30Hz max.

avsforum Members Atmos & Auro Configuration Spreadsheet

How to Create a Dolby Atmos Demo Disc (post #15199)

I'm just a caveman. Your modern world frightens and confuses me.

Last edited by kokishin; 07-09-2014 at 03:26 PM.
kokishin is online now  
post #29 of 649 Old 07-09-2014, 03:28 PM - Thread Starter
Senior Member
 
WhiskeyOmega's Avatar
 
Join Date: Apr 2014
Location: UK
Posts: 264
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 17
[quote=kokishin;25615449]
Quote:
Originally Posted by WhiskeyOmega View Post
OK scratch the dolby being the sync problem as it's working fine now. But I forced 4k output from the oppo and it dropped the refresh rate to 25hz. I now have a feeling it's to do with 50hz programs and outputs. Very strange. /QUOTE]


Haven't looked at the Oppo specs in a long time but if the Oppo provides HDMI 1.4 out, then due to HDMI 1.4 bandwidth restrictions, it can only support up to 4K @ 30Hz max.
Hdmi 1.4 max bandwidth is 10.4Gbps which can handle 4k @60hz in 4:2:0. The oppo can output this if you look in the settings. I ended up just putting a av sync of +380ms which then changed a couple of days later to +330ms for no reason.

LG 55LA970W - Oppo 103D - Onkyo TX-NR636 - Kef Q1,5,9C speakers and Rel 150 sub - Sennheiser HD650 Headphones
WhiskeyOmega is offline  
post #30 of 649 Old 07-09-2014, 03:52 PM
Advanced Member
 
kokishin's Avatar
 
Join Date: Sep 2006
Location: Silicon Valley
Posts: 728
Mentioned: 4 Post(s)
Tagged: 1 Thread(s)
Quoted: 361 Post(s)
Liked: 164
[quote=WhiskeyOmega;25615625]
Quote:
Originally Posted by kokishin View Post
Hdmi 1.4 max bandwidth is 10.4Gbps which can handle 4k @60hz in 4:2:0. The oppo can output this if you look in the settings. I ended up just putting a av sync of +380ms which then changed a couple of days later to +330ms for no reason.
I must be misreading the table (scroll down ~ mid-way until you see the red/gray/green HDMI version comparison table):

http://en.wikipedia.org/wiki/HDMI#Version_comparison

avsforum Members Atmos & Auro Configuration Spreadsheet

How to Create a Dolby Atmos Demo Disc (post #15199)

I'm just a caveman. Your modern world frightens and confuses me.
kokishin is online now  
Reply Receivers, Amps, and Processors
Gear in this thread



Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off