Receiver Not Switching Listening Modes Automatically - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 4 Old 07-23-2014, 09:59 AM - Thread Starter
Newbie
 
Join Date: Jul 2014
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Receiver Not Switching Listening Modes Automatically

Hello everyone! Long time lurker, first time poster. I am hoping some of you guys and gals can assist me with a minor annoyance I am having with my home theater setup.

I have an Onkyo TX-SR608 receiver connected to the Nvidia GTX680 GPU on my computer via HDMI. I am able to get amazing surround sound when I play games like Battlefield 4 and others with multichannel PCM lit up on the front of my receiver. However, my problem comes when I am playing a 2 channel source, specifically music through iTunes. I only receive sound through the front left and right speakers and subwoofers. I would prefer sound coming from all the speakers when I listen to my music. I am aware that my receiver has a listening mode called "all channel stereo" which does exactly what I want and plays music through all of my speakers. I have to manually select the all channel stereo listening mode when I want to listen to music and then manually switch back to multichannel listenining mode when I want to play games to get surround sound.

There is an option in my receiver's settings to adjust each input's listening modes when certain source material is played. I have set the PC input to all channel stereo for 2 channel sources. However, when I exit from the menu and attempt to play music, I still only receive sound through my front left, right and subs. It does not automatically switch to the preferred listening mode. In fact, even if I assign all the different sources to play in all channel stereo on the PC input, this setting does not take effect and I only get sound from my other speakers when I play surround sound content.

Am I missing something? I would like it to automatically do all channel stereo when I play music and multichannel PCM for everything else. As it stands, I have to manually change the listening mode each and every time.

A similar thing happens when I watch TV. I have my U-Verse receiver plugged into my Xbox One which is then connected to my receiver, all via HDMI. When I watch a watch something with surround sound content, such as a movie on HBO, I receive surround sound just fine. However, when I am watching anything else, I only get sound through my front left, right and subs. I would like two channel content to be played either through all channel stereo or Dolby Pro Logic IIx automatically but am unable to do this.

I am left with the rather inelegant solution of having to manually switch listening modes back and forth every time I listen to two channel content.

Thanks in advance for the help!
srbbell is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-23-2014, 10:33 AM
AVS Special Member
 
Selden Ball's Avatar
 
Join Date: Jan 2001
Location: upstate NY
Posts: 7,666
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 747 Post(s)
Liked: 513
You need to use a media player which supports WASAPI. See Which media players reconfigure HDMI to match number of source channels?

Your symptoms are consistent with the media player software on your computer being configured to use DirectSound and not WASAPI. DirectSound normally uses exactly the number of channels that you have configured in the Windows Playback Devices wizard no matter how many channels the source material contains. If you've configured it for 7.l channels and the source material contains only 2 channels (stereo), then the other five channels will be active too, but will be silent. When the other channels are active, ProLogic and Neo can't do anything because, so far as they are concerned, the surround-sound channels already are in use.

In contrast, players which use WASAPI send only the channels provided in the source material, so ProLogic and Neo can be used to expand them to use the other surround channels.

Selden

Marantz SR7009/7.1.4/FH+TM/DefTech PM1000/LCR+TM amped
Selden Ball is offline  
post #3 of 4 Old 07-24-2014, 03:01 PM - Thread Starter
Newbie
 
Join Date: Jul 2014
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Thank you for the prompt reply!

I did go into the preferences menu inside of iTunes and change it from DirectSound to Windows Audio Session. Unfortunately, that did not remedy the problem. Is this what you are referring to?

I still have the same issue with my Uverse going through my Xbox One on channels with two channel audio; that is I can't get my receiver to automatically pump those two channels out through all of my speakers.
srbbell is offline  
post #4 of 4 Old 07-24-2014, 03:11 PM
AVS Special Member
 
Selden Ball's Avatar
 
Join Date: Jan 2001
Location: upstate NY
Posts: 7,666
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 747 Post(s)
Liked: 513
Quote:
Originally Posted by srbbell View Post
Thank you for the prompt reply!

I did go into the preferences menu inside of iTunes and change it from DirectSound to Windows Audio Session. Unfortunately, that did not remedy the problem. Is this what you are referring to?
I believe so, although I've never used iTunes.

Quote:
Originally Posted by srbbell View Post
I still have the same issue with my Uverse going through my Xbox One on channels with two channel audio; that is I can't get my receiver to automatically pump those two channels out through all of my speakers.
I believe this indicates that your TV is advertising in its EDID that only two speakers are available, which forces the player devices to down-convert to stereo. Double-check the settings in the TV. Also check your receiver's settings. It might have an audio output setting for "TV, TV+AMP, AMP" which would need to be set to "AMP".

Edited to add:
Many TV channels transmit messed up audio. Some transmit only stereo (which can be expanded), some transmit full 5.1 surround sound (which doesn't need to be expanded unless you have a 7.1 system) and some transmit stereo as 5.1 channels but with the surround channels silent. There's nothing you can do about the latter. Your receiver sees that all of the audio channels are being used, so it can't apply ProLogic to use all of your speakers. If your Uverse has stereo analog output (RCA connections) you could try using them instead of digital audio.

Another edit:
Some receivers have a feature called "all channel stereo" which sends a stereo signal to all speakers. You might try that.

Selden

Marantz SR7009/7.1.4/FH+TM/DefTech PM1000/LCR+TM amped

Last edited by Selden Ball; 07-24-2014 at 03:25 PM.
Selden Ball is offline  
Reply Receivers, Amps, and Processors

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off