Denon 2809 Shuts off randomly, even with nothing plugged into it. - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old Today, 01:09 PM - Thread Starter
Member
 
wakacha's Avatar
 
Join Date: Jul 2008
Location: Ontario Canada
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Denon 2809 Shuts off randomly, even with nothing plugged into it.

Very strange, was using this receiver daily for past 3 years or so. Now it just started randomly shutting off. I unplugged each speaker individually to see if it was a wire short but it still shuts off even with literally nothing plugged in, no HDMI nothing but the power cord. It was plugged into a Monster power center, I plugged straight into wall socket to see if that was issue, same thing. Tried a different power bar, same. Checked all speaker wire posts for maybe random wire bits causing a short, nothing. Blew the whole thing and all holes (including headphone port as I had read that dust accumulation can trip the protection on) Still same thing.

Any other suggestions or am I just screwed? Pretty sure I am out of warranty.

Thanks.
wakacha is online now  
Sponsored Links
Advertisement
 
post #2 of 3 Old Today, 01:14 PM
585-645-1006
 
jdsmoothie's Avatar
 
Join Date: Sep 2007
Location: Orlando, FL
Posts: 46,914
Mentioned: 21 Post(s)
Tagged: 0 Thread(s)
Quoted: 2162 Post(s)
Liked: 1786
^^
Try unplugging the unit for 10 minutes and then plug back in and do at least 4-5 microprocessor resets in a row. If still no joy, either repair/replace, although only a 2 year warranty.

---------------------------------
"JD" – jd@avscience.com ; Direct line 585-645-1006, AVScience - Authorized dealer for AVRs, Speakers, etc. 

Daily 8am – 8pm EST
Call for pricing - Denon, Marantz, Yamaha, Pioneer, Onkyo, Def Tech, Atlantic Tech, Oppo
** Think the AVR is defective?  Reset the microprocessor 4-5 times. 
jdsmoothie is offline  
post #3 of 3 Old Today, 03:06 PM - Thread Starter
Member
 
wakacha's Avatar
 
Join Date: Jul 2008
Location: Ontario Canada
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
ok thank you I'll try it.
wakacha is online now  
Reply Receivers, Amps, and Processors



Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off