Troubleshooting B&K AV5000 - AVS Forum
Forum Jump: 
Thread Tools
post #1 of 2 Unread Today, 03:22 PM - Thread Starter
Newbie
 
Join Date: Oct 2014
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Question Troubleshooting B&K AV5000

Hello AVS Forum. I resultantly picked up a non-working B&K Components AV5000 5 channel amplifier for less then a scrap metal price.

I opened it up and found via a visual inspection;

On the power supply board;
R1 & R2 2W 100ohm resistors overheated and one had failed open

Amp boards;
R1, R1A, R1B (5 total) looked to have overheated in the past, so I replaced them, the old ones were a tiny bit out of range, but still functional.

C2, C2B, C12, C12A, C12B
A couple of the 100uF 100V capacitors looked a bit swollen, so I replaced them all.

Two of the + side fuses were blown, Ch. 1 & 4


I replaced everything that VISUALLY looked damaged. I am worried that whatever caused these problems will materialize when I plug the unit in to test it.

Suggestions on other things to test while she is apart and before applying power? I'm on a really tight budget, so if I cant get this thing running, no music for me for awhile..... Thank you in advance!
Attached Thumbnails
Click image for larger version

Name:	amp board.png
Views:	1
Size:	422.6 KB
ID:	437434   Click image for larger version

Name:	power board.png
Views:	1
Size:	121.1 KB
ID:	437442   Click image for larger version

Name:	ps board.png
Views:	1
Size:	124.4 KB
ID:	437450   Click image for larger version

Name:	con 2 board.png
Views:	1
Size:	132.1 KB
ID:	437458   Click image for larger version

Name:	con board.png
Views:	1
Size:	73.1 KB
ID:	437466  

Click image for larger version

Name:	toroid.png
Views:	1
Size:	66.1 KB
ID:	437482   Click image for larger version

Name:	bom1.png
Views:	1
Size:	72.8 KB
ID:	437490   Click image for larger version

Name:	bom2.png
Views:	1
Size:	72.9 KB
ID:	437498   Click image for larger version

Name:	power supply board.png
Views:	1
Size:	59.8 KB
ID:	437506  
Nor_Cal_Grown is online now  
Sponsored Links
Advertisement
 
post #2 of 2 Unread Today, 03:31 PM - Thread Starter
Newbie
 
Join Date: Oct 2014
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
pics
Attached Thumbnails
Click image for larger version

Name:	rear s.jpg
Views:	1
Size:	221.4 KB
ID:	437538   Click image for larger version

Name:	inside s.jpg
Views:	1
Size:	179.8 KB
ID:	437546   Click image for larger version

Name:	close s.jpg
Views:	1
Size:	152.2 KB
ID:	437554  
Nor_Cal_Grown is online now  
Reply Receivers, Amps, and Processors

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off