NAD T748 + NAD 916+ NAD 912 tripping!! - AVS | Home Theater Discussions And Reviews
Forum Jump: 
Thread Tools
post #1 of 1 Unread Today, 06:42 PM - Thread Starter
Newbie
 
Join Date: Aug 2014
Location: chicago,il
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Unhappy NAD T748 + NAD 916+ NAD 912 tripping!!

:

Hello guys,
I was happily using NAD T748 as a preamp with my Rotel 976 6 channel amp and with my Mordaunt Short speakers. For some reason felt the need to upgrade and sold off my rotel and bought NAD 916 (6 channel) & NAD 912.
My plan was to use the 912 as mono in bridged for the center and 916 for the bi-amped fronts and rears (4 ohms).
For some reason my T748 doesnt like the combo as it will trip as soon as I plug it in. Also when I connect the speakers by themselves, there is loud static in bridged mode. Stereo works fine (?)
I tried hooking up all speakers individually using a bluray to amp directly, all speakers work fine. Its the combination that sends the T748 in safe mode.
I checked all wires if there are touching and all looks fine.
Spent a good amount on these two amps and dont want them to turn into 50 lbs of garbage.

Please help. Any suggestions are appreciated to get this system up and running again.
One of the most significant bummers is I probably fried tweeters in my surrounds. Not sure though.

Thank you

FYI: PS3+Roku3+BDP to NAD T748 to NAD 916+ NAD 912----Benq W1070+ Mordaunt short MS903, MS905, MS903 + HSU-STF1
dhirajpiste1 is online now  
Sponsored Links
Advertisement
 
Reply Receivers, Amps, and Processors

Tags
amplifier , Mordaunt Short , Nad , Rotel , tripping

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off