Denon AVR-S910w and NVIDIA shield issue - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!


Forum Jump: 
 
Thread Tools
post #1 of 2 Old 01-14-2016, 08:00 AM - Thread Starter
Newbie
 
Join Date: Jan 2016
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Denon AVR-S910w and NVIDIA shield issue

I'm not sure you guys encounter this issue.

I bought a cheap 4K receiver 2 weeks ago and no issues connecting my NVIDIA shield. I maximize the shield resolution to 4K 30hz and to my surprise the Netflix don't show the ultra HD because my receiver is not HDCP.

So I returned it last night and grab the 910w.

Same setup but the shield on the same settings is flickering and snow screen.. I just don't know what to do. Up scaling was disabled..

My cable hdmi is not 18gbps but cmon, the returned receiver is working fine.

Hope anyone give me some advice..
ad78 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 01-18-2016, 12:41 AM - Thread Starter
Newbie
 
Join Date: Jan 2016
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Mods please delete. I believe that the newer denon that are HDCP 2.2 receiver needs a proper cable.

I resolve my issue by buying multiple cable over Amazon. I even changed the cable of my bluray, shield, and sat cable box.

The default broadcasting on Comcast was 1080i (CNN) pushing the up scaling to 4K makes the difference.
ad78 is offline  
Sponsored Links
Advertisement
 
Reply Receivers, Amps, and Processors
Gear in this thread

taboola here
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off