I have an Denon AVR-X2200W, will it support HDR and HDMI 2.0a? (xpost reddit) - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 1Likes
  • 1 Post By urbanracer34
 
Thread Tools
post #1 of 8 Old 07-20-2016, 07:46 PM - Thread Starter
Member
 
urbanracer34's Avatar
 
Join Date: Jan 2010
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 14
I have an Denon AVR-X2200W, will it support HDR and HDMI 2.0a? (xpost reddit)

I posted this on reddit/r/hometheater and one of the people there suggested getting in touch with you guys, specifically a problem in the first paragraph.

https://www.reddit.com/r/hometheater...pe_to_upgrade/

I bought this after consulting various internet forums and reddits a few months ago. It has worked wonderfully, except for the fact that the audio will not go up or down after power on unless you switch it off and on quickly a couple times.

It has firmware version 2400-4140-6075 currently on it, and checking for firmware updates, it says it's on the latest available.

Will it support HDR, HDMI 2.0a, and BT.2020 should I buy a 4k tv in the next couple of years? Has anyone tested this model with a 4k tv before? or did I buy it at the wrong time, seeing as new models came out?

The person suggested I contact JDsmoothie regarding the underlined issue.

(S)he said this:
"I wouldn't think so (If my settings file would carry over this bug) and if you've already done 2 factory resets already I doubt it will help. I would call Denon support and get a ticket started on it. They will have you try several things first (like a factory reset) that you've already done but it sounds like there's something wrong with the receiver. If you can get past the first level of CS people maybe you could get a tech on the line or get a call back from one who might have more insight but I wouldn't just put up with it doing that. Somethings up."

Oh yay.
Madmax67 likes this.
urbanracer34 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 07-20-2016, 11:17 PM
AVS Forum Addicted Member
 
jdsmoothie's Avatar
 
Join Date: Sep 2007
Location: Orlando, FL
Posts: 66,989
Mentioned: 269 Post(s)
Tagged: 1 Thread(s)
Quoted: 12414 Post(s)
Liked: 5666
Yes, as noted in post 1 of the below linked thread the 2015 Denon AVRs (including the X2200W) all support connecting to a 4k TV w/HDMI 2.0a(HDR) and HDCP 2.2.

The "OFFICIAL" 2015 Denon "S-series" / "X-series" AVR Owner's thread + FAQ (HDCP 2.2)

Regarding your volume issue ... if resetting the unit a few times in a row hasn't resolved the issue, you've got a defective unit which either needs to be exchanged/replaced (if within return period) or repaired.

Last edited by jdsmoothie; 07-20-2016 at 11:20 PM.
jdsmoothie is offline  
post #3 of 8 Old 07-27-2016, 05:08 PM - Thread Starter
Member
 
urbanracer34's Avatar
 
Join Date: Jan 2010
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 14
Alright, thanks JD. I was worried it would come to this.

Last edited by urbanracer34; 07-27-2016 at 05:22 PM. Reason: did not realize he touched upon my issue
urbanracer34 is offline  
 
post #4 of 8 Old 03-07-2017, 09:33 AM
Newbie
 
Join Date: Dec 2015
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 0
I know this is an old thread but It pertains to a question I have. I have a PS4 connected to this same Denon and I cannot get HDR to display on my Samsung set. It only works if I disconnect the PS4 from the receiver and connect it directly to the Samsung connect box.

Ideas or solutions recommended?

Thanks.
Genomecop is online now  
post #5 of 8 Old 03-07-2017, 10:35 AM
AVS Forum Addicted Member
 
jdsmoothie's Avatar
 
Join Date: Sep 2007
Location: Orlando, FL
Posts: 66,989
Mentioned: 269 Post(s)
Tagged: 1 Thread(s)
Quoted: 12414 Post(s)
Liked: 5666
Quote:
Originally Posted by Genomecop View Post
I know this is an old thread but It pertains to a question I have. I have a PS4 connected to this same Denon and I cannot get HDR to display on my Samsung set. It only works if I disconnect the PS4 from the receiver and connect it directly to the Samsung connect box.

Ideas or solutions recommended?

Thanks.
Are you using "Premium" certified HDMI cables?

https://www.monoprice.com/product?c_...seq=1&format=2
jdsmoothie is offline  
post #6 of 8 Old 03-07-2017, 11:37 AM
Newbie
 
Join Date: Dec 2015
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 0
Quote:
Originally Posted by jdsmoothie View Post
Are you using "Premium" certified HDMI cables?

https://www.monoprice.com/product?c_...seq=1&format=2
Yes on the cables.
Genomecop is online now  
post #7 of 8 Old 03-07-2017, 12:31 PM
AVS Forum Addicted Member
 
jdsmoothie's Avatar
 
Join Date: Sep 2007
Location: Orlando, FL
Posts: 66,989
Mentioned: 269 Post(s)
Tagged: 1 Thread(s)
Quoted: 12414 Post(s)
Liked: 5666
Quote:
Originally Posted by Genomecop View Post
Yes on the cables.
Have you tried every HDMI input? Have you set "Deep Color Output = OFF" on the PS4? Otherwise suggest you post in the Owner's thread linked below for other X2200W owners to chime in.

The "OFFICIAL" 2015 Denon "S-series" / "X-series" AVR Owner's thread + FAQ (HDCP 2.2)



Seems to be no problem for this member, although not using a PS4.


Quote:
Originally Posted by hammerdwn View Post
A few quick x2200 questions after watching 4k bluray disc of "Jason Bourne"... DTS-X MA bitsream sounded great, HDR picture looked good too.

-When I go to the Denon App, for some reason the Audio INPUT was just blank. I've never seen that. Usually it will show all the input speakers, but with DTS-X MA it was just empty! Is that normal?


-When playing the movie, the UBD-K8500 player and the Tv report 4k with HDR and the picture looks amazing. Meanwhile in the Denon App, the Video INPUT Resolution says "4K Half" during the movie. However, when I stop the movie and just view the player's menus, the App says the Resolution is "4K Full". Just wondering what 4K Half vs 4k Full means and if I should care?

Last edited by jdsmoothie; 03-07-2017 at 12:43 PM.
jdsmoothie is offline  
post #8 of 8 Old Today, 03:24 AM
Newbie
 
Join Date: Dec 2015
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 0
Quote:
Originally Posted by jdsmoothie View Post
Have you tried every HDMI input? Have you set "Deep Color Output = OFF" on the PS4? Otherwise suggest you post in the Owner's thread linked below for other X2200W owners to chime in.

The "OFFICIAL" 2015 Denon "S-series" / "X-series" AVR Owner's thread + FAQ (HDCP 2.2)



Seems to be no problem for this member, although not using a PS4.
I 'solved' the problem by connecting the PS4 directly to the Samsung connect box and running an optical out PS4 to AVR.
Genomecop is online now  
Sponsored Links
Advertisement
 
Reply Receivers, Amps, and Processors
Gear in this thread



Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off