HTPC surround sound not working with GeForce GTX 1050Ti - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 1 Old 04-25-2017, 10:29 AM - Thread Starter
Newbie
 
Join Date: Apr 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
HTPC surround sound not working with GeForce GTX 1050Ti

I have the following setup

htpc--->switch---> tv (hdmi cable)

The switch is also connected to a 5.1 surround sound speaker system through a toslink cable

My motherboard is a asus prime z270a

I had the above outlined setup with a cheap videocard with no issues. I purchased the GeForce GTX1050Ti but cannot get the audio to play through the surround sound system. The sound will only work through the TV speakers.

I have installed the latest drivers for the video card but with no luck. When I connect the toslink cable directly from the motherboard to the surround sound, I can get surround sound however, I would like to use the switch as I have other devices.

The switch is the following:

4x1 HDMI® Switch w/ TOSlink & Digital Coaxial Audio Output (Audio Return Channel/3D/CEC Support) from Monoprice

The TV is a Samsung smart tv 6290

The surround sound system is Logitech Z-5500 THX-Certified 5.1 Digital Surround Sound Speaker System

The HDMI cable is connected from the graphics card to the switch, then a toslink cable carries it to the surround sound system. When it is in this configuration, I cannot get surround sound to work, it only comes out through the TV speakers.

Any advice would be appreciated.
htpc2402 is offline  
Sponsored Links
Advertisement
 
Reply Receivers, Amps, and Processors

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off