5.2 Channel Denon AVR-S510BT - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 1Likes
  • 1 Post By jdsmoothie
 
Thread Tools
post #1 of 11 Old 09-17-2017, 09:35 AM - Thread Starter
Newbie
 
Join Date: Sep 2017
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 0
5.2 Channel Denon AVR-S510BT

All,

I'm a newbie and trying to setup speaker system in my living room which was pre-wired.
got Denon AVR-S510BT and installed two front, one center, two rear speakers in the wall, and i see 5 input options behind the Receiver for all 5 speakers, but i got two more pre-wired in my patio, i dont see any option to add them into my reciever, not sure, this receiver doesnt support or i'm not able to understand how to do it. would you please take time and explain how it works, since i'm newbie, it is very confising for me.

Thank You All.
manchem is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 09-17-2017, 09:46 AM
AVS Forum Addicted Member
 
jdsmoothie's Avatar
 
Join Date: Sep 2007
Location: Orlando, FL
Posts: 71,842
Mentioned: 386 Post(s)
Tagged: 1 Thread(s)
Quoted: 15365 Post(s)
Liked: 7513
Only Denon 7CH models support Zone 2. The S510BT is only a 5CH model so no Zone 2 support.
Madmax67 likes this.
jdsmoothie is offline  
post #3 of 11 Old 09-17-2017, 09:51 AM - Thread Starter
Newbie
 
Join Date: Sep 2017
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 0
Quote:
Originally Posted by jdsmoothie View Post
Only Denon 7CH models support Zone 2. The S510BT is only a 5CH model so no Zone 2 support.
Thank You for your response.

another quick question, I got sub woofer Polk PSW10 and it has two outs, do i need to use both to the receiver or only one is sufficient, it is saying 1 and 2 outs, not sure what does it mean.

Thank You
manchem is offline  
 
post #4 of 11 Old 09-17-2017, 06:41 PM
AVS Forum Special Member
 
Madmax67's Avatar
 
Join Date: Nov 2015
Location: Mckinney,Texas
Posts: 2,098
Mentioned: 12 Post(s)
Tagged: 0 Thread(s)
Quoted: 846 Post(s)
Liked: 947
Quote:
Originally Posted by manchem View Post
Thank You for your response.

another quick question, I got sub woofer Polk PSW10 and it has two outs, do i need to use both to the receiver or only one is sufficient, it is saying 1 and 2 outs, not sure what does it mean.

Thank You
No dedicated LFE input on the sub so just use the single left white line input on the sub coming from a single sub pre output in the receiver. Either one will do.

You're very welcome.

Chane A5 towers,Chane A2.4 center,RBH bipole side surrounds, Rythmik LV12R x2,Denon X4300H, Outlaw 5000,Front B speakers: Wharfedale Diamond 10.1 books. http://www.avsforum.com/forum/90-rec...d-part-ii.html
Madmax67 is offline  
post #5 of 11 Old 09-17-2017, 06:49 PM
AVS Forum Special Member
 
Madmax67's Avatar
 
Join Date: Nov 2015
Location: Mckinney,Texas
Posts: 2,098
Mentioned: 12 Post(s)
Tagged: 0 Thread(s)
Quoted: 846 Post(s)
Liked: 947
Also without an LFE input you want to make sure to set the subwoofers low pass filter knob to it's highest setting. This allows the receiver to handle the bass management instead of the sub.

Chane A5 towers,Chane A2.4 center,RBH bipole side surrounds, Rythmik LV12R x2,Denon X4300H, Outlaw 5000,Front B speakers: Wharfedale Diamond 10.1 books. http://www.avsforum.com/forum/90-rec...d-part-ii.html
Madmax67 is offline  
post #6 of 11 Old 09-18-2017, 06:47 PM - Thread Starter
Newbie
 
Join Date: Sep 2017
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 0
Quote:
Originally Posted by Madmax67 View Post
Also without an LFE input you want to make sure to set the subwoofers low pass filter knob to it's highest setting. This allows the receiver to handle the bass management instead of the sub.
Thank You for your response, I do appreciate it.
manchem is offline  
post #7 of 11 Old 09-19-2017, 12:03 AM
AVS Forum Special Member
 
Madmax67's Avatar
 
Join Date: Nov 2015
Location: Mckinney,Texas
Posts: 2,098
Mentioned: 12 Post(s)
Tagged: 0 Thread(s)
Quoted: 846 Post(s)
Liked: 947
Quote:
Originally Posted by manchem View Post
Thank You for your response, I do appreciate it.
No problem and good luck.

Chane A5 towers,Chane A2.4 center,RBH bipole side surrounds, Rythmik LV12R x2,Denon X4300H, Outlaw 5000,Front B speakers: Wharfedale Diamond 10.1 books. http://www.avsforum.com/forum/90-rec...d-part-ii.html
Madmax67 is offline  
post #8 of 11 Old 09-19-2017, 06:57 AM - Thread Starter
Newbie
 
Join Date: Sep 2017
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 0
i was able to connect all my speakers and Receiver and able to play using my Iphone through Bluetooth, however my video is not working from any source, i have a old DVD player and Xbox 360, both were working when i connect directly to the TV but when i connect to Receiver audio is working from both and no video showing up, just so you know, both has 3 wires (red,white,yellow)
manchem is offline  
post #9 of 11 Old 09-19-2017, 06:57 AM - Thread Starter
Newbie
 
Join Date: Sep 2017
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 0
any help is appreciated
manchem is offline  
post #10 of 11 Old 09-19-2017, 07:02 AM
AVS Forum Addicted Member
 
jdsmoothie's Avatar
 
Join Date: Sep 2007
Location: Orlando, FL
Posts: 71,842
Mentioned: 386 Post(s)
Tagged: 1 Thread(s)
Quoted: 15365 Post(s)
Liked: 7513
Quote:
Originally Posted by manchem View Post
i was able to connect all my speakers and Receiver and able to play using my Iphone through Bluetooth, however my video is not working from any source, i have a old DVD player and Xbox 360, both were working when i connect directly to the TV but when i connect to Receiver audio is working from both and no video showing up, just so you know, both has 3 wires (red,white,yellow)
The S510BT cannot do analog --> HDMI video conversion. You must also connect a yellow composite video cable from the AVR to the TV.

Please post additional questions in the dedicated Owner's thread linked below.

The "OFFICIAL" 2015 Denon "S-series" / "X-series" AVR Owner's thread + FAQ (HDCP 2.2)

Last edited by jdsmoothie; 09-19-2017 at 07:05 AM.
jdsmoothie is offline  
post #11 of 11 Old 09-19-2017, 07:08 AM - Thread Starter
Newbie
 
Join Date: Sep 2017
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 0
Quote:
Originally Posted by jdsmoothie View Post
The S510BT cannot do analog --> HDMI video conversion. You must also connect a yellow composite video cable from the AVR to the TV.

Please post additional questions in the dedicated Owner's thread linked below.

The "OFFICIAL" 2015 Denon "S-series" / "X-series" AVR Owner's thread + FAQ (HDCP 2.2)
Thank you for the response. next time i will use the thread as you suggested.
manchem is offline  
Sponsored Links
Advertisement
 
Reply Receivers, Amps, and Processors

Tags
patio speakers , pre-wire , receiver

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off