Rotel Owner's Thread - Page 44 - AVS Forum
Forum Jump: 
 3Likes
Reply
 
Thread Tools
post #1291 of 1311 Old 05-20-2014, 08:31 PM
Senior Member
 
hatlesschimp's Avatar
 
Join Date: Nov 2012
Posts: 356
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Liked: 66
With the rotel 1585 should I have the fan set to low or high? Im thinking if I cant hear them why not set it to high.

TV: SONY 65" 4K X900 - AVR: DENON AVR x4000 - AMP: ROTEL RMB 1585 5Ch 200w - OPPO 103D BD PLAYER
CENTRE: KEF Q600c - FRONT L/R: KEF Q900 - WIDE FRONT L/R: KEF Q300
SURROUND L/R: KEF Q800DS's - SURROUND BACK L/R: MINX 21's
SUB: SVS PC13-ULTRA
hatlesschimp is offline  
Sponsored Links
Advertisement
 
post #1292 of 1311 Old 05-21-2014, 02:47 PM
Member
 
jimfrench's Avatar
 
Join Date: Nov 2007
Location: Mount Pearl, NL, Canada
Posts: 90
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by hatlesschimp View Post

With the rotel 1585 should I have the fan set to low or high? Im thinking if I cant hear them why not set it to high.

That sounds logical to me, but how much heat is given off? I opted for the Class D 1575 mostly because of the lesser amount of heat and limited room to place the amp.
jimfrench is offline  
post #1293 of 1311 Old 06-26-2014, 08:51 PM
Member
 
soonerfann's Avatar
 
Join Date: Mar 2003
Location: OKC, OK
Posts: 109
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 11
New 1585, balanced inputs not working

Just installed new 1585 amp with DHC 80.3. No sound coming from any of the 5 speakers when using balanced cables. When I just now tried interconnects, everything works. Is there a switch I'm missing like on my Mac for balanced?
soonerfann is offline  
post #1294 of 1311 Old 06-27-2014, 07:30 PM
Member
 
soonerfann's Avatar
 
Join Date: Mar 2003
Location: OKC, OK
Posts: 109
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 11
My installer got them to work this AM. We aren't sure what we did different other than hook up the interconnects and unhook them to try XLR again? Anyone with balanced audio issues?
Franin likes this.
soonerfann is offline  
post #1295 of 1311 Old 08-15-2014, 04:20 PM
Senior Member
 
motogp34's Avatar
 
Join Date: Oct 2006
Location: Ont. Canada
Posts: 330
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 12
??

anyone know how to calibrate with the rsp-1572 using the eq filters ?
motogp34 is offline  
post #1296 of 1311 Old 09-04-2014, 06:49 AM
CIH USER
 
Franin's Avatar
 
Join Date: Aug 2007
Location: Western Australia
Posts: 17,292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 155 Post(s)
Liked: 212
Quote:
Originally Posted by hatlesschimp View Post
I picked up the Rotel 1585 and damn its big and heavy! Nearly done a hernia! !

Ill post more pictures later and my first impressions.







Hi there how is the Amp preforming? Im looking at getting a pair of these. I was looking at the Yamaha MX-5000 but I found the Rotel RMB 1585 to be 5x200 all channels driven impressive.

_________________________

Frank

Franin is online now  
post #1297 of 1311 Old 09-09-2014, 05:57 AM
CIH USER
 
Franin's Avatar
 
Join Date: Aug 2007
Location: Western Australia
Posts: 17,292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 155 Post(s)
Liked: 212
Very quiet thread

_________________________

Frank

Franin is online now  
post #1298 of 1311 Old 09-09-2014, 07:16 AM
Senior Member
 
hatlesschimp's Avatar
 
Join Date: Nov 2012
Posts: 356
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Liked: 66
Quote:
Originally Posted by Franin View Post
Hi there how is the Amp preforming? Im looking at getting a pair of these. I was looking at the Yamaha MX-5000 but I found the Rotel RMB 1585 to be 5x200 all channels driven impressive.
Does an awesome job. Never had a problem with it! The only bad thing is the SUPER BRIGHT Led power button light. I just stuck a yellow sticky note over it LOL. Seriously I love it and with Dolby Atmos coming it only makes it more relivant for me in the future. Its simple and works. The difference in sound without the Rotel and with it realy is chalk and cheeze.

TV: SONY 65" 4K X900 - AVR: DENON AVR x4000 - AMP: ROTEL RMB 1585 5Ch 200w - OPPO 103D BD PLAYER
CENTRE: KEF Q600c - FRONT L/R: KEF Q900 - WIDE FRONT L/R: KEF Q300
SURROUND L/R: KEF Q800DS's - SURROUND BACK L/R: MINX 21's
SUB: SVS PC13-ULTRA
hatlesschimp is offline  
post #1299 of 1311 Old 09-09-2014, 07:25 AM
CIH USER
 
Franin's Avatar
 
Join Date: Aug 2007
Location: Western Australia
Posts: 17,292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 155 Post(s)
Liked: 212
Quote:
Originally Posted by hatlesschimp View Post
Does an awesome job. Never had a problem with it! The only bad thing is the SUPER BRIGHT Led power button light. I just stuck a yellow sticky note over it LOL. Seriously I love it and with Dolby Atmos coming it only makes it more relivant for me in the future. Its simple and works. The difference in sound without the Rotel and with it realy is chalk and cheeze.
Thats good to read. I was actually looking between the Anthem and the Parasound as well but I was actually considering the Anthem MCA 50 and had ordered them and I cancelled them when I was fortunate to be able to hear the Rotel two channel version and I was blown away. So I ordered a couple of the RMB 1585 so hopefully by the end of the week I should receive them.

_________________________

Frank

Franin is online now  
post #1300 of 1311 Old 09-09-2014, 04:27 PM
Senior Member
 
hatlesschimp's Avatar
 
Join Date: Nov 2012
Posts: 356
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Liked: 66
Good stuff.

Yeah I have no complaints. For me the 1585 just goes about its business.

TV: SONY 65" 4K X900 - AVR: DENON AVR x4000 - AMP: ROTEL RMB 1585 5Ch 200w - OPPO 103D BD PLAYER
CENTRE: KEF Q600c - FRONT L/R: KEF Q900 - WIDE FRONT L/R: KEF Q300
SURROUND L/R: KEF Q800DS's - SURROUND BACK L/R: MINX 21's
SUB: SVS PC13-ULTRA
hatlesschimp is offline  
post #1301 of 1311 Old 09-09-2014, 06:13 PM
Member
 
KaliKid2013's Avatar
 
Join Date: May 2013
Location: USA
Posts: 30
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Liked: 12
Quote:
Originally Posted by hatlesschimp View Post
Does an awesome job. Never had a problem with it! The only bad thing is the SUPER BRIGHT Led power button light. I just stuck a yellow sticky note over it LOL. Seriously I love it and with Dolby Atmos coming it only makes it more relivant for me in the future. Its simple and works. The difference in sound without the Rotel and with it realy is chalk and cheeze.
I am only about 2 years into this hobby, so I am no great source of info.

About a year ago, I had 684 in the front, 686 in the rear, HTM 62 in the front and an ASW 610, all going through an integrated Marantz SR5005.

I replaced that system with the 1585 and the 1572 pre-amp with it, CM10 in the front and rear, the CM2 Center and an ASW12 sub. The 1585 has balanced connections, the 1572 does not, and it should since the 1585 does. I find the quality excellent, more power than I need, clear and uncolored sound.

My dealer loaned me a pair of 804 to try for a week and I saw no reason why I wouldn't also use the 1585 with the 804 if I go that route for my next upgrade.

Last week at a dealer, I did some listening with the 803 and 802, both run through McIntosh equipment and really didn't think the McIntosh did much more than the 1585 is doing. But again, I am fairly new at this and my ears are definitely not as sensitive and knowledgeable as other, more experienced people here.

So take it with a grain of salt.
Attached Thumbnails
Click image for larger version

Name:	IMG_2101.jpg
Views:	38
Size:	98.3 KB
ID:	255138  

B&W CM10 fronts-B&W CM10 rears-CM2 Center-ASWCM12 sub---Rotel RSP-1572 pre-amp-Rotel RMB-1585 amp---Oppo BDP-105 Blu-ray---SurgeX QX515---Samsung UN60H7150---AppleTV---Acoustimac DMD-422 acoustic panels 48"X24"X2" (11) w/ Owens Corning 703.
KaliKid2013 is offline  
post #1302 of 1311 Old 09-09-2014, 09:38 PM
CIH USER
 
Franin's Avatar
 
Join Date: Aug 2007
Location: Western Australia
Posts: 17,292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 155 Post(s)
Liked: 212
Quote:
Originally Posted by KaliKid2013 View Post
I am only about 2 years into this hobby, so I am no great source of info.

About a year ago, I had 684 in the front, 686 in the rear, HTM 62 in the front and an ASW 610, all going through an integrated Marantz SR5005.

I replaced that system with the 1585 and the 1572 pre-amp with it, CM10 in the front and rear, the CM2 Center and an ASW12 sub. The 1585 has balanced connections, the 1572 does not, and it should since the 1585 does. I find the quality excellent, more power than I need, clear and uncolored sound.

My dealer loaned me a pair of 804 to try for a week and I saw no reason why I wouldn't also use the 1585 with the 804 if I go that route for my next upgrade.

Last week at a dealer, I did some listening with the 803 and 802, both run through McIntosh equipment and really didn't think the McIntosh did much more than the 1585 is doing. But again, I am fairly new at this and my ears are definitely not as sensitive and knowledgeable as other, more experienced people here.

So take it with a grain of salt.
Thanks for that. From what I heard I was very impressed. The pic looks great. Not only are they impressive with power they look good too
Franin is online now  
post #1303 of 1311 Old 09-10-2014, 10:23 AM
Advanced Member
 
Blindamood's Avatar
 
Join Date: Oct 2003
Location: South Florida
Posts: 708
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 15
Quote:
Originally Posted by hatlesschimp View Post
The only bad thing is the SUPER BRIGHT Led power button light. I just stuck a yellow sticky note over it LOL.
Rotel also sells a little sticker that fits over the brightly lit ring, to tone it down a bit...you can find it here: http://www.bwgroupusa.com/bwgroup-pa...mmer-ring.html

Brad
Blindamood is offline  
post #1304 of 1311 Old 09-11-2014, 04:54 AM
CIH USER
 
Franin's Avatar
 
Join Date: Aug 2007
Location: Western Australia
Posts: 17,292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 155 Post(s)
Liked: 212
Quote:
Originally Posted by Blindamood View Post
Rotel also sells a little sticker that fits over the brightly lit ring, to tone it down a bit...you can find it here: http://www.bwgroupusa.com/bwgroup-pa...mmer-ring.html
They think of everything
Franin is online now  
post #1305 of 1311 Old 09-14-2014, 01:38 PM
Member
 
Invictus87's Avatar
 
Join Date: Jun 2010
Posts: 39
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 10
Hi, does anyone know the difference between the Rotel RB-1572 and the R-1572V2. I have seen the V2 on the Magnolia AV website but Rotel's site does not distinguish this version. I imagine it was simply some internal upgrades and they just dropped the V2 after a while. Just curious because I read an bad review of the RMB-1575 ICE amp and was just curious when the V2's came out and any differences or improvements. Thanks.

Invictus87 is offline  
post #1306 of 1311 Old 09-16-2014, 08:04 AM
CIH USER
 
Franin's Avatar
 
Join Date: Aug 2007
Location: Western Australia
Posts: 17,292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 155 Post(s)
Liked: 212
Quote:
Originally Posted by soonerfann View Post
My installer got them to work this AM. We aren't sure what we did different other than hook up the interconnects and unhook them to try XLR again? Anyone with balanced audio issues?
yes

_________________________

Frank

Franin is online now  
post #1307 of 1311 Old 09-16-2014, 08:39 AM
CIH USER
 
Franin's Avatar
 
Join Date: Aug 2007
Location: Western Australia
Posts: 17,292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 155 Post(s)
Liked: 212
Quote:
Originally Posted by soonerfann View Post
Just installed new 1585 amp with DHC 80.3. No sound coming from any of the 5 speakers when using balanced cables. When I just now tried interconnects, everything works. Is there a switch I'm missing like on my Mac for balanced?
Ive done what your installers has suggested on one channel and it works on XLR. Why is that doing that?

Does anyone else have this issue?

_________________________

Frank

Franin is online now  
post #1308 of 1311 Old 09-16-2014, 03:46 PM
CIH USER
 
Franin's Avatar
 
Join Date: Aug 2007
Location: Western Australia
Posts: 17,292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 155 Post(s)
Liked: 212
Quote:
Originally Posted by Franin View Post
Ive done what your installers has suggested on one channel and it works on XLR. Why is that doing that?

Does anyone else have this issue?
anyone?? This is actually happening on 2 brand new power amps rmb-1085

_________________________

Frank

Franin is online now  
post #1309 of 1311 Old 09-17-2014, 09:14 AM
CIH USER
 
Franin's Avatar
 
Join Date: Aug 2007
Location: Western Australia
Posts: 17,292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 155 Post(s)
Liked: 212
Found what the issue is. This will be a lesson for all XLR users who decide when buying this pre amp what you need to do. Remove the mini RCA caps. That is what the issue was.

Lesson learned and all good.

_________________________

Frank

Franin is online now  
post #1310 of 1311 Old 09-23-2014, 01:12 AM
Member
 
Vlasto's Avatar
 
Join Date: Nov 2006
Posts: 59
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 17
does anybody has personal experience with RA 1570 ?


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
"Progressive Metal Band"
Vlasto is offline  
post #1311 of 1311 Old 09-23-2014, 09:30 AM
CIH USER
 
Franin's Avatar
 
Join Date: Aug 2007
Location: Western Australia
Posts: 17,292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 155 Post(s)
Liked: 212
Rotel Owner's Thread

I've been using these Amps for a couple of days now. Wow!! I'm impressed.Click image for larger version

Name:	ImageUploadedByTapatalk1411491330.726426.jpg
Views:	19
Size:	190.4 KB
ID:	276185

_________________________

Frank


Last edited by Franin; 09-23-2014 at 09:56 AM.
Franin is online now  
Reply Receivers, Amps, and Processors

Tags
Rotel , Rotel Rsx 1562 , Rotel Rsx 1550 Home Theater Receiver , Rotel Rsp 976 Surround Sound Preamplifier Processor

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off