Receiver Keeps Cutting Out - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 03-10-2007, 05:26 PM - Thread Starter
Newbie
 
OHIO EAGLE's Avatar
 
Join Date: Mar 2007
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I just swapped my Sony DVD player with a newer Sony that upconverts and had HDMI a connection. Now my Sony receiver (5 years old) cuts out on me and the volume won't come back on unless I turn the power off and then on again. The receiver dispays "PROTECT" when this happens. Now I just moved and upgraded to a plasma and a new DVD player( as I already mentioned) and I do not have my 2 rear speakers hooked up yet. Does anyone have any idea what could be causing this. I also bought a new Monster Power Protector, but I still have the same problem even when I don't plug the receiver into it. Sorry for babbling, but I was really hoping not to have to upgrade my receiver and speakers as I have already spent a small fortune on everything else.
-Thanks
Matt
OHIO EAGLE is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 03-10-2007, 05:39 PM
AVS Special Member
 
louthewiz's Avatar
 
Join Date: Oct 2003
Location: Brooklyn U.S.A.
Posts: 4,081
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
It sounds like a short in one of the speaker wires,
Check to see if any connections are touching each other like the pos and neg wires,
Also see if the hdmi is faulty..
louthewiz is offline  
Reply Receivers, Amps, and Processors

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off