Help! My Denon AVR-3805 is shutting off! Flashing Red.. - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 4 Old 07-16-2007, 09:19 AM - Thread Starter
Member
 
jdbizkits's Avatar
 
Join Date: Mar 2005
Location: Valencia, CA (los angeles)
Posts: 78
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have had my Denon 3805 and system running for about 2 years. I have not had any issues and have not touched a thing in a long time. All of a sudden the receiver is going into the protection mode (shutting off and flashing red light) when I turn up the volume a little bit (only to -15db or so...not really loud at all). It seems to only happen on DVD and TV mode. I checked the CD player and I can play it super load for a long time with no issues.

I tried to narrow things down a bit also, by turning off the TV (i am using the component video switching). I also put a plain CD player in the DVD player with no video and it still tripped it.

I shut off the sub/amp, still tripped. I tried dolby digital, pro logic, DTS, and stereo...all tripped. I dont have this issue on my zone 2 setup either.

If anyone can help me out to figure this out that would be great. This is really a bummer and my family is giving me the evil eye since this is the families tv setup and since the video goes through receiver....it kills everything.

Thanks,
JD
jdbizkits is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-16-2007, 09:30 AM
AVS Addicted Member
 
JOHNnDENVER's Avatar
 
Join Date: Dec 2005
Posts: 13,377
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 12
1. Check all speaker wire and re-do all speaker connections. Listen carefully to each driver in each speaker to make sure you do not have a blown driver that you are unaware of.

Still have issues?

2. disconect all speakers and see if the amp stays on

Still have issues?

3. start swap'n speaker connections and see if you can isolate it to one speaker

Still have issues?

Take the AVR in for service.
JOHNnDENVER is offline  
post #3 of 4 Old 07-16-2007, 10:15 AM
AVS Special Member
 
Zen Traveler's Avatar
 
Join Date: Feb 2005
Location: Texas
Posts: 4,372
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 269 Post(s)
Liked: 371
Quote:
Originally Posted by JOHNnDENVER View Post

1. Check all speaker wire and re-do all speaker connections...

I agree with JnD--check this first.
Zen Traveler is online now  
post #4 of 4 Old 07-18-2007, 07:08 AM
AVS Special Member
 
wolfgaze's Avatar
 
Join Date: Feb 2005
Location: The Wood
Posts: 1,151
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
If it does have to go in for Service, you have a Denon Authorized Service Center not too far from where you live:

SCAN AUDIO
8101 ORION AVENUE #7
VAN NUYS, CA 91406 USA
(818) 786-4240



Even though you are out of your warranty, it would be wise to take it to an authorized repair center.
wolfgaze is offline  
Reply Receivers, Amps, and Processors



Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off