Problem w Onkyo SR605 with DVR over HDMI - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 5 Old 11-07-2007, 10:31 PM - Thread Starter
Newbie
 
tommo!'s Avatar
 
Join Date: Jun 2007
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I'm somewhat new at this but learning all the time so please bear with me...

I recently ordered the Onkyo SR-605. On it's arrival, I immediately connected it to my speakers and my PS3, and DVR box. The DVR is a Scientific Atlanta 8300 HD box. Both the PS3 and the DVR box connect to the Onkyo via HDMI cables, my TV is connected to the Onkyo HDMI out. The PS3 connection works perfectly, video and sound are as good as I could hope for.

The problem is I get no sound when I switch to cable. The video is fine, but no sound at all.

A word about my receiver setup:
-I have HDMI monitor on
-I have the HDMI inputs set for the correct input (I do get video)
-I have the Digital sound set for the correct HDMI input

I switched the HDMI cables and the jacks, but the problem persists, the PS3 is fine, the DVR does not work. I will get sound from my TV speakers if I plug the DVR directly into my TV over HDMI. I will also get sound if I turn HDMI Audio Out to "On" in the receiver, though again the sound is only in my TV speakers and does not come through my stereo.

What I ended up doing for the time-being is run a single component cable from the digital audio out on the DVR box to the COAX digital input on the Onkyo, and assigned the audio to go with the cable video feed. This seems to work reasonably well but seems unnecessary.

So my questions to you guys, the experts, are a) am I missing something here, why won't my audio come through HDMI to my speakers?

and

b) With the hack-setup I mentioned above what do I lose? Is this quasi-equivalent or is the quality considerably worse compared to digital audio over HDMI?

Many thanks to everyone, I can't seem to figure this one out!

PS: This seems to be a very similar issue, but nothing mentioned in this thread fixes my problem... I can't post the URL as I am new but it's avsforum.com/avs-vb/showthread.php?p=12120560
tommo! is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 11-08-2007, 06:32 AM - Thread Starter
Newbie
 
tommo!'s Avatar
 
Join Date: Jun 2007
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Also, I recently discovered that I have to toggle the HDMI Audio Out setting when I switch between my PS3 and DVR box. (It must be "OFF" for the PS3, and "ON" for the DVR). Is there anything else I can do to make this less of a hassle?
tommo! is offline  
post #3 of 5 Old 11-15-2007, 12:42 PM - Thread Starter
Newbie
 
tommo!'s Avatar
 
Join Date: Jun 2007
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Update: I am now using sound over RCA cables, assigned to my cable input channel, so I have the video over HDMI, and the sound over these cables.

The only thing I can think of is perhaps my cable box isn't passing the correct encoding for the sound over HDMI, or at least it's not passing what my Onkyo receiver expects.

My only question now is: For HD cable TV, am I losing sound quality by using RCA cables? Am I missing out on additional speaker channels or is RCA adequate? It sounds reasonable to my untrained ears but I want to make sure before I solidify this setup.
tommo! is offline  
post #4 of 5 Old 11-15-2007, 01:02 PM
AVS Addicted Member
 
JOHNnDENVER's Avatar
 
Join Date: Dec 2005
Posts: 13,377
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 12
Yes you are most likely missing out on full DD 5.1 for some content.
I would assume there is an optical or digital coax audio out as well? This would be a better alternate choice if you can't get the HDMI audio going correctly.
JOHNnDENVER is offline  
post #5 of 5 Old 11-15-2007, 01:51 PM
AVS Special Member
 
kplex's Avatar
 
Join Date: Jun 2007
Posts: 3,590
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
First, make sure HDMI Audio = NO. Setting it to YES screws a lot of things up.

Then, I found this with regard to settings for SA 8300 cable box. I don't have one so I don't know if this is relevant or not.

1. Press SETTINGS twice on the remote control to open the General Settings
menu.
2. Press MOVE UP or MOVE DOWN to select the option Audio: Digital Out.
3. Press MOVE RIGHT to select Dolby Digital. This setting will send Dolby
Digital audio to the HDMI, DIGITAL AUDIO OUT, and OPTICAL AUDIO OUT
connectors on the 8300HD.
kplex is offline  
Reply Receivers, Amps, and Processors

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off