HELP! Denon Receiver AVR 1905 only plays stereo. - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 4 Old 08-05-2011, 02:55 PM - Thread Starter
Newbie
 
cherryghost18's Avatar
 
Join Date: Aug 2011
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Bit of an amateur when it comes to the home theater department. I've had the same receiver and simple setup for the past few years: Denon AVR 1905 w/sony speakers and a sub. Recently I took my receiver out of storage, hooked up all the speakers, sub, record player xbox etc. only to find that I can only get sound out of the front L and R speakers when the receiver is set to stereo.

When I switch to 7ch or any other surround mode, silence. No output whatsoever.

I blew a fuse prior to putting it in storage which I just recently replaced with the proper ampage. I blew the fuse when I (stupidly) plugged my vacuum into one of the two power outlets in the back of the receiver. I don't recall if at the time the surround still worked. I know I continued to use the stereo as usual and I think I would have noticed not having surround.

I have reset the microprocessor and still nothing.

Is there a setting I may have accidentally enabled? Is there something I can do at home to diagnose the problem? I know having it serviced and repaired at this point would probably end up running significantly more than I'm able to spend.

I can provide any more information necessary. I'd really love to get this thing back operating, I miss my system. Any help is appreciated.

THANKS!
cherryghost18 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 08-05-2011, 05:17 PM
AVS Special Member
 
BIslander's Avatar
 
Join Date: Jul 2005
Posts: 8,476
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 32 Post(s)
Liked: 123
I suggest you do a factory reset and then play the receiver test tones used to set levels. That will tell you whether the basics of the AVR are working. If so, then try attaching playback equipment.
BIslander is offline  
post #3 of 4 Old 08-05-2011, 05:30 PM
 
schan1269's Avatar
 
Join Date: Apr 2011
Posts: 2,914
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Talk about trying to make your Denon suck...
schan1269 is offline  
post #4 of 4 Old 08-09-2011, 11:56 AM - Thread Starter
Newbie
 
cherryghost18's Avatar
 
Join Date: Aug 2011
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by schan1269 View Post

Talk about trying to make your Denon suck...

thanks for your help
cherryghost18 is offline  
Reply Audio theory, Setup and Chat

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off