Jamo classic4 help/ no bass? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 1 Old 12-07-2012, 07:07 PM - Thread Starter
Newbie
 
newone42's Avatar
 
Join Date: Dec 2012
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi all yesterday set up two Jamo classic 4 speakers for my mains in a 5.1 setup.using a Denon AVR 3802 7.1 receiver 110 per channel. Rears are energy and center is an energy speaker. No sub in use yet.... Savin up! Problem is the Jamo Classic 4 speakers have no bass? Tried test tone and checking if in phase and all is good. But literally they sound like Tim cans at normal listening mode or my listening mode and only seem to get some bass at very high volume levels which well I would go deaf soon if kept at those levels!frown.gif tries to adjust bass to but out more and no difference really? The energy speakers all are producing bass in 5.1 and 5 channel stereo. If I go to just two channel of front mains the bass is gone and speakers sound like in a bucket or something. When I bought them the bass was very nice and not punchy at all and were connected to a lower end receiver than mine but producing good bass? So I know they duel post bindings do I use these and how.... Hope that came out right? So problem no matter what I try to date just no real bass output at all? I must be doing something wrong? Any help or advice or general thought would be truly appreciated and with gratitude since I'm pulling what's left of my hair out.... Only thing I'm accomplishing is bypassing a razor in shaven my head and no help for the bass output problem! Jeez I'm lost here all!
newone42 is offline  
Reply Audio theory, Setup and Chat

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off