Help with audio not sounding blended - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!


Forum Jump: 
 
Thread Tools
Old 09-15-2013, 07:30 PM - Thread Starter
Member
 
nthydro's Avatar
 
Join Date: Dec 2010
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
I'm a noobie so I'm just learning how to setup my audio system. My setup consists of Energy Take Classic 5.1 with a Premier Acoustic PA-10 10" sub and a Denon 1913 receiver.

Problem is the speakers don't seem to blend well with the sub.

Here are my settings:

Fronts & Rears: 120hz
Center: 110hz
Subwoofer: 120hz (crossover on sub set to max)
Phase: 0
Cinama EQ: off
Dynamic Compression: off
Dynamic Volume: light
Dynamic EQ: on

Are my settings adequate? And would I be better off having the sub in front or right next to the sofa? I can also move it in the corner under the desk but the chair is blocking it so I don't know if it'll affect performance. The sub right now sounds too 'localized' so I think moving it up front might help?
nthydro is offline  
Sponsored Links
Advertisement
 
Old 09-20-2013, 01:34 PM
AVS Special Member
 
4DHD's Avatar
 
Join Date: Aug 2004
Location: sierra ecuadoriana
Posts: 6,208
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 204 Post(s)
Liked: 109
With a XO @ 120 the sub needs to be up front, somewhere between the L/R mains. That is b/c any frequency over 80 can be located.

Custom, one of a kind pair, MJC212 mains, mod PT800 center, PT800 surrounds, SUB1500s. Parasound P7, Citation 19, Parasound HCA2205A, HK AVR3600, Marantz TT, Samsung BD player, Denon DVD-A player, MacBook Pro w/ Dirac Stereo Suite.
4DHD is offline  
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off