Boston Acoustics Digital Media 2.1 subwoofer buzz - AVS Forum
Forum Jump: 
 
Thread Tools
Old 11-18-2013, 12:02 PM - Thread Starter
Newbie
 
pawl06's Avatar
 
Join Date: Nov 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

I recently purchased a Boston Acoustics Digital Media 2.1 system w/ powered subwoofer.  When I plug in the power cable to the subwoofer and switch it on, I hear a constant, high-pitched squeal.  The squealing changes frequencies when I plug in, say, the control module.  But when I turn the power switch off and unplug the power cable, I hear the frequency gradually get higher and higher until it completely stops, maybe a minute after cutting all power to the sub.  I've tried moving the sub to a different outlet, but that it still emits the squeal.  I though it might be a problem with the powered subwoofer, but other two-pronged devices in my room make similar noises.  I have an xbox 360 battery charger that makes a ton of noise when plugged in.  Even some of the three-pronged cables, like for the tv and xbox, make a small amount of buzzing noise.  Do you think this is just a grounding issue?  I live in an apartment, so I don't know what I would do to verify this.  

pawl06 is offline  
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off