Center speaker not working with 5.1 speakers - AVS | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!


Forum Jump: 
 
Thread Tools
post #1 of 5 Old 02-28-2014, 10:43 AM - Thread Starter
Newbie
 
nick347b's Avatar
 
Join Date: Feb 2014
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

I'm setting up an older gen 5.1 Creative speaker system for my PC and everything is working great except that no sound, or hardly any sound is coming out of the center channel. When I do an audio test through the Reatek Audio Manager, I can just barely hear it through this channel. I tried swapping channels so the center channel came out of a different speaker and that speaker did the same thing and the middle speaker was fine. I tried boosting it to +10 dB in room correction and nothing changed. Any ideas?

nick347b is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 03-01-2014, 05:53 AM
AVS Special Member
 
Selden Ball's Avatar
 
Join Date: Jan 2001
Location: upstate NY
Posts: 8,644
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 1294 Post(s)
Liked: 690
Exactly what model of speaker system is it?
How is it connected to your computer?

Your symptoms are consistent with either the computer's center channel output being defective or the speaker system's amplifier's center channel input having problems. It could be a bad solder join in the cabling or connectors, for example, or the electronics could be damaged.

Selden

Marantz SR7009+MM9000/Atmos 7.1.4 (FH+TM:DefTech PM1000)/LCR+TM amped
Selden Ball is online now  
post #3 of 5 Old 03-01-2014, 02:43 PM - Thread Starter
Newbie
 
nick347b's Avatar
 
Join Date: Feb 2014
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

Creative Inspire 5.1 5300. It's connected by a 3-wire conjoined cable with male stereo at both ends, green for front speakers, black for rear and orange for center/sub speakers. They're connected to the motherboard which has HD Realtek audio. The sub is working fine, it's just the center speaker that's being weird. Again, it's not completely dead, it's just extremely quiet when I run the audio test and other than that it doesn't emit sound other than soft white noise like the others when I turn them on.

nick347b is offline  
post #4 of 5 Old 03-02-2014, 10:35 AM
AVS Special Member
 
Selden Ball's Avatar
 
Join Date: Jan 2001
Location: upstate NY
Posts: 8,644
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 1294 Post(s)
Liked: 690
It isn't clear from your description which ends of the cables were swapped. If the center speaker still sounds bad when you swap only the connections at the input on the subwoofer, then the problem is in the speaker system, not in the soundcard or cable.

If it is in the speaker system, try swapping the old center speaker's cable at the subwoofer with one of the other speakers' output connection on the subwoofer. If the new center speaker sounds bad, and the old one is OK, then the problem is in the subwoofer and you'll have to get it repaired. If the old one sounds still bad, check its cable carefully. It might be damaged at one end or the other or in the middle. You might be able to fix it yourself.

Selden

Marantz SR7009+MM9000/Atmos 7.1.4 (FH+TM:DefTech PM1000)/LCR+TM amped
Selden Ball is online now  
post #5 of 5 Old 03-02-2014, 11:28 AM - Thread Starter
Newbie
 
nick347b's Avatar
 
Join Date: Feb 2014
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Selden Ball View Post

If it is in the speaker system, try swapping the old center speaker's cable at the subwoofer with one of the other speakers' output connection on the subwoofer. If the new center speaker sounds bad, and the old one is OK, then the problem is in the subwoofer and you'll have to get it repaired.

Yeah this is exactly what happened. Sorry for being unclear. One thing I did notice is that the male input for the center speaker can't physically go in quite as far as the other 4 speaker inputs due to the small circular niche around the female end not being quite as deep as the other four. But if the sub casing was designed like that, I don't see how that could be the problem... but at the same time it seems strange.

nick347b is offline  
Sponsored Links
Advertisement
 
Reply Audio Theory, Setup, and Chat



Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off